OctaneRender™ 2019.1.4

Forums: OctaneRender™ 2019.1.4
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

OctaneRender™ 2019.1.4

Postby abstrax » Mon Nov 11, 2019 7:55 am

abstrax Mon Nov 11, 2019 7:55 am
Hi all,

This release contains more fixes for 2019.1.x. To find an overview of the features of 2019.1 please go here.

Also make sure that you have a NVIDIA driver of version 419.x or higher.


Changes since OctaneRender 2019.1.3:

  • The overhauled auto-bump now supports all projection types and extra UV sets (see viewtopic.php?p=371750#p371750 for an example).
  • Improved auto-bump to preserve sharp edges of the geometry.
  • Fixed crash when you try to render a displacement mixer with an unconnected displacement pin (see viewtopic.php?p=371779#p371779).
  • Fixed toon rendering of bump/normal maps (see viewtopic.php?p=371859#p371859).
  • Fixed problem that a mixed universal material with 1.0 mix factor renders differently to a universal material - when there is some transmission involved.
  • Fixed render artefacts with specular materials that have an IOR between (1 .. 1.00005) (see viewtopic.php?p=371943#p371943).
  • Fixed missing thin film interference if RGB IOR or IOR + color is used in layered materials.
  • Fixed incorrect fake shadow colour if a vertex attribute texture is used in the transmission channel.
  • Fixed environment shadows missing in the general shadow pass.
  • Fixed error "unexpected primitive type 2" when you try to use the baking camera and displacement.
  • Fixed kernel failure if you render accurate rounded edges with the PMC kernel and a baking camera.
  • Fixed exception handling on MacOS which should reduce the delay/freeze during a crash.

Downloads

Downloads for Enterprise subscription users:

OctaneRender Enterprise 2019.1.4 Standalone for Windows (installer)
OctaneRender Enterprise 2019.1.4 Standalone for Windows (ZIP archive)
OctaneRender Enterprise 2019.1.4 Standalone for MacOS
OctaneRender Enterprise 2019.1.4 Standalone for Linux

OctaneRender Enterprise 2019.1.4 Slave for Windows (installer)
OctaneRender Enterprise 2019.1.4 Slave for Windows (ZIP archive)
OctaneRender Enterprise 2019.1.4 Slave for MacOS
OctaneRender Enterprise 2019.1.4 Slave for Linux

Downloads for Studio subscription users:

OctaneRender Studio 2019.1.4 Standalone for Windows (installer)
OctaneRender Studio 2019.1.4 Standalone for Windows (ZIP archive)
OctaneRender Studio 2019.1.4 Standalone for MacOS
OctaneRender Studio 2019.1.4 Standalone for Linux

Demo downloads:

OctaneRender Demo 2019.1.4 Standalone for Windows (installer)
OctaneRender Demo 2019.1.4 Standalone for Windows (ZIP archive)
OctaneRender Demo 2019.1.4 Standalone for MacOS
OctaneRender Demo 2019.1.4 Standalone for Linux


Happy rendering
Your OTOY NZ team
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5153
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby abstrax » Mon Nov 11, 2019 8:25 am

abstrax Mon Nov 11, 2019 8:25 am
PolderAnimation wrote:Very small thing but it says OctaneRender Studio 2019.1.3 instead of 4.

Thanks. Fixed.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5153
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby funk » Mon Nov 11, 2019 1:45 pm

funk Mon Nov 11, 2019 1:45 pm
Thanks team
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 14
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 919
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby J.C » Mon Nov 11, 2019 8:46 pm

J.C Mon Nov 11, 2019 8:46 pm
Thanks for the release!
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPUs: 4xRTX 2080, 2xGTX 980 Ti.
System – Windows 10, Octane 4-2020, Blender Plugin 17.x-21.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 1398
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby funk » Tue Nov 12, 2019 5:58 am

funk Tue Nov 12, 2019 5:58 am
I'm trying to load a previous orbx, which had animated displacement. I noticed that scrubbing the timeline is not updating the displacement now.

1. Load the attached orbx
2. Make sure youre at frame 0, and click the render target to start rendering
3. Look at the "wire" pass, so we can see the displacement clearer
4. Scrub the timeline to frame 60

NOTE: At this point, the displacement is actually wrong. Take a screengrab or copy the image to clipboard so we can use it later for comparison.

5. Press stop
6. Press start to start rendering again

The displacement has now updated and looks correct.

animated_displacement_test.png
You do not have the required permissions to view the files attached to this post.
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 14
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 919
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby WIPEXPO » Tue Nov 12, 2019 8:21 am

WIPEXPO Tue Nov 12, 2019 8:21 am
Hi,
Perpetual license ... when ??
WIPEXPO
Licensed Customer
Licensed Customer
 
Posts: 23
Joined: Tue May 23, 2017 12:37 pm

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby lukas8410 » Tue Nov 12, 2019 10:11 am

lukas8410 Tue Nov 12, 2019 10:11 am
Hi! So I've downloaded the enterprise version, but there is not Daemon to install, so my question is: Is it a change, or mistake?

Thanks!
Luke
// Behance: https://www.behance.net/LukaszKondek //

- Octane v3
- 1x Geforce 980 Ti , and 1x 570 GTX
lukas8410
Licensed Customer
Licensed Customer
 
Posts: 100
Joined: Tue Oct 02, 2012 9:59 am

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby abstrax » Tue Nov 12, 2019 10:51 am

abstrax Tue Nov 12, 2019 10:51 am
lukas8410 wrote:Hi! So I've downloaded the enterprise version, but there is not Daemon to install, so my question is: Is it a change, or mistake?

Thanks!
Luke

Since version 2019.1.2 the slave is distributed in a separate package - see the downloads list in the opening post.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5153
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ 2019.1.4 [current 2019.1.x]

Postby funk » Tue Nov 12, 2019 11:04 am

funk Tue Nov 12, 2019 11:04 am
I'm seeing a new error in the log: "Tried to access null node"

While this is not obvious in standalone, the modo plugin pops up a dialog box every time a log error appears

1. Load the orbx
2. Go to window > create log window
3. Right click the glossy material > render

A log error appears:

Started logging on 12.11.19 21:59:25
OctaneRender Enterprise 2019.1.4 (6000400)
Tried to access null node
You do not have the required permissions to view the files attached to this post.
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 14
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 919
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia
Next

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 2 guests

Tue Oct 27, 2020 10:13 am [ UTC ]