Viewport slow when ipr rendering

Forums: Viewport slow when ipr rendering
Houdini Integrated Plugin

Moderator: juanjgon

Viewport slow when ipr rendering

Postby coresign » Thu Nov 22, 2018 12:22 pm

coresign Thu Nov 22, 2018 12:22 pm
Viewport very slow when IPR rendering, even when I disable the monitor graphic card and use another card to render.
coresign
Licensed Customer
Licensed Customer
 
Posts: 12
Joined: Thu Jun 01, 2017 4:29 am

Re: Viewport slow when ipr rendering

Postby juanjgon » Thu Nov 22, 2018 1:03 pm

juanjgon Thu Nov 22, 2018 1:03 pm
Hi,

Are you sure that after disabling the GPU used for the monitors this problem is still there? Be aware that after changing the GPUs configuration you need to fully close the IPR window and open it again. Reload the scene is not enough to update the GPUs config.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7370
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Viewport slow when ipr rendering

Postby coresign » Thu Nov 22, 2018 1:24 pm

coresign Thu Nov 22, 2018 1:24 pm
Yes, And I try to restart Houdini still not working, viewport frome 120 FPS jump to 8-12FPS when ipr rendering.
coresign
Licensed Customer
Licensed Customer
 
Posts: 12
Joined: Thu Jun 01, 2017 4:29 am

Re: Viewport slow when ipr rendering

Postby juanjgon » Thu Nov 22, 2018 3:48 pm

juanjgon Thu Nov 22, 2018 3:48 pm
coresign wrote:Yes, And I try to restart Houdini still not working, viewport frome 120 FPS jump to 8-12FPS when ipr rendering.

While working with any kind of scene, or even on simple one? Sorry, but I can't reproduce something like that here if the display GPU is disabled, at least with basic scenes. If you can send me your same repro scene I could take a look at it.

Have you double checked that the GPU that you have disabled is the display one?

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7370
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Viewport slow when ipr rendering

Postby coresign » Fri Nov 23, 2018 1:23 am

coresign Fri Nov 23, 2018 1:23 am
I switch to use another graphics card as my monitor display card, fix the problem, pretty weird but thank you very much.
coresign
Licensed Customer
Licensed Customer
 
Posts: 12
Joined: Thu Jun 01, 2017 4:29 am

Re: Viewport slow when ipr rendering

Postby Luther76 » Tue Nov 27, 2018 10:18 pm

Luther76 Tue Nov 27, 2018 10:18 pm
Hello,
I've the same problem. I use Houdini 17 with 4 geforce gtx 1080i on windows 10. I use, with the same PC and the same configuration, also the C4D octane plugin and everythings goes well. So I think there is something wired on this plugins. When I scroll the timeline, the IPR windows refresh very very slow, and also houdini stay freeze for a long time. I've seen also that only one of 4 GPU works...

I've try a heavy scene and a very light one (a plane with a dodecaedron on top) and the problem is tha same.

Any advice and suggestions will be greatly appreciated

Cheers

Paolo
Luther76
Licensed Customer
Licensed Customer
 
Posts: 15
Joined: Fri Mar 24, 2017 3:49 pm

Re: Viewport slow when ipr rendering

Postby juanjgon » Tue Nov 27, 2018 11:23 pm

juanjgon Tue Nov 27, 2018 11:23 pm
Hi,

Some ideas about what could be the problem, but in any case, if you can send me one of these example test scenes, I could take a look at it here to see if I can reproduce this problem here:

1) Check the GPUs configuration to be sure that the display one is disabled, or at least that it has the priority feature enabled and set to low.
2) Check the log file configuration. If you have it enabled to file (or even worse, to the console) it could make the scene update really slow.
3) What is the IPR update mode configuration? Check the attached image. There are four buttons "D", "M", "I" and "V". If enabled that means that the plugin updates the full mesh of all the objects (the "D" update deformations option), all the scene materials (the "M" update materials option), all the instancers at point level (the "I" update instancers option) and all the volume objects (the "V" update volumes option). Can you please check what happens if you disable these four buttons? And if you enable the "Disable Upd." button.

Even in my small laptop with its small MX150 GPU, the scene updating is fast enough to move the timeline without problems, of course, if I disable the deformations update button in complex scenes. Not as fast as working with the IPR disabled, but at least updating several fps.

Thanks,
-Juanjo
Attachments
2018-11-28 00_14_41-Octane IPR.jpg
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7370
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Viewport slow when ipr rendering

Postby Luther76 » Wed Nov 28, 2018 12:16 pm

Luther76 Wed Nov 28, 2018 12:16 pm
Hi Juanjo,
thanks for your reply and for your work.

I try to disable the GPU one and I I swich off all the buttons in the update mode and the IPR work very fine with this configuration with my simple scene (dodecaedron on a grid), but when I reload my heavy scene, the IPR back to work very slowy... In the scene I've a texture HDR and I do not know whether it makes sense but when I turn on the "alpha Channel" in the render menu "boom" everything goes well, the IPR start to work very fast. I hope this can help you for future improvement.

I have a question about the disable GPU: it only concerns the IPR or also the batch render? I've started a batch render and if I see the task manager it seem that only a GPU work... I attach a screenshot of my task manager during the render.

So, thank you very much for all.

Cheers.

Paolo
Attachments
GPU.PNG
Luther76
Licensed Customer
Licensed Customer
 
Posts: 15
Joined: Fri Mar 24, 2017 3:49 pm

Re: Viewport slow when ipr rendering

Postby juanjgon » Wed Nov 28, 2018 12:22 pm

juanjgon Wed Nov 28, 2018 12:22 pm
Luther76 wrote:I try to disable the GPU one and I I swich off all the buttons in the update mode and the IPR work very fine with this configuration with my simple scene (dodecaedron on a grid), but when I reload my heavy scene, the IPR back to work very slowy... In the scene I've a texture HDR and I do not know whether it makes sense but when I turn on the "alpha Channel" in the render menu "boom" everything goes well, the IPR start to work very fast. I hope this can help you for future improvement.


Hmm, perhaps the plugin is reloading and pre-processing the textures for each frame if they are used in the render target environment nodes, even if the "M" materials update option is disabled. This could be possible. I'll check it.

Luther76 wrote:I have a question about the disable GPU: it only concerns the IPR or also the batch render? I've started a batch render and if I see the task manager it seem that only a GPU work... I attach a screenshot of my task manager during the render.


The Windows task manager is not a good tool to measure the GPUs performance while rendering, but in any case, you must select one of the "Compute" modes in the graph drop down menu to at least see something related to the CUDA computing process.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7370
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Viewport slow when ipr rendering

Postby Luther76 » Thu Nov 29, 2018 10:52 am

Luther76 Thu Nov 29, 2018 10:52 am
Hi Juanjo,
I've some updates about my ipr trouble...

Today I open the yesterday's scene and I have the same trouble with the IPR. So I check the configuration (GPU, log file, IPR update mode and also the "render apha" flag) and nothing has been changed.

I noticed at the same time tha the lag was only when the camera's position change. When I move the objects or when I change material settings or when I rotete the HDR texure, the IPR refresh very very fast.


Any advice and suggestions?

Thanks

Paolo
Luther76
Licensed Customer
Licensed Customer
 
Posts: 15
Joined: Fri Mar 24, 2017 3:49 pm
Next

Return to Houdini


Who is online

Users browsing this forum: No registered users and 2 guests

Fri Apr 10, 2020 10:52 am [ UTC ]