Octane Sketchup Exporter - Full 1022-12

Forums: Octane Sketchup Exporter - Full 1022-12
SketchUp Integrated Plugin (Integrated Plugin maintained by OTOY)

Re: Octane Sketchup Exporter - Full 1022-12

Postby Andrew Mitchell » Fri Oct 29, 2010 6:25 pm

Andrew Mitchell Fri Oct 29, 2010 6:25 pm
I'm having an issue with the plugin. Everything exports correctly, however any movement of the camera causes the model to disappear, and not even resetting the camera will bring it back. I have tried it on several different sketchup files from Version 7 and 8 and get the same results, regardless.

I think it has to do with the bounding box of the model that is exported, because if I make a compact model, i.e. a simple plane and box, I don't have the issue. But with scenes with multiple large components and groups, the problem persists. I have tried moving the camera with the slider and numerical inputs, but the instant that i modify it, the mesh disappears.

Tested on:
Sketchup Pro 7 and 8
Vista 64/32, Plugin 1022-12 and Octane Render Beta V5.
Simuviz
Andrew Mitchell
Licensed Customer
Licensed Customer
 
Posts: 42
Joined: Sat May 29, 2010 4:16 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby TIG » Sat Oct 30, 2010 11:11 am

TIG Sat Oct 30, 2010 11:11 am
Andrew

I think your issue isn't with the Sketchup Exporter itself, but rather with Octane Render ?
The SKP model exports OK but then the Octane camera adjustment seems flaky if the model has any complexity...
I haven't heard of this problem before...
Can I suggest that you also post a similar question in the Renderer forum too, as the fix seems to be outside of the Exporter and in Octane itself... :?
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby cropkaarchitects » Mon Nov 01, 2010 12:59 am

cropkaarchitects Mon Nov 01, 2010 12:59 am
Hi Tig!

First of all many thanks for your great work on the exporter!

I have issues with updating/re-exporting the skp model - whenever there are groups / components added to an existsing skp file and the file is exported to obj / mtl all materials in the previosuly saved ocs swap places - they randomly move from one object to another! Even materials added / modified in octane! BTW - the version 2.3 behaves in an even more bizzare way - all materials turn into Default!

Is it necessary to explode everything in the scene before starting the work with Octane, or is there a way to keep groups and components intact?

Thanks!
cropkaarchitects
Licensed Customer
Licensed Customer
 
Posts: 26
Joined: Mon Oct 11, 2010 9:40 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby erik » Mon Nov 01, 2010 1:31 am

erik Mon Nov 01, 2010 1:31 am
Hi,

I'm guessing that what happens there with the "disapearing model" is infact that the origin of the scene is thousands of meters away from the model and when you try to move the camera your model rotates several hundred meters away. Perhaps check both your units, and origin point of the scene. If you have an obj which is in meters and the origin is close or centralised to the model you shouldn't have that sort of problem.
Win8.1 | Quadro + Titan | Xeons & Corei7 | 12 GB etc
User avatar
erik
Licensed Customer
Licensed Customer
 
Posts: 39
Joined: Sun Nov 22, 2009 10:32 pm
Location: New Zealand

Re: Octane Sketchup Exporter - Full 1022-12

Postby TIG » Mon Nov 01, 2010 10:35 am

TIG Mon Nov 01, 2010 10:35 am
Erik's point is very astute!
Since the Octane Camera will default orbit around [0,0,0] you need to have made your SKp with the origin somewhere sensible - e.g. inside it.
You may also have a an imported site mesh that has a small piece of face several miles from the origin which is getting imported too ? Edit the mesh and check its 'bounds' look sensible - try to move it's insertion point axis to somewhere nearby too...
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby Morat » Thu Nov 04, 2010 7:17 pm

Morat Thu Nov 04, 2010 7:17 pm
I've had that issue with the camera, and it only happens if I export the camera in the plugin (Sketchup 8). If I don't export the camera everything works fine.

When the camera is messed up you can't even fix it by setting a focus point manually - Octane ignores it. Do we need to report this on another part of the forum?

Awesome exporter by the way, when I bought Octane I didn't realise it existed. Nice bonus, Refractive should be shouting about it on the features page.
Win 7 64 | Geforce GTX260 1gb | Q6600 @ Stock Speeds | 8GB
Morat
Licensed Customer
Licensed Customer
 
Posts: 57
Joined: Wed Oct 13, 2010 6:38 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby TIG » Thu Nov 04, 2010 7:27 pm

TIG Thu Nov 04, 2010 7:27 pm
Morat

Can you explain exactly what steps you take to break the exported camera.
I can't reproduce it BUT then I have the SKP''s origin inside what I export.

Perhaps a screen=shot or PM me the zipped SKP with an explanation...

There really shouldn't be an issue as the target/eye of the camera get exported in meters just as the rest of the model :?
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby Morat » Thu Nov 04, 2010 7:56 pm

Morat Thu Nov 04, 2010 7:56 pm
I've just tried recreating it and I can't :-(. Pretty much all my Sketchup exports have the wild camera problem. If I find what I did that fixed it I'll PM you the skp.
Win 7 64 | Geforce GTX260 1gb | Q6600 @ Stock Speeds | 8GB
Morat
Licensed Customer
Licensed Customer
 
Posts: 57
Joined: Wed Oct 13, 2010 6:38 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby Morat » Thu Nov 04, 2010 8:11 pm

Morat Thu Nov 04, 2010 8:11 pm
Got one! To reproduce the problem:

Open in Sketchup 8

Hit "render frame" in plugin with camera export disabled - don't change any other settings. The camera will be fine in Octane and you can orbit the vane just fine.

Close Octane

Re-export from Sketchup with camera enabled. The camera in Octane will be FUBAR and cannot be corrected by using a manual focus point selection.
Attachments
Vane Sculpture for ivygen.rar
(379.72 KiB) Downloaded 132 times
Win 7 64 | Geforce GTX260 1gb | Q6600 @ Stock Speeds | 8GB
Morat
Licensed Customer
Licensed Customer
 
Posts: 57
Joined: Wed Oct 13, 2010 6:38 pm

Re: Octane Sketchup Exporter - Full 1022-12

Postby TIG » Thu Nov 04, 2010 8:58 pm

TIG Thu Nov 04, 2010 8:58 pm
Morat

I can't reproduce your supposed problem...

First I modified your SKP a little - all of its the faces are 'inside out - i.e. the back faces are NOT inside the object, but facing outwards - use a Style with a distinctive back-face color... To fix Select a face, Reverse, the Orient - all faces should now be the right way round...
Your default front-face is pure-white too - which doesn't show up too well against the default Octane 'white' background'...

Then I Exported with Camera AND the image's Resolution [so the image a manageable size in Octane] AND the SKP's Lighting so it's at least 'shaded'.

In Octane I see the view I had in SUp rendered in Octane.
I move the camera position in Octane.
I save the Octane's OCS.

I modify the SKP - add geometry etc...

Next I re-export the SKP, but I un-check the 'Camera' option.
Now in Octane I see the view I last had in when I saved the OCS... BUT any other changes to the SKP are seen.

So the camera exported OK the first time then it didn't the second time - as expected.

I adjust some material settings and change the view point again.
I save the OCS.

Next I re-export the SKP... but this time I check the 'Camera' option once more.
Now the OCS render opens with the camera re-set to match the SKp's camera again, however, the changed material settings in the OCS are used as these always override the SKP's exported values...

Can you try these steps and report back - I can see no problem with the steps I outlined :?
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm
PreviousNext

Return to SketchUp


Who is online

Users browsing this forum: No registered users and 3 guests

Wed Oct 21, 2020 7:34 pm [ UTC ]