Itoo animation is not working

Forums: Itoo animation is not working
Sub forum for bug reports
Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Itoo animation is not working

Postby coilbook » Fri Dec 13, 2019 8:35 pm

coilbook Fri Dec 13, 2019 8:35 pm
Well, another bug. Itoo animation tab is not working with this octane version. It seems that they cannot find a balance between no updating static itoo forest the next frame and updating animated itoo forest objects when we need them.
Even when animate at render time is off

UPDATE: 8.12 works and 8.14 doesnt.


This is their change "Fixed Forest pack unnecessary update on frame change."

Please fix it where animated itoo gets updated and static like grass doesn't. I think the issue with grass not showing up when camera is animated related to this bug
Attachments
ddddddddddddddddddddddddddd.jpg
coilbook
Licensed Customer
Licensed Customer
 
Posts: 2588
Joined: Mon Mar 24, 2014 2:27 pm

Re: Itoo animation is not working

Postby neonZorglub » Wed Jan 15, 2020 4:31 am

neonZorglub Wed Jan 15, 2020 4:31 am
Hi coilbook,

Here is a sample from itoo, adapted for Octane:
fp_animation_Exercises_Octane.zip
(116.31 KiB) Downloaded 15 times


The animation mode 'Follow Geometry' works fine as instance (Octane support: 'Direct mode', and FP render mode set as Automatic)
This simply use the animated reference object 'Bend with keyframes' for all instances.

Other animation modes are not specially supported, so you may need to set the FP render mode as Mesh.
See in this sample, the fp_random object uses the 'Random Samples' mode, and it works like that.

I'll try to add better support for other animation modes in the future.
Thanks
neonZorglub
OctaneRender Team
OctaneRender Team
 
Posts: 306
Joined: Sun Jul 31, 2016 10:08 pm

Re: Itoo animation is not working

Postby coilbook » Wed Jan 22, 2020 4:35 pm

coilbook Wed Jan 22, 2020 4:35 pm
neonZorglub wrote:Hi coilbook,

Here is a sample from itoo, adapted for Octane:
fp_animation_Exercises_Octane.zip


The animation mode 'Follow Geometry' works fine as instance (Octane support: 'Direct mode', and FP render mode set as Automatic)
This simply use the animated reference object 'Bend with keyframes' for all instances.

Other animation modes are not specially supported, so you may need to set the FP render mode as Mesh.
See in this sample, the fp_random object uses the 'Random Samples' mode, and it works like that.

I'll try to add better support for other animation modes in the future.
Thanks


I am not sure what you guys did with all these modes. In octane 4 it worked like a charm now it is a cluster mess
coilbook
Licensed Customer
Licensed Customer
 
Posts: 2588
Joined: Mon Mar 24, 2014 2:27 pm

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 0 guests

Fri Apr 10, 2020 10:16 am [ UTC ]