OctaneRender™ Standalone 4.01

Forums: OctaneRender™ Standalone 4.01
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

OctaneRender™ Standalone 4.01

Postby abstrax » Thu Dec 06, 2018 9:08 am

abstrax Thu Dec 06, 2018 9:08 am
Hi all,

This is the second stable release of OctaneRender version 4 fixing various issues that have been reported for 4.00.


License upgrade

Unless you have a subscription license, you will have to upgrade your version 3 licenses to version 4. This upgrade is free and can be done via these 4 steps:

  1. Go to https://home.otoy.com/render/octane-render/purchase/
  2. Select "Upgrade" in the top menu.
  3. Click on "UPGRADE NOW" next to "Upgrade existing licenses to OctaneRender 4".
  4. Select the licenses you want to upgrade and confirm.


New GPU requirements

To use this version, you need a GPU of compute model 3.0 or higher. Support for Fermi GPUs (like GTX 4xx and 5xx) has been dropped. Also make sure you use a driver of version 387 or higher and if you are working on Mac OS that have a CUDA driver installed that supports at least CUDA 9.1.

And if you are working on Windows 7 or 8 we highly recommend to update your driver to version 417.22 or higher. This driver fixes an issue where the CUDA API function calls fail with error 2 (out of memory) even though these API calls don't allocate any memory. See viewtopic.php?f=24&t=69639 for more details.


Changes since version 4.00:

  • Improved the planetary environment by replacing the planetary axis and angle input pins with latitude and longitude pins, to allow you defining the correct orientation of the planet underneath your location that can be matched against the coordinates in the sun direction node.
  • Improved memory management during progressive scene data updates, when out-of-core is used to fix a performance regression observed with various scenes. It was caused by better a utilization of VRAM with a smaller amount of unused GPU memory, but then having to subsequently move new resources to out-of-core because progressive data updates couldn't fit new data.
  • Removed the fast GPU upload which caused issues on systems that connected via PCIe risers/expanders (see viewtopic.php?p=351110#p351110). It didn't make much of a difference in most cases.
  • Refactored the resource tracking of render devices to avoid that some allocations are not accounted for correctly. Also the memory usage and distribution can be quite different for each device. The most visible sign of these changes is the viewport status bar which shows now more detailed scene statistics and memory usage for each device, when you click on it.
  • Fixed CUDA failure in the baking camera when rendering a scene with animated meshes.
  • Fixed hot pixels and incorrect light distributions in scenes with portals that have AI light enabled.
  • Fixed global light exclusion of the environment if the scene contains portals (see viewtopic.php?p=351802#p351802).
  • Fixed clamping of post-effects in the denoised main pass.
  • Fixed artifacts in scenes of scaled meshes that use displacement, which became most visible in the AO info channel kernel.
  • Fixed wireframe rendering when using the baking camera.
  • Fixed incorrect attribute access when a scene with volumes is rendered using the baking camera.
  • Fixed bug that caused the denoiser to not start on the very first frame / render (see viewtopic.php?p=352129#p352129)
  • Fixed incorrect rendering of shadow catcher materials in the denoiser main pass (see viewtopic.php?p=352596#p352596).
  • Fixed filtering out of daemons that run on the same machine as the net render master.


Downloads for users with a regular license
OctaneRender for Windows (installer)
OctaneRender for Windows (zip)
OctaneRender for Mac OS
OctaneRender for Linux

Downloads for users with a Studio subscription license
OctaneRender Studio for Windows (installer)
OctaneRender Studio for Windows (zip)
OctaneRender Studio for Mac OS
OctaneRender Studio for Linux

Demo version downloads
OctaneRender Demo version for Windows (installer)
OctaneRender Demo version for Windows (ZIP archive)
OctaneRender Demo version for Mac OS X (DMG image)
OctaneRender Demo version for Linux (ZIP archive)


Happy rendering,
Your OTOY Team
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5113
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ Standalone 4.01 [current 4.xx]

Postby funk » Thu Dec 06, 2018 1:35 pm

funk Thu Dec 06, 2018 1:35 pm
Thank you.

Your splash screen still shows "Version 4.00"
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 806
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ Standalone 4.01 [current 4.xx]

Postby eklein » Thu Dec 06, 2018 3:24 pm

eklein Thu Dec 06, 2018 3:24 pm
The denoiser still does not initialize or work on RTX 2070 with 4.01. Using Windows 10 and latest Nvidia drivers.

Open the orbx file select render target and the denoiser does not work with all the correct settings (See attach file).

It looks like the issue with the denoiser in the RTX 2070 is that it won't initialize properly when starting with a new scene. Once the IPR is active toggling back and forth the "Denoise volumes" setting then denoiser works. Also toggling denoiser layer settings like "denoised diffuse indirect" makes it work.

Eric
You do not have the required permissions to view the files attached to this post.
eklein
Licensed Customer
Licensed Customer
 
Posts: 48
Joined: Wed Apr 09, 2014 5:59 am

Re: OctaneRender™ Standalone 4.01 [current 4.xx]

Postby abstrax » Fri Dec 07, 2018 12:27 am

abstrax Fri Dec 07, 2018 12:27 am
eklein wrote:The denoiser still does not initialize or work on RTX 2070 with 4.01. Using Windows 10 and latest Nvidia drivers.

Open the orbx file select render target and the denoiser does not work with all the correct settings (See attach file).

It looks like the issue with the denoiser in the RTX 2070 is that it won't initialize properly when starting with a new scene. Once the IPR is active toggling back and forth the "Denoise volumes" setting then denoiser works. Also toggling denoiser layer settings like "denoised diffuse indirect" makes it work.

Eric

We were not able to reproduce the issue here and can't see how this can still happen. Vijay will send you a test build with more logging so we can see what is going on on your system.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5113
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 2 guests

Mon Dec 16, 2019 2:01 am [ UTC ]