OctaneRender™ Standalone 2.26

Forums: OctaneRender™ Standalone 2.26
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

OctaneRender™ Standalone 2.26

Postby abstrax » Fri Oct 21, 2016 4:07 am

abstrax Fri Oct 21, 2016 4:07 am
Hi all,

This is probably the last maintenance update of v2 (unless we broke something important with this release). It adds support for Pascal GPUs and provides various bug fixes that have accumulated over the last months.


Changes since version 2.25:

  • Added support for Pascal and switched from CUDA 6.5 to CUDA 7.5/8.0.
  • Added confirmation to menu item File -> Save as default....
  • Extended the value range of the max. samples pins of the various kernel nodes to 1 .. 1,000,000 and limited the slider range to 1..100,000.
  • Fixed rendering of the object layer ID.
  • Fixed orientation of the tangent vector when the UV coordinate system is left-handed (turning from U to V is clockwise).
  • Fixed incorrect initialization of the shutter time in the render engine after loading a project.
  • Fixed missing geometry update if the shutter time changed and the geometry has vertex speeds, but not animated vertices positions.
  • Made importance sampling of environments numerically more stable and work correctly if it's completely black.
  • Disabled sampling of disabled portals.
  • The render engine will be updated after finishing a Lua script that was rendering a temporary render target.
  • Improved geometry compilation time when a scene loaded from Alembic is re-compiled, due to a time change, but not all meshes are animated.
  • Fixed a bug where partial geometry updates on the slaves were missing to update the extra primitive data, causing the slaves to crash during rendering.
  • Fixed random crashes on Linux, caused by OpenSSL when the DNS lookup timed out.
  • Fixed empty drop down when you pick a material from a mesh with no material names specified.
  • Made sure that the rendered image is displayed sharp at 100% zoom level.
  • Fixed incorrect handling of file names that start with "..".
  • Sped up deletion of multiple items from the node graph editor.
  • The text display of the scatter node will be hidden if the scatter node stores a large number of transformations.
  • Eliminated pop-up dialog when an empty script graph is being copied.
  • Lua: Added octane.gui.createSettingsComponent() to create simple settings components.
  • Lua: Script graphs can now override the default node name via the entry _name.
  • Lua: Added staticPinCount to octane.NODE_ITEM_PROP.
  • Lua: If setting a property for a node item or a GUI component fails, an error is raised.


Downloads:

Windows
- 64-bit commercial version (installer)
- 64-bit commercial version (ZIP archive)

Mac OS X
- 64-bit commercial version (DMG image)

Linux
- 64-bit commercial version (ZIP archive)

Happy rendering,
Your OTOY NZ Team
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5141
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby nuno1980 » Fri Oct 21, 2016 9:57 am

nuno1980 Fri Oct 21, 2016 9:57 am
Good news for 1MS/px. :) But it would be excellent news for continuous (0 as infinity S/px).
NOTE: I'm sorry for bad english due to mute ;)

[email protected]
16GB [email protected]
ASUS Z97-Pro Gamer
EVGA GF GTX 980 Ti SC+ 2.0 :D
SSD OCZ RD400 0.5TB
HDDs 1TB SATA2 and 3TB SATA3.
LG BD-RE BH16NS40
PSU 1 kW
CRT monitor 17"
nuno1980
Licensed Customer
Licensed Customer
 
Posts: 626
Joined: Sat Dec 18, 2010 10:04 pm

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby Notiusweb » Mon Oct 24, 2016 4:03 pm

Notiusweb Mon Oct 24, 2016 4:03 pm
Wow, great support! Thank you for this release :D
Win 10 Pro 64, Xeon E5-2687W v2 (8x 3.40GHz), G.Skill 64 GB DDR3-2400, ASRock X79 Extreme 11
Mobo: 1 Titan RTX, 1 Titan Xp
External: 6 Titan X Pascal, 2 GTX Titan X
Plugs: Enterprise
User avatar
Notiusweb
Licensed Customer
Licensed Customer
 
Posts: 1283
Joined: Mon Nov 10, 2014 4:51 am

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby nuno1980 » Fri Oct 28, 2016 8:32 pm

nuno1980 Fri Oct 28, 2016 8:32 pm
This new version is ~1.24x slower than v2.25 at PMC kernel with parallelism 1. Why?????????????? :? :(
NOTE: I'm sorry for bad english due to mute ;)

[email protected]
16GB [email protected]
ASUS Z97-Pro Gamer
EVGA GF GTX 980 Ti SC+ 2.0 :D
SSD OCZ RD400 0.5TB
HDDs 1TB SATA2 and 3TB SATA3.
LG BD-RE BH16NS40
PSU 1 kW
CRT monitor 17"
nuno1980
Licensed Customer
Licensed Customer
 
Posts: 626
Joined: Sat Dec 18, 2010 10:04 pm

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby abstrax » Fri Oct 28, 2016 11:10 pm

abstrax Fri Oct 28, 2016 11:10 pm
nuno1980 wrote:This new version is ~1.24x slower than v2.25 at PMC kernel with parallelism 1. Why?????????????? :? :(

Don't know. Will have a look at it next week.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5141
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby coon_ra » Sat Oct 29, 2016 4:56 pm

coon_ra Sat Oct 29, 2016 4:56 pm
Are there any specific settings, or version of drivers, or else to make 1080 work in pmc of Octane 2.26? EVGA 1080 FTW failed to render with pmc kernel but works with PT and DL. Same time 580s work fine, just each is about half of 1080 performance.
PS: I got Octane 3.04 Demo, in PMC mode it renders on both current GPUs unlike 2.26 that uses only Geforce GTX 580 in PMC. Any idea how to make 2.26 use 1080 in PMC? Or it is impossible at all?
Asus P9X79 WS, i7-3930K set to 4250mHz, EVGA gtx 1080 FTW DT 8Gb + Zotac gtx 580 amp2! 3gb
coon_ra
Licensed Customer
Licensed Customer
 
Posts: 12
Joined: Wed Apr 18, 2012 8:20 am

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby nuno1980 » Sun Nov 06, 2016 11:08 pm

nuno1980 Sun Nov 06, 2016 11:08 pm
abstrax wrote:Will have a look at it next week.
Do you forget this?
NOTE: I'm sorry for bad english due to mute ;)

[email protected]
16GB [email protected]
ASUS Z97-Pro Gamer
EVGA GF GTX 980 Ti SC+ 2.0 :D
SSD OCZ RD400 0.5TB
HDDs 1TB SATA2 and 3TB SATA3.
LG BD-RE BH16NS40
PSU 1 kW
CRT monitor 17"
nuno1980
Licensed Customer
Licensed Customer
 
Posts: 626
Joined: Sat Dec 18, 2010 10:04 pm

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby abstrax » Mon Nov 07, 2016 3:06 am

abstrax Mon Nov 07, 2016 3:06 am
coon_ra wrote:Are there any specific settings, or version of drivers, or else to make 1080 work in pmc of Octane 2.26? EVGA 1080 FTW failed to render with pmc kernel but works with PT and DL. Same time 580s work fine, just each is about half of 1080 performance.
PS: I got Octane 3.04 Demo, in PMC mode it renders on both current GPUs unlike 2.26 that uses only Geforce GTX 580 in PMC. Any idea how to make 2.26 use 1080 in PMC? Or it is impossible at all?

I had a look and found that it was an oversight during the merge into the v2 branch. I will release an update in the next couple days which will fix this problem.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5141
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ Standalone 2.26 [current 2.xx]

Postby abstrax » Mon Nov 07, 2016 3:09 am

abstrax Mon Nov 07, 2016 3:09 am
nuno1980 wrote:This new version is ~1.24x slower than v2.25 at PMC kernel with parallelism 1. Why?????????????? :? :(

I had a look and the problem was introduced by the switch to the CUDA 7.5+8.0 toolkit combo. I did this because kernels would fail on Pascal with CUDA 6.5+8.0. Unfortunately this seems to break PMC for at least Maxwell. It not only renders slower, but also incorrect. I'm trying to find a solution for this issue.
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5141
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ Standalone 2.26

Postby karanis » Sun Feb 05, 2017 9:42 pm

karanis Sun Feb 05, 2017 9:42 pm
Another VERY important fix for me in Linux is :

Standalone in command line does not need Xserver running anymore.

That was an important fix for me, automating renders with lua etc.

Thanks
Win7 64 & Slackware 14 64 | 3x Zotac 580 amp & 1x MSI 680 | i7 3930K @4.8 | 32 GB | Asus rampage extreme IV
User avatar
karanis
Licensed Customer
Licensed Customer
 
Posts: 79
Joined: Sat Jul 23, 2011 11:21 pm
Location: Ankara / TURKEY
Next

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 2 guests

Tue Aug 11, 2020 5:01 pm [ UTC ]