Xparticles OpenVDB mirrored in VDB volume

Forums: Xparticles OpenVDB mirrored in VDB volume
Maxon Cinema 4D (Export script developed by abstrax, Integrated Plugin developed by aoktar)

Moderator: aoktar

Xparticles OpenVDB mirrored in VDB volume

Postby ounocreative » Wed Feb 28, 2018 12:13 pm

ounocreative Wed Feb 28, 2018 12:13 pm
Having an issue using a fire animation generated in xparticles.

The animation consists of a cube on fire that rotates 360 counter clockwise, I cache the animation to openvdb and load it into a vdb volume. Once I do this however the whole animation is mirrored and rotates the opposite direction.

The xparticles cached preview shows a correct animation with the object and fire rotating correctly however vdb volume is mirroring this instead.

I've tested this in a new file with basic shapes and it does the same thing. Right now my only solution is to cache the fire animation rotating in the opposite direction so its the correct way round once imported into the vdb volume.

I don't know if theres an option I'm missing but I can't see anything related to rotation direction in either xparticles or the vdb volume, perhaps there is something missing with regards to support for files generated in xparticles.

Any thoughts?
Attachments
Screenshot_18.jpg
ounocreative
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Tue Jan 10, 2017 9:16 am

Re: Xparticles OpenVDB mirrored in VDB volume

Postby Loopinglovers » Mon Nov 26, 2018 1:51 pm

Loopinglovers Mon Nov 26, 2018 1:51 pm
Hey Mate,
i just run into the same Problem - did you discover a workflow to fix it allready?
cheers
Loopinglovers
Licensed Customer
Licensed Customer
 
Posts: 3
Joined: Sat Oct 27, 2018 7:48 pm

Re: Xparticles OpenVDB mirrored in VDB volume

Postby aoktar » Mon Nov 26, 2018 1:58 pm

aoktar Mon Nov 26, 2018 1:58 pm
What's up with V4.00 stable?
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12691
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Xparticles OpenVDB mirrored in VDB volume

Postby ounocreative » Thu Apr 25, 2019 12:10 pm

ounocreative Thu Apr 25, 2019 12:10 pm
Hey guys

Wanted to provide an update on this issue as I have recently revisited it and its still present.

This is using the latest version of XParticles and V4.03 of Octane.

It seems to be related to the Z axis. In the this screenshot you can see my animation of smoke trails following some missiles, this is animated along the Z axis using an attractor. However in the Octane viewer you'll notice the exported VDB being rendered completely mirrored to the actual animation.

Screenshot_66.png


In screenshot 2 I have rotated the attractor around to the X axis and rebuilt the cache, this animation seems to render fine in the Octane VDB object, following the same path/size as the previewed ExplosiaFX on the left.

Screenshot_67.png


So it seems to be related to Z axis data, I don't know if Xparticles isn't exporting it correctly or if the Octane VDB volume is not understanding it correctly. For this animation I can rotate everything to animate down the X axis but for things that spin in all axis this isn't going to help and a fix is needed,

Hopefully this info is useful in getting it fixed as Id love to have it work properly.
ounocreative
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Tue Jan 10, 2017 9:16 am

Re: Xparticles OpenVDB mirrored in VDB volume

Postby ounocreative » Thu Apr 25, 2019 4:58 pm

ounocreative Thu Apr 25, 2019 4:58 pm
Still getting mirrored if you're not dead on the 0 point center of the world.

Am I just missing an option somewhere? Or is this just not supported properly?

It's incredibly frustrating.

Screenshot_71.png
ounocreative
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Tue Jan 10, 2017 9:16 am

Re: Xparticles OpenVDB mirrored in VDB volume

Postby aoktar » Thu Apr 25, 2019 5:50 pm

aoktar Thu Apr 25, 2019 5:50 pm
ounocreative wrote:It's incredibly frustrating.


Our VDB loader gives the same results as how R20's vdb loader does.
Attachments
a1.jpg
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12691
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Xparticles OpenVDB mirrored in VDB volume

Postby ounocreative » Fri Apr 26, 2019 9:34 am

ounocreative Fri Apr 26, 2019 9:34 am
Thanks for the reply.

Definitely seems to be Xparticles then. Tried the same thing at work with R20 and the cinema volume builder and I get the same mirrored version. Must be missing an option somewhere or perhaps theres a bug in the openVDB export in Xparticles.

Will post over on the Xparticles forum, see if we can get to the bottom of this.
Attachments
Screenshot_152.jpg
ounocreative
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Tue Jan 10, 2017 9:16 am

Re: Xparticles OpenVDB mirrored in VDB volume

Postby ounocreative » Fri Apr 26, 2019 1:59 pm

ounocreative Fri Apr 26, 2019 1:59 pm
I finally have a solution thanks to the guys over at Insydium.

Entering a value of -1 to the VDB volumes Z axis for size fixes this issue. Fog volume appears in the right place and the right way around!

Also if you're planning on using Xparticles with R20s volume building it requires the same fix in the volume loader along with a negative value in the Y size axis on the volume mesher!

Hopefully this helps others with the same Xparticles issues.
ounocreative
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Tue Jan 10, 2017 9:16 am

Re: Xparticles OpenVDB mirrored in VDB volume

Postby helloimneil » Mon Jun 03, 2019 1:53 am

helloimneil Mon Jun 03, 2019 1:53 am
Thank you so much for sharing your solution. I encountered this today and was incredibly bummed to run into this strange problem/bug. Cheers to you, man! Should our paths ever cross I'll gladly buy you a pint.
helloimneil
Licensed Customer
Licensed Customer
 
Posts: 30
Joined: Sat Apr 01, 2017 9:44 pm

Re: Xparticles OpenVDB mirrored in VDB volume

Postby chrisfranklin6002 » Tue Jun 18, 2019 12:59 pm

chrisfranklin6002 Tue Jun 18, 2019 12:59 pm
Jesus this has been bugging me for so long!!! Nice one!!
chrisfranklin6002
Licensed Customer
Licensed Customer
 
Posts: 9
Joined: Wed Jan 13, 2016 9:23 am

Return to Maxon Cinema 4D


Who is online

Users browsing this forum: Google [Bot] and 12 guests

Mon Dec 09, 2019 9:02 pm [ UTC ]