OctaneRender™ Standalone 4.02

Forums: OctaneRender™ Standalone 4.02
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

OctaneRender™ Standalone 4.02

Postby haze » Wed Jan 23, 2019 12:32 am

haze Wed Jan 23, 2019 12:32 am
Hi all,


This is a medium-sized maintenance update - we have fixed a number of issues that have been reported since 4.01.1 and upgraded OSL as well.


License upgrade

Unless you have a subscription license, you will have to upgrade your version 3 licenses to version 4. This upgrade is free and can be done via these 4 steps:

  1. Go to https://home.otoy.com/render/octane-render/purchase/
  2. Select "Upgrade" in the top menu.
  3. Click on "UPGRADE NOW" next to "Upgrade existing licenses to OctaneRender 4".
  4. Select the licenses you want to upgrade and confirm.


New GPU requirements

To use this version, you need a GPU of compute model 3.0 or higher. Support for Fermi GPUs (like GTX 4xx and 5xx) has been dropped. Also make sure you use a driver of version 387 or higher and if you are working on Mac OS that have a CUDA driver installed that supports at least CUDA 9.1.

And if you are working on Windows 7 or 8 we highly recommend to update your driver to version 417.22 or higher. This driver fixes an issue where the CUDA API function calls fail with error 2 (out of memory) even though these API calls don't allocate any memory. See viewtopic.php?f=24&t=69639 for more details.


Changes since version 4.01.1:

  • fixed a render failure when there are one or more invalid hairs in the scene.
  • added render job output linkers to the context menu.
  • fixed unnecessary shader recompiles when there is an update to a texture.
  • upgraded OSL to version 1.9.13.
  • fixed an uncommon render failure when using baking camera.
  • fixed denoiser not working properly when it is used the first time on RTX cards in one session.
  • fixed internal compilation error when using an OSL shader with a very long parameter list.
  • fixed transform changes not being detected sometimes at shutter open and close.
  • fixed a bug where non-alphanumeric characters in system username could cause cuDNN validation to fail.
  • fixed a case where a script graph would fail to load a required module from an ORBX.
  • fixed very slow geometry processing of some frames, of specific scenes with many instances.
  • fixed a crash from an Xparticles scene.
  • fixed a rare render failure in animated scenes.
  • exported EXRs now contain all information for the Photoshop Compositing plugin so Compositing project files have been removed (requires plugin v1.1.0 or newer).
  • added option to swap order of gamma correction and image color inversion.
  • fixed two random render failures.
  • fixed normals and UVs sometimes not loaded properly from FBX.
  • added subdivision sharpness scale to geometry import settings.
  • fixed a possible crash if loading an HDR with x-direction flipped.
  • fixed unnecessary geometry rebuilds when the camera is deleted.


Downloads for users with a regular license
OctaneRender for Windows (installer)
OctaneRender for Windows (zip)
OctaneRender for Mac OS
OctaneRender for Linux

Downloads for users with a Studio subscription license
OctaneRender Studio for Windows (installer)
OctaneRender Studio for Windows (zip)
OctaneRender Studio for Mac OS
OctaneRender Studio for Linux

Downloads for users with an additional Enterprise All-Access license (excluding subscription All-Access)
OctaneRender Enterprise for Windows (installer)
OctaneRender Enterprise for Windows (zip)
OctaneRender Enterprise for Mac OS
OctaneRender Enterprise for Linux

Demo version downloads
OctaneRender Demo version for Windows (installer)
OctaneRender Demo version for Windows (ZIP archive)
OctaneRender Demo version for Mac OS X (DMG image)
OctaneRender Demo version for Linux (ZIP archive)


Happy rendering,
Your OTOY Team
User avatar
haze
OctaneRender Team
OctaneRender Team
 
Posts: 802
Joined: Sun Feb 08, 2015 8:57 pm

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby funk » Wed Jan 23, 2019 4:03 pm

funk Wed Jan 23, 2019 4:03 pm
Thanks OTOY
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 799
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby PolderAnimation » Wed Jan 23, 2019 5:59 pm

PolderAnimation Wed Jan 23, 2019 5:59 pm
osl raytype "reflection" does not work properly anymore or at least it works different then octane 4.01.
Win 10 64bit | 5 x 1080ti | i7 7700K | 64GB
User avatar
PolderAnimation
Licensed Customer
Licensed Customer
 
Posts: 282
Joined: Mon Oct 10, 2011 10:23 am
Location: Netherlands

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby Refracty » Wed Jan 23, 2019 7:58 pm

Refracty Wed Jan 23, 2019 7:58 pm
Cool, that makes Octane 4 complete. Can't wait for update of the render plugins to upgrade all licenses to V4.
Thank you

3D Animation, Motion Design & CGI Köln
www.lichtblickstudio.com
User avatar
Refracty
Licensed Customer
Licensed Customer
 
Posts: 1583
Joined: Wed Dec 01, 2010 6:42 pm
Location: 3D-Visualisierung Köln

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby roeland » Wed Jan 23, 2019 10:50 pm

roeland Wed Jan 23, 2019 10:50 pm
PolderAnimation wrote:osl raytype "reflection" does not work properly anymore or at least it works different then octane 4.01.


Can you give an example?
User avatar
roeland
OctaneRender Team
OctaneRender Team
 
Posts: 1741
Joined: Wed Mar 09, 2011 10:09 pm

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby PolderAnimation » Thu Jan 24, 2019 8:09 am

PolderAnimation Thu Jan 24, 2019 8:09 am
roeland wrote:
PolderAnimation wrote:osl raytype "reflection" does not work properly anymore or at least it works different then octane 4.01.


Can you give an example?


I will come back to you about this, maybe it has something to do with other parameters. Keep you posted.
Win 10 64bit | 5 x 1080ti | i7 7700K | 64GB
User avatar
PolderAnimation
Licensed Customer
Licensed Customer
 
Posts: 282
Joined: Mon Oct 10, 2011 10:23 am
Location: Netherlands

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby funk » Sat Jan 26, 2019 4:17 am

funk Sat Jan 26, 2019 4:17 am
haze wrote:[*] added option to swap order of gamma correction and image color inversion.


So is this referring to the "linear space invert" option on images? Or something else?
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 799
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby funk » Thu Jan 31, 2019 2:06 am

funk Thu Jan 31, 2019 2:06 am
I've found an issue with clearcoat in the universal material, if you are using GI clamp (it's more noticable if you use a HDRI environment texture with a bright sun or window).

The universal material's roughness is affecting clearcoat amount when it shouldnt be

eg. set Kernel GI clamp = 1.0, universal dielectric IOR = 1.0 and coating= 1.0, then compare roughness 0.0 to 1.0. When roughness is high, the clearcoat is dimmer
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 799
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby funk » Sun Feb 03, 2019 1:59 pm

funk Sun Feb 03, 2019 1:59 pm
I also found a second issue with coating. If you disable "visible to specular" on an emitter, the coating still shows the emitter, but as a very low sample, noisy reflection

If you disable "visible to diffuse", but leave "visible to specular" enabled, you dont see any reflection at all
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 799
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ Standalone 4.02 [current 4.xx]

Postby roeland » Wed Feb 13, 2019 12:59 am

roeland Wed Feb 13, 2019 12:59 am
funk wrote:I've found an issue with clearcoat in the universal material, if you are using GI clamp (it's more noticable if you use a HDRI environment texture with a bright sun or window).

The universal material's roughness is affecting clearcoat amount when it shouldnt be

eg. set Kernel GI clamp = 1.0, universal dielectric IOR = 1.0 and coating= 1.0, then compare roughness 0.0 to 1.0. When roughness is high, the clearcoat is dimmer


That is somewhat expected, if you use GI clamp values that low you'll get all kinds of bias in your rendered images, including too dim specular reflections.
User avatar
roeland
OctaneRender Team
OctaneRender Team
 
Posts: 1741
Joined: Wed Mar 09, 2011 10:09 pm
Next

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 1 guest

Thu Dec 12, 2019 10:52 am [ UTC ]