Losing obj parameters

Forums: Losing obj parameters
Sub forum for bug reports

Moderator: juanjgon

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Losing obj parameters

Postby pasto » Sat Jan 14, 2017 6:17 pm

pasto Sat Jan 14, 2017 6:17 pm
Hello,


I've already evoqued this problem but it is becoming more and more present in my everyday Octane/houdini use.

I've got a huge scene with many objects and many of them have an octane param tab displayed. I crash very often with a strange message of missing parameter or missing brace.
And when I reopen the scene my octane param tab are gone or the UI is totally messed up (several empty tabs with a simple "p" on them), I dont even have the transform fields left on them).
When I try to add the octane params it doesn't work at all. and when I clic on an object I have this long list in the console (it is just a piece of it, it is way longer) :

WARNING: OPUI_DialogPRM2: Symbol "p.helptext" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.helptitle" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.helpurl" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.pmenu" object stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.dragdrop" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.defaultval" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.labeltext" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.expr" value stepped on.

WARNING: OPUI_DialogPRM2: Symbol "p.jive" value stepped on.

etc, etc.

Here is a little part of the scene with an affected object container.

thanx a lot

Jérôme
Attachments
OCTANEproblem.zip
(2.27 MiB) Downloaded 95 times
pasto
Licensed Customer
Licensed Customer
 
Posts: 54
Joined: Wed Apr 30, 2014 8:07 am

Re: Losing obj parameters

Postby juanjgon » Sun Jan 15, 2017 9:53 am

juanjgon Sun Jan 15, 2017 9:53 am
Hi,

To be honest, I've never seen something like that. Are you using any other plugin, or script, or anything else that could add or modify the parameter in the OBJ nodes?

The Octane plugin is using the standard Houdini functions to add spare parameters to the OBJ nodes, and once added no other plugin function is used again to modify these parameters. Really I can't understand how it is possible that this problem could be related to our plugin.

Do you have this problem always after a crash, or you get it just after add the Octane spare parameters? It can be also some kind of corruption in the scene file, but I can't figure how to reproduce it here. Can be even a bug in Houdini, or a side effect of another plugin. I'll think about it.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7575
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Losing obj parameters

Postby pasto » Sun Jan 15, 2017 7:48 pm

pasto Sun Jan 15, 2017 7:48 pm
Do you have this problem always after a crash, or you get it just after add the Octane spare parameters?


Both but just after a crash, when I can't re-open the scene, I must go back to the last backup.

I guess the only add on I use is the Qlib assets library, and It seems to part of the problem. Any clue on this may be ?

Pretty aware of the surralism of this behaviour, I can't see why octane would change the object tab settings !
But it happens only with octane scenes and octane parameters manipulation.

Still investigating, many thanx anyway
pasto
Licensed Customer
Licensed Customer
 
Posts: 54
Joined: Wed Apr 30, 2014 8:07 am

Re: Losing obj parameters

Postby juanjgon » Mon Jan 16, 2017 9:18 am

juanjgon Mon Jan 16, 2017 9:18 am
Do you know if Qlib is adding (or removing) some kind of options, labels or tags to the OBJ nodes? Perhaps this lib has some kind of side effect if used with the Octane plugin OBJ spare parameters. I have seen that Qlib has a python script qLib/scripts/python/qliblabels.py that seems to be related to add/remove tags or options to the nodes, but I am not sure how it works.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7575
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Losing obj parameters

Postby pasto » Mon Jan 16, 2017 3:29 pm

pasto Mon Jan 16, 2017 3:29 pm
I don't really know sorry, but I got tons of python errors anyway, could be that.

Is there any way I could "clean" my scene completely from these param loss behavior ?
I tried to cut/copy the objects in another scene without success.

Thanx a lot

Jérôme
pasto
Licensed Customer
Licensed Customer
 
Posts: 54
Joined: Wed Apr 30, 2014 8:07 am

Re: Losing obj parameters

Postby juanjgon » Mon Jan 16, 2017 6:00 pm

juanjgon Mon Jan 16, 2017 6:00 pm
The Houdini plugin has a command to remove the Octane spare parameters from all the selected nodes. You can select all the OBJ nodes and use the "-ObjParms" shelf tool, but I am not sure how to remove parameters from other plugins.

It is really a weird issue, but I am fairly sure that it is not directly related to the Octane plugin alone. I've no reports about this issue from other users, and I can't reproduce it here. To be honest, I can't figure how our plugin could corrupt your attached scene with the multiple "p" tabs. Must be something else, other plugin or something related to your scene or the Houdini configuration ...

-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7575
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Losing obj parameters

Postby pasto » Tue Jan 17, 2017 5:44 pm

pasto Tue Jan 17, 2017 5:44 pm
ok, thank you, I will try to find out.

Jérôme
pasto
Licensed Customer
Licensed Customer
 
Posts: 54
Joined: Wed Apr 30, 2014 8:07 am

Re: Losing obj parameters

Postby juanjgon » Tue Jan 17, 2017 6:19 pm

juanjgon Tue Jan 17, 2017 6:19 pm
Yes please, if you can get any clue about the source of this problem let me know to try to reproduce it here. A scene corruption is a critical issue that should be fixed if possible.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7575
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Losing obj parameters

Postby Janmansilver » Fri Feb 24, 2017 2:07 pm

Janmansilver Fri Feb 24, 2017 2:07 pm
I've had the same issue, the only other plugin i've used has been redshift, but switched back to octane recently
Janmansilver
Licensed Customer
Licensed Customer
 
Posts: 33
Joined: Wed Apr 22, 2015 3:05 pm

Re: Losing obj parameters

Postby juanjgon » Fri Feb 24, 2017 3:19 pm

juanjgon Fri Feb 24, 2017 3:19 pm
Hmm, one question. Do you remember if you were working with the multi-thread scene extraction feature enabled? I have just remembered an issue related to a bug in the Houdini HDK accessing to the spare parameters from multiple threads. Perhaps this problem is related to this bug.

Anyway, I'll check the plugin code to see if it can be affected by this issue in the HDK.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7575
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain
Next

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 0 guests

Tue Jun 02, 2020 5:59 pm [ UTC ]