OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Forums: OctaneRender 2020 for DAZ Studio [TEST and STABLE]
DAZ Studio (Export Script Plugin developed by Tugpsx; Integrated Plugin maintained by Paul Kinnane)

Moderator: face_off

Forum rules
Please keep character renders sensibly modest, please do not post sexually explicit scenes of characters.

OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby face_off » Wed Dec 11, 2019 5:50 am

face_off Wed Dec 11, 2019 5:50 am
This is the recommended thread for downloading, and posting any questions, suggestions or support queries for OctaneRender for DAZ Studio - TEST (ie. pre-release) and STABLE releases.

SOLUTIONS TO COMMON ISSUES

1) Make sure your NVIDIA drivers are up to date.

2) Make sure you are running the latest version of the OctaneRender for DAZStudio plugin.

3) If you experience a DAZStudio crash - deleting C:\Users\[username]\OctaneRender\Data\OctaneRender_settings.oczdb may resolve the issue. This also resolves the "COULD NOT INITIALISE IN-MEMORY DB!" error on startup and a number of other issues.

4) If the Save button is disabled when using the Final button - disable the Final button and in Render settings select the SuperScope (2:1) Size / aspect ratio and drag the Viewport height or width until you reach required resolution.

5) If rendering an animation fails after 11 frames - make sure the DAZStudio viewport is visible when you render the animation.

6) If Octane materials are not loading when you load a previously saved scene - tick Preferences->Load OctaneRender materials from .duf user presets. If ticking this option does not stick between DAZStudio restarts, delete OctaneRender_settings.oczdb as per NOTE 3 above.

7) If you get a "Could not save a frame for X times!" - please refer to the thread at https://render.otoy.com/forum/viewtopic.php?f=44&t=66258 for potential solutions.

8) If you get a "Bogus Scene Path" error - this is due to having an apostrophe in the filepath of a texturemap (so store your textures in foldernames which do not have apostrophes).

9) Octane panel title bar is off the screen and cannot be closed - click anywhere on the Octane panel and then press Alt-F4.

10) Rendering an animation results in the scene emitter intensities changing - this is because rendering animations is done in "Final" mode, where meshes are merged. To resolve this, UNTICK the Preferences->Use Combined Mesh, or ENABLE the Surface Brightness pin on each of the emission materials in the scene.

11) Denoiser is not working - make sure you have a graphics card selected for Denoising in the System tab->Open Device Settings window, and that you are using the Path Tracing kernel.

12) Render artifacts near eyebrows - this is due to the eyebrow geometry going inside the head mesh surface. So morph, move or scale the eyebrows so they do not intersect with the head mesh.

13) Octane panes do not appear on the screen (ie. they open off the screen) - Main Menu Bar->Window->Workspace->Select Layout->Accept (you might choose a different layout to the current layout to make this work).


KNOWN ISSUES AWAITING RESOLUTION

1) DAZStudio strand hair is not currently supported by the plugin. Some users have been able to get it to render using a workaround, detailed at https://render.otoy.com/forum/viewtopic.php?f=44&t=71635.

2) The Denoised Beauty pass cannot be saved when rendering an animation.

3) Multi-layer render passes cannot be saved when rendering an animation

4) Crash when opening the Viewport with loading scenes into the Octane 2020.1 version of the plugin. This is being investigated by OTOY. The workaround is to open the Viewport on an empty scene and then load the older scene.

5) Visible Environment, Customer LUT, Panoramic camera and OSL nodes are not currently supported.

6) Reloading a scene and then opening the Viewport will not start the render. To get around this, click Pause and then Continue.

7) Smart Unfold is current disabled in the plugin, and will be re-enabled once the issues around this function are resolved.

8) The plugin will not currently Import Materials from ORBX files where there are multiple materials in the ORBX file.

9) Templating is not currently working for specular and roughness maps from Iray materials.

10) UDIM Tiles are not currently supported.

11) Instancing of Grouped items is not currently working correctly.

DAZ Studio Version
DAZ Studio 4.8 or later on Window Vista, 7, 8 or 10 64bit

To use this version, you need a GPU of compute model 3.0 or higher. Support for Fermi GPUs (like GTX 4xx and 5xx) has been dropped. Also make sure you use a driver of version 419.17 or higher.

Network Rendering
For Network Rendering, you must use the Octane slave release from the Octane Standalone installer which matches the exact Octane version of the plugin you are using. This version matches OctaneRender Standalone 4.00.

Support Issues
If you have a support issue, pls provide the following information:
- Operating System (ie. Win XP, Vista, 7, 8)
- Amount of RAM
- Graphics Card(s) - model (ie. GTX 580, 3GB)
- Nvidia driver version
- DAZ Studio version
- OctaneRender for DAZ Studio version (ie. 2.24.2.1)

- The most important part of resolving a problem is me being able to re-produce that problem. So pls provide as much detail as possible in order for me to do this, and if the problem is specific to the scene, send me the scene.

Download Links

Current STABLE build (Octane 2020.1.4)


Previous STABLE build (Octane 2020.1)


Release Notes

2020.1.4.55 (25-Jul-2020)
- Compiled with Octane 2020.1.4

2020.1.0.55 (28-Apr-2020)
- Compiled with Octane 2020.1

2020.1.0.54 (16-Apr-2020)
- Compiled with Octane 2020.1 RC3

2020.1.0.53 (21-Mar-2020)
- Compiled with Octane 2020.1 RC2

2020.1.0.52 (11-Mar-2020)
- Fixed crash and OOC settings problems introduced in 2020.1.0.51

2020.1.0.51 (06-Mar-2020)
- Compiled with Octane 2020.1 RC1
- Removed the setting of the Windows TDR Deley setting when the plugin starts up
- Removed the OOC GPU Headroom slider, as this is now in the Device Settings panel

2020.1.0.50 (22-Jan-2020)
- Compiled with Octane 2020.1 XB3

2020.1.0.49 (30-Dec-2019)
- Compiled with Octane 2020.1 XB2

2020.1.0.48 (18-Dec-2019)
- Fixed crash when clicking the top right menu of the main plugin window
- The NodeGraph Editor now updates to the selected Octane material if a material is selected from Materials tab

2020.1.0.47 (11-Dec-2019)
- Compiled with Octane 2020.1 XB1
- Fix bug which stopped the Enable Plugin and Disable Plugin menu items from working
- Added Kosek-Wilke Daylight Model
- Added the Hair Material node
- Added the Random Walk medium (NOTE: If you enable Lock Step Length Pins on any of the Mediums, the Volume Shadow Ray Step Length will override the Volume Step Length)

Paul
Last edited by face_off on Sat Jul 25, 2020 12:42 am, edited 26 times in total.
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14091
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby Sorel » Wed Dec 11, 2019 2:32 pm

Sorel Wed Dec 11, 2019 2:32 pm
Downloaded before I went to bed last night, excited to give it a go after work.
User avatar
Sorel
Licensed Customer
Licensed Customer
 
Posts: 181
Joined: Tue Feb 25, 2014 5:22 pm

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby Kanne » Wed Dec 11, 2019 7:34 pm

Kanne Wed Dec 11, 2019 7:34 pm
The first's tests are sobering. Same scene rendered with 2019.2, 2020XB1 and 2020XB1 with RTX.
In the 2020XB1 without RTX the eyebrows went missing, eye reflections are gone and seems between surfaces appear visible. With RTX enabled there are more issues but i think i already read in the main 2020XB1 thread there is an issue with universal materials and transmission. From render passes the error appears in the diffuse layers.

===============================
Second Problem (SOLVED)
Missing Eyebrowse and Eye-Reflection due to Surface Material Filter reset in Preferences after plugin update.

First Problem (SOLVED):

I've tried to render a scene from 2019.2 but it just returns a greyish noise on the diffuse channel, everything else is just black. The octane log says its trying to access an invalid pin, P_FILM_SETTINGS. Which pin is this? is it a node on the materials or in the settings? Can i reset this somehow? I've got the current NVidea treiber 441.xxx and i'am using 2 RTX 2070. I've already deleted the OctaneRender_settings.oczdb file and restarted. I tried it with and without RTX enabled.

Code: Select all
20:07:20.758: +++++ Plugin running.
20:10:07.998: Tried to access null node
20:10:07.998: Tried to access pin via an invalid ID P_FILM_SETTINGS (311)
20:10:07.998: Tried to access null node pin
20:10:07.998: Tried to access null node
20:10:07.998: Tried to access pin via an invalid ID P_FILM_SETTINGS (311)
20:10:07.998: Tried to access null node pin


A fresh scene renders fine.

Nevermind. Got it. Had to toggle between Viewport Size and Render Setup
Attachments
FirstTest_2020XB1.jpg
Last edited by Kanne on Fri Dec 13, 2019 3:30 pm, edited 1 time in total.
Kanne
Licensed Customer
Licensed Customer
 
Posts: 44
Joined: Wed Mar 06, 2019 5:51 pm

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby face_off » Thu Dec 12, 2019 12:29 pm

face_off Thu Dec 12, 2019 12:29 pm
In the 2020XB1 without RTX the eyebrows went missing, eye reflections are gone and seems between surfaces appear visible. With RTX enabled there are more issues but i think i already read in the main 2020XB1 thread there is an issue with universal materials and transmission. From render passes the error appears in the diffuse layers.
Sorry you had these issues. I have not made any code changes that would effect this issues, so I can only guess that they are related to Octane 2020.1. It would be interesting to see if you remove (or disable) all geometry other than the eyes - are the reflections still missing in 2020.1, but present in 2019.1? In which case, is this issue reproduced in Octane Standalone if you export the scene (with just the eyes) to .ORBX.

May I suggest if you have differences like you are seeing, try to export just the effected geometry in the 2019 and 2020 version of the plugin, and see if the problems are reproduced in Octane Standalone. If this is the case, we can track down the problem more easily.

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14091
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby Kanne » Thu Dec 12, 2019 3:12 pm

Kanne Thu Dec 12, 2019 3:12 pm
face_off wrote:
In the 2020XB1 without RTX the eyebrows went missing, eye reflections are gone and seems between surfaces appear visible. With RTX enabled there are more issues but i think i already read in the main 2020XB1 thread there is an issue with universal materials and transmission. From render passes the error appears in the diffuse layers.
Sorry you had these issues. I have not made any code changes that would effect this issues, so I can only guess that they are related to Octane 2020.1. It would be interesting to see if you remove (or disable) all geometry other than the eyes - are the reflections still missing in 2020.1, but present in 2019.1? In which case, is this issue reproduced in Octane Standalone if you export the scene (with just the eyes) to .ORBX.

May I suggest if you have differences like you are seeing, try to export just the effected geometry in the 2019 and 2020 version of the plugin, and see if the problems are reproduced in Octane Standalone. If this is the case, we can track down the problem more easily.

Paul


Thank your for your response and offer to have a look into it. As soon as i have time i will dig deaper into it and provide more information.
Kanne
Licensed Customer
Licensed Customer
 
Posts: 44
Joined: Wed Mar 06, 2019 5:51 pm

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby osiosiosi » Thu Dec 12, 2019 8:55 pm

osiosiosi Thu Dec 12, 2019 8:55 pm
Really nice u did such an early build @Paul :-)

Thank you!


About this problem with eyeybrows and other hair not showing. I allready had this happen with earlyer octane versions. Thats nothing new.

However .. i never could pin down why this was happening.
osiosiosi
Licensed Customer
Licensed Customer
 
Posts: 58
Joined: Tue Oct 18, 2016 9:40 am

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby face_off » Thu Dec 12, 2019 10:31 pm

face_off Thu Dec 12, 2019 10:31 pm
About this problem with eyeybrows and other hair not showing. I allready had this happen with earlyer octane versions. Thats nothing new.
Ah yes, you are right. Was it something to do with the parenting of the mesh, or a prop that was attached to the head?

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14091
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby OneManVN » Fri Dec 13, 2019 12:08 am

OneManVN Fri Dec 13, 2019 12:08 am
Issues with loading scene. I suspect the cause is the scene was created in the previous stable version 2019.1.4.46 I have yet to try creating a scene with 2020. The only workaround right now is to save scene as "Scene subset" open a new scene fire it up, then drag and drop the scene subset in it. I've tried all known methods of troubleshooting. At least I can still work with it. Hopefully, the next build sorts it out.

PS: I can't post the scene do to NDA.
OneManVN
Licensed Customer
Licensed Customer
 
Posts: 7
Joined: Mon Jun 03, 2019 12:25 am

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby osiosiosi » Fri Dec 13, 2019 12:33 am

osiosiosi Fri Dec 13, 2019 12:33 am
face_off wrote:
About this problem with eyeybrows and other hair not showing. I allready had this happen with earlyer octane versions. Thats nothing new.
Ah yes, you are right. Was it something to do with the parenting of the mesh, or a prop that was attached to the head?

Paul


Cant be the head alone. I had this with all bodyheair that was fibre. I remember one could make it sort of visible when setting the rayepsylon to a crazy wrong value ... but everything else was "broken" then.

I am sure it had nothing to do with applyed shaders or maps cause i tryed to change those.

For me it happend all the sudden in scenes i had allready rendered fine before. Without changing anything inside the scene.

But a time ago it was all ok again (no idea why) ... didnt show since then.
osiosiosi
Licensed Customer
Licensed Customer
 
Posts: 58
Joined: Tue Oct 18, 2016 9:40 am

Re: OctaneRender 2020 for DAZ Studio [TEST and STABLE]

Postby face_off » Fri Dec 13, 2019 3:06 am

face_off Fri Dec 13, 2019 3:06 am
I am sure it had nothing to do with applyed shaders or maps cause i tryed to change those.


Could be https://render.otoy.com/forum/viewtopic.php?f=44&t=62180&p=317855&hilit=brows#p317855 too?

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14091
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia
Next

Return to DAZ Studio


Who is online

Users browsing this forum: No registered users and 4 guests

Thu Aug 06, 2020 7:35 am [ UTC ]