Cannot install Plugin to Rhino 6

Forums: Cannot install Plugin to Rhino 6
Rhino 3D (Export script developed by SamPage; Integrated Plugin developed by Paul Kinnane)

Moderator: face_off

Cannot install Plugin to Rhino 6

Postby dohyoungkims » Wed May 30, 2018 2:06 pm

dohyoungkims Wed May 30, 2018 2:06 pm
I have rhino 5 and 6 installed on my work laptop.
Rhino 5: Version 5 SR14 64-bit (5.14.522.8390, 5/22/2017)
Rhino 6: Rhino 6 SR5 2018-5-23 (Rhino 6, 6.5.18143.7081

Octane 3 Plugin for Rhino is installed and running for Rhino 5
but I cannot get the Plugin for Rhino 6 installed. I do not want to uninstall the plugin for Rhino 5 because plugin for Rhino 6 is unstable at the moment.

When I drag "OctaneRenderForRhino6_3_08_0_91.rhi" or (3_08_0_88.rhi) to Rhino 6, I get a error message that says:
"This package is not compatible with the Rhino Installer Engine. You may need to update to the latest Rhino Service Release to use this plugin."
Also tried opening it through "C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe" but no received the same error message.

However, when I darg "OctaneRenderForRhino5_3_7_0_87.rhi" to Rhino 6, the installation works but it says:
"OctaneRenderForRhino is about to be installed for Rhino 5.0" and not Rhino 6.

Anyone have this issue or is there a post about this somewhere that I missed?

Thanks,
Win 10 64Bit | Geforce GTX 980 TI HYBRID x 2 | i7 6700K | 32GB
dohyoungkims
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Wed Nov 25, 2015 2:57 pm

Re: Cannot install Plugin to Rhino 6

Postby face_off » Wed May 30, 2018 11:56 pm

face_off Wed May 30, 2018 11:56 pm
Is it possible you have the Rhino5 and Rhino6 installers mixed up? You shouldn't be able to install a Rhino5 plugin into Rhino6.

Also - I built the installer with Rhino6 SR3, so perhaps try that version of Rhino if you can find it. I will be doing a SR5 version of the plugin in the next few days too - which may resolve your issue.

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13428
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: Cannot install Plugin to Rhino 6

Postby dohyoungkims » Thu May 31, 2018 2:41 pm

dohyoungkims Thu May 31, 2018 2:41 pm
Hey Paul, thank you for the prompt reply.

I made sure that I that I used the correct version (Rhino 6) for the installer.

I can't install Rhino 6 R3 at this time so I will wait until the R5 version of the installer is released. Hopefully, that will resolve the issue.

Thanks Paul!
Win 10 64Bit | Geforce GTX 980 TI HYBRID x 2 | i7 6700K | 32GB
dohyoungkims
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Wed Nov 25, 2015 2:57 pm

Re: Cannot install Plugin to Rhino 6

Postby face_off » Fri Jun 01, 2018 6:13 am

face_off Fri Jun 01, 2018 6:13 am
Can you pls try the TEST release 3.08.1.92 and tell me if it fixes your issues. It was built with Rhino6 SR4, so may not with with SR5 (which is the beta test version I believe).

Thanks

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13428
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: Cannot install Plugin to Rhino 6

Postby dohyoungkims » Fri Jun 01, 2018 1:53 pm

dohyoungkims Fri Jun 01, 2018 1:53 pm
Paul, sorry but no luck!

See attached screenshot.

The version I have is :
Version 6 SR5
(6.5.18149.14421, 5/29/2018)
Commercial

Here is the release notice dated May 30, 2018 : https://discourse.mcneel.com/t/rhino-6- ... able/64056
Attachments
Capture.JPG
Win 10 64Bit | Geforce GTX 980 TI HYBRID x 2 | i7 6700K | 32GB
dohyoungkims
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Wed Nov 25, 2015 2:57 pm

Re: Cannot install Plugin to Rhino 6

Postby face_off » Wed Jun 06, 2018 10:58 pm

face_off Wed Jun 06, 2018 10:58 pm
See attached screenshot.

The version I have is :
Version 6 SR5
(6.5.18149.14421, 5/29/2018)
Commercial

Here is the release notice dated May 30, 2018 : https://discourse.mcneel.com/t/rhino-6- ... able/64056
I just posted a new build of 3.08.1.92 in the release thread, which was compiled with RHino6 SR5. Can you pls try it?

Thanks

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13428
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: Cannot install Plugin to Rhino 6

Postby dohyoungkims » Mon Jun 11, 2018 5:31 pm

dohyoungkims Mon Jun 11, 2018 5:31 pm
Paul,

It is very strange. I tested from my home computer and I have no issues installing the plugin. However, I am still running into the same error on my work-laptop...(not compatible)

Any ideas?
Win 10 64Bit | Geforce GTX 980 TI HYBRID x 2 | i7 6700K | 32GB
dohyoungkims
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Wed Nov 25, 2015 2:57 pm

Re: Cannot install Plugin to Rhino 6

Postby Striebel » Mon Jun 11, 2018 7:25 pm

Striebel Mon Jun 11, 2018 7:25 pm
Hi, had the same issue. Couldn't install plugin for Rhino 6 version OctaneRenderForRhino6_3_08_1_92.
After deleting Rhino 5 from my system and trying to drag the plugin to Rhino 6 I saw it was trying to call Rhino 5, in Rhino 5 install folder.
*.*rhi seemed to be liked to wrong version of Rhino. Repaired Rhino 6 installation, dragged plugin to Rhino 6 and it worked. (with Rhino5 deinstalled)
hope I could help
(maybe it also works if you just link *.*rhi to Rhino 6, I didn't try this yet)
Striebel
Licensed Customer
Licensed Customer
 
Posts: 1
Joined: Wed Jun 06, 2018 9:57 am

Re: Cannot install Plugin to Rhino 6

Postby face_off » Tue Jun 12, 2018 12:04 am

face_off Tue Jun 12, 2018 12:04 am
Thanks. I am reasonably certain that this is a Rhino6 installation bug - so if you continue to have issues - try the McNeel forums, where there are a few threads on addressing issues like this.

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13428
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: Cannot install Plugin to Rhino 6

Postby dohyoungkims » Thu Jun 14, 2018 5:31 pm

dohyoungkims Thu Jun 14, 2018 5:31 pm
Paul,

after uninstalling all rhino versions, I installed rhino 6 first (6.3) and then updated the service release to 6.5, and then installed the plug-in and it worked.
Afterwards, I installed rhino 5 and the plugin, and it now works flawlessly on both versions.

Thanks!!!!
Win 10 64Bit | Geforce GTX 980 TI HYBRID x 2 | i7 6700K | 32GB
dohyoungkims
Licensed Customer
Licensed Customer
 
Posts: 11
Joined: Wed Nov 25, 2015 2:57 pm
Next

Return to Rhinoceros 3D


Who is online

Users browsing this forum: No registered users and 1 guest

Sun Sep 22, 2019 6:12 pm [ UTC ]