Light Reflection

Forums: Light Reflection
Newtek Lightwave 3D (exporter developed by holocube, Integrated Plugin developed by juanjgon)

Light Reflection

Postby Rob49152 » Fri May 17, 2019 11:33 pm

Rob49152 Fri May 17, 2019 11:33 pm
So I have a few octane lights in a scene. Some behind a glass surface and some in front.

I have them all set to 'unseen by camera' as I don't want to see the lights emitters. Just the lighting they are casting like in invisible light-bulb.
If the index of refraction of the glass is greater than 1.0 I see the light emitter shapes through the glass. I also see the reflection of the 'in front' light emitter shape on the glass itself, but I don't see the emitter.

If the index of refraction is 1.0 or smaller it works as expected and I don't see the emitters or their reflections.

I am using the path tracing kernal but it also happens with the PMC kernal.

Is this a bug? or am I missing some setting?
CPU: 2x E5-2687W (2x 8 cores + HT = 32 threads @ 3.2GHz+) MOBO: ASUS Z9PE-D8 WS OS:Win7 Ult
RAM: 64gb HD:Revo 3 x2, 240 OCZ SSD, 4TB WD BLACK Website: http://www.interocitor-media.com/tardis
Rob49152
Licensed Customer
Licensed Customer
 
Posts: 48
Joined: Tue Mar 12, 2013 12:23 am
Location: Saskatoon, Sk, Canada

Re: Light Reflection

Postby juanjgon » Sat May 18, 2019 6:13 pm

juanjgon Sat May 18, 2019 6:13 pm
Hi,

I think that this is an Octane limitation, or perhaps even the expected behavior. The problem is that the unseen by camera feature hides the objects from the camera rays, but once a ray hit a transparent surface with refraction it becomes a refracted ray, missing the camera ray status, so this ray is not affected by the unseen by camera flag.

Have you tried to change the dissolve parameter of these emitters to see if it helps?

-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 6951
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Light Reflection

Postby Rob49152 » Sat May 18, 2019 8:58 pm

Rob49152 Sat May 18, 2019 8:58 pm
By 'dissolve perameter' do you mean the Shape Opacity on the light settings panel? If so the answer is no it doesn't.
I made a quick test scene.
glass_render.jpg


- all lights are set to unseen by camera
- top row of lights (yellow, cyan, purple) are in front of the glass. Closer to the camera
- bottom row of lights (red, green, blue) are behind the glass. Further away from the camera.
-the amount of refraction on the glass does change the visibility of the reflected lights (top) but not the lights behind the glass (bottom)
- the middle pane of glass is set to iof=1.15
Last edited by Rob49152 on Sat May 18, 2019 9:05 pm, edited 1 time in total.
CPU: 2x E5-2687W (2x 8 cores + HT = 32 threads @ 3.2GHz+) MOBO: ASUS Z9PE-D8 WS OS:Win7 Ult
RAM: 64gb HD:Revo 3 x2, 240 OCZ SSD, 4TB WD BLACK Website: http://www.interocitor-media.com/tardis
Rob49152
Licensed Customer
Licensed Customer
 
Posts: 48
Joined: Tue Mar 12, 2013 12:23 am
Location: Saskatoon, Sk, Canada

Re: Light Reflection

Postby Rob49152 » Sat May 18, 2019 9:04 pm

Rob49152 Sat May 18, 2019 9:04 pm
here's when I changed the left pane of glass IoR to 1.0001
glass_render01.jpg

the red light instantly becomes visible. Also the GPU ram used stats at the bottom change and actually go down while the CPU ram jumps up.
CPU: 2x E5-2687W (2x 8 cores + HT = 32 threads @ 3.2GHz+) MOBO: ASUS Z9PE-D8 WS OS:Win7 Ult
RAM: 64gb HD:Revo 3 x2, 240 OCZ SSD, 4TB WD BLACK Website: http://www.interocitor-media.com/tardis
Rob49152
Licensed Customer
Licensed Customer
 
Posts: 48
Joined: Tue Mar 12, 2013 12:23 am
Location: Saskatoon, Sk, Canada

Re: Light Reflection

Postby juanjgon » Mon May 20, 2019 10:09 pm

juanjgon Mon May 20, 2019 10:09 pm
Hmm, yes, I see. In this case, the only solution that comes to my mind is to disable the light "Affect Specular" parameter. With this parameter disabled and the shape opacity set to 0.0, the lights should be invisible for the refracted rays, but the problem is that this light is not going to affect the specularity of any scene surface, so not sure if this could help.

And the other solution that you could try is to disable the light for glass objects using the Light Pass Mask feature (that you can find the LWOctane custom object properties plugin). You could group all the lights inside a pass and disable them for the glass objects.

Hope it helps,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 6951
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Return to Lightwave 3D


Who is online

Users browsing this forum: No registered users and 2 guests

Thu Oct 17, 2019 7:16 am [ UTC ]