GPU efficiency and

Forums: GPU efficiency and
Blender (Export script developed by yoyoz; Integrated Plugin developed by JimStar)

GPU efficiency and

Postby protovu » Wed Jan 16, 2019 11:01 pm

protovu Wed Jan 16, 2019 11:01 pm
Hi Guys,
Please forgive the compound nature of this question. I suspect the problems may be related.
I recently upgraded my Dual Xeon to Win10 from 7.
Not sure I am seeing the render speeds I need.

With no priority selected, you will see that I have a very strange activity spread between my GPUs. Really only 1 GPU at work. This is for both the Preview and the Render.

When the Preview Render finishes, it looks correct, and denoised (denoise not shown as I wanted to capture the GPU information in action).

Why is there almost no GPU activity on 3 of my GPUs? (see lower image)
-------------
Separately, and this may be a bug: When Rendering (not preview) the message "Please enable denoise in current camera imager first!" flashes. I do have it enabled in the Spectral AI Denoiser panel..(see upper image).
Then, even though the lighting starts out correctly, it seems the HDRI drops out.

Thank you for advice and help,
Rick
Attachments
denoise.PNG
blenderOctaneGPUquestion.png
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm

Re: GPU efficiency and

Postby J.C » Thu Jan 17, 2019 12:15 am

J.C Thu Jan 17, 2019 12:15 am
Hi Rick,

did you switch your GPU's usage to compute mode in task manager?

If "Please enable denoise in current camera imager first!" appears you probably have a enoiser pass enabled while it is not enabled in Camera Imager settings.
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti,1xGTX 970
System – OS X 10.12.6, Windows 10, Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 712
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: GPU efficiency and

Postby protovu » Thu Jan 17, 2019 12:31 am

protovu Thu Jan 17, 2019 12:31 am
Hi J.C.,
Thank you for responding quickly. Ticking the Camera Imager box in the "N"shortcut panel did the trick. What a difference! Thank you.

I did nothing in the Task Manager, other than look at the graphs. I don't see any settings to control there regarding any settings. Only the ability to observe.
Are you saying I am supposed to switch my GPUs to compute mode?

And I am only really seeing 1 GPU at work during the render.

Rick
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm

Re: GPU efficiency and

Postby protovu » Thu Jan 17, 2019 1:16 am

protovu Thu Jan 17, 2019 1:16 am
J.C.,

Separately, is there a way to enable denoise/beauty in Preview? And a way to toggle it on and off?

Thank you,
Rick
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm

Re: GPU efficiency and

Postby J.C » Thu Jan 17, 2019 9:57 am

J.C Thu Jan 17, 2019 9:57 am
protovu wrote:J.C.,

Separately, is there a way to enable denoise/beauty in Preview? And a way to toggle it on and off?

Thank you,
Rick


Rick, check this out how to measure your GPUs workload:
https://www.quora.com/How-can-I-detect- ... et-and-CPU
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti,1xGTX 970
System – OS X 10.12.6, Windows 10, Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 712
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: GPU efficiency and

Postby J.C » Thu Jan 17, 2019 10:19 am

J.C Thu Jan 17, 2019 10:19 am
protovu wrote:J.C.,

Separately, is there a way to enable denoise/beauty in Preview? And a way to toggle it on and off?

Thank you,
Rick


To use denoiser in preview you need to enable denoiser in Camera imager preview, lower the interval, adjust denoiser samples, uncheck denoise at completion... then enable preview pass type in passess to Denoiser Beauty.

The information on those settings:
https://docs.otoy.com/StandaloneH_STA/S ... noiser.htm
Attachments
denoiser preview.jpg
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti,1xGTX 970
System – OS X 10.12.6, Windows 10, Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 712
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: GPU efficiency and

Postby protovu » Thu Jan 17, 2019 5:19 pm

protovu Thu Jan 17, 2019 5:19 pm
Thank you, JC!

Rick
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm

Re: GPU efficiency and

Postby protovu » Sat Jan 19, 2019 9:26 pm

protovu Sat Jan 19, 2019 9:26 pm
Hi JC,

Rendering is going pretty well in the Preview, but encountering render stops with many of the following over and over during camera adjustments or shader adjustments:

Server error|Error in Render-server at address "127.0.0.1".
Not connected|No Render-server at adress "127.0.0.1"
Less often: Error binding on socket TCP port 5130 which seems related specifically to the RS.

Then I need to get out of render preview and reboot the Octane Server.

____________________________
Separate question on Octane device settings, as I am encountering terrible sluggishness, even typing this....
what is a good strategy?



Your advice appreciated,
Rick
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm

Re: GPU efficiency and

Postby J.C » Sun Jan 20, 2019 9:49 am

J.C Sun Jan 20, 2019 9:49 am
Hi Rick

What's your system configuration? What octane plugin version are out using?
To see more what's going on there is an Octane log window below the devices settings.

The best practice in using GPUs is to use one that drives the monitor and the rest assign to octane.
If you want to use all devices you may accounter less system responsiveness and freezes. You can also change the render priority to a selected device so it won't work at full speed.
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti,1xGTX 970
System – OS X 10.12.6, Windows 10, Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 712
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: GPU efficiency and

Postby protovu » Sun Jan 20, 2019 10:13 pm

protovu Sun Jan 20, 2019 10:13 pm
monitorsgpu.PNG

Hi JC,
Thank you for thew best practices information. I will give it a try. Does the attached look correct?
Computer seems pretty slow even typing this message.

My system:
Win10 64bit
Dual Xeon
32 GB RAM

GeForce...GTX 970, 980ti , 2 x Titan X's
protovu
Licensed Customer
Licensed Customer
 
Posts: 280
Joined: Thu Sep 11, 2014 7:30 pm
Next

Return to Blender


Who is online

Users browsing this forum: No registered users and 1 guest

Sat Feb 23, 2019 1:21 am [ UTC ]