Cinema 4D version 4.02.1-R3 (Obsolete stable)

Forums: Cinema 4D version 4.02.1-R3 (Obsolete stable)
Sub forum for plugin releases

Moderator: aoktar

Cinema 4D version 4.02.1-R3 (Obsolete stable)

Postby aoktar » Sat Feb 09, 2019 9:53 am

aoktar Sat Feb 09, 2019 9:53 am
Hi All,
This is the latest stable release of the plugin which is based on V4.02.1 SDK and matches OctaneRender Standalone 4.02.1. To learn more about the new features and improvements of OctaneRender 4, please check out our blog post.

License upgrade
Unless you have a subscription license, you will have to upgrade your version 3 licenses to version 4. This upgrade is free and can be done via these 4 steps:

Go to https://home.otoy.com/render/octane-render/purchase/
Select "Upgrade" in the top menu.
Click on "UPGRADE NOW" next to "Upgrade existing licenses to OctaneRender 4".
Select the licenses you want to upgrade and confirm.

To use this version, you need a GPU of compute model 3.0 or higher. Support for Fermi GPUs (like GTX 4xx and 5xx) has been dropped. Also make sure you use a driver of version 387 or higher and if you are working on Mac OS that have a CUDA driver installed that supports at least CUDA 9.1.

IN ANY CRASH CASE PLEASE DO THESE!!!
If you see CUDA errors follow 1,2,3,4.
1- Try different drivers, some of them could cause instability issues. Do a clean install while doing this to be sure previous files completely removed.
2- Check gpu frequency. Overclocking would cause instability issues
3- Check PSU. Insufficient power output would cause instability issues
4- Check the free amount of GPU's VRAM and system's RAM while working. Low VRAM will/may cause CUDA errors. Be aware of some generator objects will have different triangle count in Picture Viewer than Live Viewer. It’s like “editor/render” parameter. Just try to use same value. Also try to optimise your scene for polygon count, even use smaller images. Try to use Octane texture nodes rather than using C4D texture/shaders.
Alternatively, use V4 and Out-of-core(OOC) function. Increase RAM for OOC and It should not exceed physical RAM amount. Check TDR value and increase if it's necessary.
5- If you see C4D crashes without CUDA errors, then send us bugreport.zip, screen-shots and video capture to show process and crash moment. Also please send us a sample scene in a format of C4D or ORBX to let us investigate and test it. Alternatively, try to delete/hide some objects/materials until crash gone away. If you find what's causing crashes, send us a sample scene to let us for
investigating and bring a fix or solution.
Thanks for helping the development by your feedbackst! It’s impossible to quickly catch every case without user feedbacks! It’s the same procedure as other companies do like Maxon/etc...


Changes of V4.02.1-R3
- Fix: brdf type in octane materials come from old scenes.
- Fix: Missing parts for saved blend material in livedb.
- Fix: Render pause with denoising passes if you don't select denoiser in active camera which have enabled Imager.

Changes of V4.02.1-R2
- Single file saving for render layers with Octane-EXR file type by using exr compressions. Added half-float support
- Added full support for relative path names in renderpasses
- Fix: search function of livedb manager
- Fix: Brdf change issue with V1/V2 materials on V4. viewtopic.php?f=85&t=70622#p356762

Changes of V4.02.1
- Better log outputs
- Missing light render passes(directs/indirects)
- Bugfix: crash on exportORBX command if you don't have LiveViewer on startup layout
- commandline/nogui support on -exportORBX commandline parameter
- UDIM(Image Tiles texture) support
- Missing DeMain pass in Octane-EXR option
- Extended connection api for 3rd parties
- Fix: Wrong parameter list in Imagetexture -> "texture import type". It's fixed for some cases.
- Several minor fixes in plugin and core side(See standalone topic)

Changes of V4.01.1-R1
- Better display performance in LiveViewer
- Fix: Only displaying the vram stats for gpu0
- Minor speed improvement on scene preparation in animation rendering
- Fix: Show in Picture Viewer command
- Fix: Missing clones order in Scatter object with CSV mode
- Fix: Missing default value in Triplanar's coordinate space

Changes of V4.01.1
Fix: Texture tangent and some info passes in render settings
- Planetary environment.
- Orbx proxy object. Video: https://vimeo.com/302046063
- Fix: Unrecognized channel names in vdb file. viewtopic.php?f=30&t=69481#p350342
- No need to activate denoiser from SettingsWindow or cameraImager for getting denoising passes working in Picture Viewer
- Fix: Missing network render option for Studio builds.
- Fix: Wrong swap for objects/lights in Picture Viewer rendering when you have visibility animations.
- Fix: Extra beauty/denoising passes with RenderLayerMasks. viewtopic.php?f=86&t=68995
- Minor fixes over 4.00

Standalone
viewtopic.php?f=24&t=70612

WINDOWS REGULAR BUILD (R16-R20)
https://render.otoy.com/customerdownloa ... R3-win.rar

WINDOWS SUBSCRIPTION(Studio) BUILD (R16-R20)
https://render.otoy.com/customerdownloa ... R3-win.rar

OSX REGULAR BUILD (R15-R20)
https://render.otoy.com/customerdownloa ... Macosx.zip

OSX SUBSCRIPTION(Studio) BUILD (R15-R20)
https://render.otoy.com/customerdownloa ... Macosx.zip

Requirements:
-You'll need to update your Cinema 4D to latest versions(min. R16.050, R17.053, R18.057, R19.053, R20.028)
-Internet connection for activation, be sure that C4D and Octane will not be blocked by firewall and any antivirus software.
-Updated Nvidia drivers at least 388.xx, recommended 417.22 or 419.17 (one of most recent with Cuda 9.1) and be carreful with latest drivers which can cause cuda errors. Avoids to use 418.81.
-Cuda 9.1 driver for OSX.

ONLINE HELP MANUAL
Use embedded help buttons from Octane nodes and windows

To use OFFLINE version of manual from plugin
Download following package and extract to Cinema4D/plugins/c4doctane/manual
https://render.otoy.com/plugindownloads ... p-html.zip

V3 SAMPLE SCENES SET(make a request if you need any spesific sample)
https://render.otoy.com/plugindownloads ... scenes.rar

resource file for R15. Extract and replace old "c4doctane/res" directory with this.
res.rar
(7.23 MiB) Downloaded 55 times


See this topic for some partial samples: viewtopic.php?f=85&t=53989

CINEMA 4D TUTORIALS SECTION: viewforum.php?f=87

CHANGE LOG: https://docs.otoy.com/#60Change%20log


Installation
First remove all octane related stuff from plugins and main folder of Cinema4D.

Extract all files to Cinema4D\plugins\c4dOctane directory.
Also download manual.zip and extract to c4dOctane directory if it's not available in place.

There are a few files for each one is for different Cinema4D version. Remove all except the file is for your version.
Ex. if you have Cinema4D R18.0, keep only "c4dOctane-r18.cdl64" and delete c4dOctane-r17.cdl64, c4dOctane-r16.cdl64, c4dOctane-r15.cdl64, etc..

Cinema 4D Release 15: c4dOctane-r15.cdl64 or c4doctane_R15_demo.dylib
Cinema 4D Release 16: c4dOctane-r16.cdl64 or c4doctane_R16_demo.dylib
Cinema 4D Release 17: c4dOctane-r17.cdl64 or c4doctane_R17_demo.dylib
Cinema 4D Release 18: c4dOctane-r18.cdl64 or c4doctane_R18_demo.dylib
Cinema 4D Release 19: c4dOctane-r19.cdl64 or c4doctane_R19_demo.dylib
Cinema 4D Release 20: c4dOctane-r20.xdl64 or c4doctane_R20_demo.xlib

ORBX EXAMPLE VIDEO
https://vimeo.com/302046063

Node sliders
https://vimeo.com/268974364

Viewport rendering mode
https://vimeo.com/265747658
https://vimeo.com/265294205
Last edited by aoktar on Wed Apr 24, 2019 1:36 am, edited 16 times in total.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12456
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby Kalua » Sat Feb 09, 2019 4:34 pm

Kalua Sat Feb 09, 2019 4:34 pm
Thank you, Aoktar, for the release.
There is a Vectron buttom in the bottom of the "objects" tab in the live viewer window. I tried to use it and it just freezed C4D: I assume is a mistake to have this option in this version right?
Another small thing: V1 and 2 shaders versions migrated to V4 won't have WARD, GGX or Beckmann BRDF models recognized.
Other than that it seem s to work just fine. Image texture node in shader preview is so far working fine.
Cheers!
C4D 20.059 Octane 2018.3 R2 l 3x 1080 l Windows 10, i7-3770K, 32 GB RAM l NVIDIA SD 431.86
https://www.behance.net/PaperArchitect
User avatar
Kalua
Licensed Customer
Licensed Customer
 
Posts: 127
Joined: Fri Oct 11, 2013 2:13 am
Location: Caribbean Sea

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby TonyBoy » Sat Feb 09, 2019 6:39 pm

TonyBoy Sat Feb 09, 2019 6:39 pm
Hi Ahmet,
to be clear there id no longer any support for C4D 15? Sticking to 4.01.1 will still give some good renders. It's been a good ride, thanks!

Regards,
Tony
TonyBoy
Licensed Customer
Licensed Customer
 
Posts: 227
Joined: Thu Dec 13, 2012 4:47 pm

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby mrpinoux » Sat Feb 09, 2019 7:40 pm

mrpinoux Sat Feb 09, 2019 7:40 pm
- Bugfix: crash on exportORBX command if you don't have LiveViewer on startup layout
- Extended connection api for 3rd parties

double - x 2 - to remove
Win 8.1 64 | Geforce GTX780 x 4 | i7 5960X | 64GB
User avatar
mrpinoux
Licensed Customer
Licensed Customer
 
Posts: 56
Joined: Tue Sep 30, 2014 8:51 pm
Location: Los Angeles

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby aoktar » Sat Feb 09, 2019 10:15 pm

aoktar Sat Feb 09, 2019 10:15 pm
TonyBoy wrote:Hi Ahmet,
to be clear there id no longer any support for C4D 15? Sticking to 4.01.1 will still give some good renders. It's been a good ride, thanks!

Regards,
Tony

I notified R15 has crash at start and didn't want to hold version for that. I don't have any idea what causes that. I'll try to find and make a build.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12456
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby aoktar » Sat Feb 09, 2019 10:19 pm

aoktar Sat Feb 09, 2019 10:19 pm
Kalua wrote:Thank you, Aoktar, for the release.
There is a Vectron buttom in the bottom of the "objects" tab in the live viewer window. I tried to use it and it just freezed C4D: I assume is a mistake to have this option in this version right?
Another small thing: V1 and 2 shaders versions migrated to V4 won't have WARD, GGX or Beckmann BRDF models recognized.
Other than that it seem s to work just fine. Image texture node in shader preview is so far working fine.
Cheers!

Sorry for that! I had a little time to build and got some problems to fix. I'll make a fix.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12456
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby thanulee » Sat Feb 09, 2019 11:20 pm

thanulee Sat Feb 09, 2019 11:20 pm
Thanks alot mate!!
i7 3930K | 2 x GTX 980 ti 6gb | 32GB RAM | Corsair Carbide 540
R18 | win 10 home
thanulee
Licensed Customer
Licensed Customer
 
Posts: 454
Joined: Sat Dec 19, 2015 11:00 pm

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby aoktar » Sun Feb 10, 2019 12:09 am

aoktar Sun Feb 10, 2019 12:09 am
thanulee wrote:Thanks alot mate!!

Enjoy it! Regards!
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12456
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby aoktar » Sun Feb 10, 2019 10:00 am

aoktar Sun Feb 10, 2019 10:00 am
Kalua wrote:Another small thing: V1 and 2 shaders versions migrated to V4 won't have WARD, GGX or Beckmann BRDF models recognized.


There was no any of these models in V2/V1
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12456
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Cinema 4D version 4.02.1(Latest stable) 09.02.2019

Postby sbstnc » Sun Feb 10, 2019 1:33 pm

sbstnc Sun Feb 10, 2019 1:33 pm
Behaviour is the same as 4.01 versions, C4D interface can't be used when LV is on.

Mac OSX 10.12.6, CUDA 387.178, GPU 378.05.05.25f01
2 x 1080Ti, C4D R20

Any scene with a decent amount of geo and textures, say 4-gb VRAM.
It's like C4D stops while LV updates. As soon as LV refreshes with new samples, C4D becomes responsive for a split second, before stopping again while LV thinks some more.

What's going on please. This has only happened since 4 on a machine where nothing else has changed for 18 months. Updating 10.12.6 from 10.12.4 and new drivers has not worked. I have work to get out and I can't press a damn button.
LV on prevents any sort of viewport navigation. Can't pan, can't move around, because C4D is only responsive for 0.01 seconds every 3 seconds. Pause the LV (if you can manage to press the pause button in that 0.1second) then magically the viewport becomes super fluid and response, can pan all over, tons of geo, no problems. LV back on... can't click anything, C4D too slow, LV just keeps trying to refresh refresh, it's like LV is sucking up all system resources, but looking at stats, on an 8core C4D is 100% of 1 core and memory is fine.

I'm pretty frustrated now.

Edit: looks like some max users posting the same thing, RC7 OK but 4 onward no good.
viewtopic.php?f=80&t=70062&p=355577#p355577
viewtopic.php?f=81&t=70257&p=355087&hilit=+lv+refresh+time+#p355087
Is it core that's the problem? If so why?
sbstnc
Licensed Customer
Licensed Customer
 
Posts: 116
Joined: Mon Jul 25, 2016 1:21 am
Next

Return to Releases


Who is online

Users browsing this forum: ccpenn and 2 guests

Tue Oct 15, 2019 6:55 am [ UTC ]