OctaneRender™ 2020.1 XB3 [superseded by 2020.1 RC1]

Forums: OctaneRender™ 2020.1 XB3 [superseded by 2020.1 RC1]
A forum where development builds are posted for testing by the community.
Forum rules
NOTE: The software in this forum is not %100 reliable, they are development builds and are meant for testing by experienced octane users. If you are a new octane user, we recommend to use the current stable release from the 'Commercial Product News & Releases' forum.

OctaneRender™ 2020.1 XB3 [superseded by 2020.1 RC1]

Postby mojave » Sun Jan 19, 2020 11:08 pm

mojave Sun Jan 19, 2020 11:08 pm
Dear all,

We are happy to share our third experimental build of Octane 2020.1 As with all experimental software please do not use this for production purposes.

This release includes a large number of bug fixes and improvements including most of what haves been reported by you in previous builds. There are still some outstanding issues that could not make it to this release but we are making good progress and they should be coming in the next release. Thank you all for your support.

Should you find any issues with this release please report using this thread so we can make sure we provide you with the best feedback.

Make sure to use a NVIDIA Studio driver with version at least 435.80 for Windows or 435.12 for Linux to enable RTX support. There are no OSX drivers that currently support RTX.

2020.1 RC1 has superseded this build.

Changes since OctaneRender 2020.1 XB2:

New features:

  • Added float and color attributes support for hair primitives including alembic export/import.
  • Added support for vertex attribute export/import using FBX.
  • Added ability to hide specific object layers from being evaluated by dirt.

Improvements:

  • Minor UI improvements in the preferences panel.
  • Memory optimizations when using the built-in denoiser.
  • Minor performance improvements for hair and displacement geometry.

Bugfixes:

  • Fixed 100% transparent object casting shadow on a SSS material.
  • Fixed issue causing dirt to work just with the bottom level material when using composite materials.
  • Fixed issue causing some scenes using autofocus with RTX to miss some geometry.
  • Fixed GPU illegal memory access increasing shutter time from zero when using RTX.
  • Fixed network rendering when the master runs on OSX and uses either Windows or Linux slaves.
  • Fixed GPU invalid memory access when using auto-bumpmap with RTX geometry.
  • Fixed issue causing geometry to disappear when using a baking camera after switching render targets.
  • Fixed albedo for hair when the intersected primitive is not a hair primitive.
  • Fixed potential cause for artefacts in pixels which rays would be coplanar to quad primitives.
  • Fixed FBX export crash when the scene contains only hair or sphere primitives and no polygons.
  • Fixed issue in the way memory usage was tracked showing it continuously increasing.
  • Fixed issue with auto bump map which was not working properly on the universal material layers.
  • Fixed issue in auto bump map's plane size calculation which was causing wrong results.
  • Fixed issue that was causing geometry to disappear when using a displacement texture with zero height.
  • Fixed scenario in which auto bump would produce results hardly noticeable.
  • Fixed crash when using some OSL shaders including some OSL geometry.
  • Fixed issue causing full rebuilds after updating scatter nodes.
  • Fixed incorrect light sampling when using a a mix of RTX primitives and other primitive types.

TODO:

  • Accurate rounded edges shader support with RTX.
  • Dirt shader support with RTX.


Downloads

Downloads for Enterprise subscription users:

OctaneRender Enterprise 2020.1 XB3 Standalone for Windows (installer)
OctaneRender Enterprise 2020.1 XB3 Standalone for Windows (ZIP archive)
OctaneRender Enterprise 2020.1 XB3 Standalone for Linux
OctaneRender Enterprise 2020.1 XB3 Standalone for OSX

OctaneRender Enterprise 2020.1 XB3 Slave for Windows (installer)
OctaneRender Enterprise 2020.1 XB3 Slave for Windows (ZIP archive)
OctaneRender Enterprise 2020.1 XB3 Slave for Linux
OctaneRender Enterprise 2020.1 XB3 Slave for MacOS

Downloads for Studio subscription users:

OctaneRender Studio 2020.1 XB3 Standalone for Windows (installer)
OctaneRender Studio 2020.1 XB3 Standalone for Windows (ZIP archive)
OctaneRender Studio 2020.1 XB3 Standalone for Linux
OctaneRender Studio 2020.1 XB3 Standalone for OSX


Happy rendering
Your OTOY NZ team
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 1106
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby funk » Mon Jan 20, 2020 6:29 am

funk Mon Jan 20, 2020 6:29 am
Thanks team
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 14
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 880
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby nejck » Mon Jan 20, 2020 8:34 am

nejck Mon Jan 20, 2020 8:34 am
Indeed, thank you! It is always nice to see progress :)
nejck
Licensed Customer
Licensed Customer
 
Posts: 156
Joined: Fri Sep 28, 2018 5:24 am

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby linograndiotoy » Mon Jan 20, 2020 8:54 am

linograndiotoy Mon Jan 20, 2020 8:54 am
I've installed the Enterprise version (Win10). When I launch it I see the splash page, then nothing happens, it doesn't start.
linograndiotoy
OctaneRender Team
OctaneRender Team
 
Posts: 536
Joined: Thu Feb 01, 2018 7:10 pm

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby funk » Mon Jan 20, 2020 9:38 am

funk Mon Jan 20, 2020 9:38 am
I think something related to online licensing is causing problems.

If I use the studio version, it shows the splash screen, then it hides and nothing shows up. Octane doesnt start up.

If I use the enterprise version with my dongle, it works
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 14
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 880
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby mojave » Mon Jan 20, 2020 10:29 am

mojave Mon Jan 20, 2020 10:29 am
Thank you for the feedback, it seems that some updates required for this version have not been deployed to some of our servers. We will let you know when the problem is fixed.
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 1106
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby linograndiotoy » Mon Jan 20, 2020 10:42 am

linograndiotoy Mon Jan 20, 2020 10:42 am
Thanks!
linograndiotoy
OctaneRender Team
OctaneRender Team
 
Posts: 536
Joined: Thu Feb 01, 2018 7:10 pm

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby SSmolak » Mon Jan 20, 2020 10:48 am

SSmolak Mon Jan 20, 2020 10:48 am
Yes, it doesn't start. Only splash screen is show.

Is this version support NV Link memory pooling for RTX 2080ti ? viewtopic.php?f=33&t=73237&p=374876&hilit=NVlink+memory+pooling+doesn%27t+work#p374876
---------------------------------------
Architectural Visualizations
www.atlantis-arts.com
User avatar
SSmolak
Licensed Customer
Licensed Customer
 
Posts: 156
Joined: Sat Feb 07, 2015 5:41 pm
Location: Poland

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby Despot » Mon Jan 20, 2020 12:26 pm

Despot Mon Jan 20, 2020 12:26 pm
+1 Splash screen then nothing....
User avatar
Despot
Licensed Customer
Licensed Customer
 
Posts: 93
Joined: Tue Jan 10, 2017 3:19 pm

Re: OctaneRender™ 2020.1 XB3 [latest 2020.1.x]

Postby Notiusweb » Mon Jan 20, 2020 3:21 pm

Notiusweb Mon Jan 20, 2020 3:21 pm
Also getting splash screen only with Enterprise.
Okay, will await server fix!
Win 10 Pro 64, Xeon E5-2687W v2 (8x 3.40GHz), G.Skill 64 GB DDR3-2400, ASRock X79 Extreme 11
Mobo: 1 Titan RTX, 1 Titan Xp
External: 6 Titan X Pascal, 2 GTX Titan X
Plugs: Enterprise
User avatar
Notiusweb
Licensed Customer
Licensed Customer
 
Posts: 1283
Joined: Mon Nov 10, 2014 4:51 am
Next

Return to Development Build Releases


Who is online

Users browsing this forum: No registered users and 2 guests

Wed Aug 12, 2020 7:01 pm [ UTC ]