OctaneRender™ 2020.1 XB2 [superseded by 2020.1 XB3]

Forums: OctaneRender™ 2020.1 XB2 [superseded by 2020.1 XB3]
A forum where development builds are posted for testing by the community.
Forum rules
NOTE: The software in this forum is not %100 reliable, they are development builds and are meant for testing by experienced octane users. If you are a new octane user, we recommend to use the current stable release from the 'Commercial Product News & Releases' forum.

OctaneRender™ 2020.1 XB2 [superseded by 2020.1 XB3]

Postby mojave » Sun Dec 22, 2019 9:28 pm

mojave Sun Dec 22, 2019 9:28 pm
Dear all,

We are happy to share our second experimental build of Octane 2020.1 As with all experimental software please do not use this for production purposes.

This release includes a large number of bug fixes and improvements including those that have been reported by you in 2020.1 XB. There are still some outstanding issues that could not make it to this release but we are making good progress and they should be coming in the next one. Thank you all for your support.

Should you find any issues with this release please report using this thread so we can make sure we provide you with the best feedback.

Make sure to use a NVIDIA Studio driver with version at least 435.80 for Windows or 435.12 for Linux to enable RTX support. There are no OSX drivers that currently support RTX.

2020.1 XB3 has superseded this build.

Changes since OctaneRender 2020.1 XB1:

New features:

  • Added Cinema 4D noises to standalone. These will also be available from the Cinema 4D plugin.
  • Added IOR pin to hair material to control the Fresnel effect of the specular reflection.
  • Added randomizatoin pins to hair material.
  • Command line arguments take precedence over settings in octane_log_flags.txt.
  • Addded ACES export to the batch rendering Lua scripts.
  • Added auto bump map support for RTX primitives.
  • Added support for UV sets 2 and 3 for RTX primitives.
  • Added support for vertex attributes for RTX primitives.
  • Added support for vertex attributes for primitives using texture displacement.
  • Added support for importing and exporting point attributes via Alembic files.
  • Brought back network rendering (slave are builds available now).

Improvements:

  • Primitives using fast rounded edges shader can now be accelerated using RTX.
  • Better handling of environment sampling.
  • Various UI cosmetic changes including buttons capitalization and full stops.
  • Reduced VRAM used for instancing up to less than half in the most common case.

Bugfixes:

  • Fixed CUDA crash when using turbulence texture in dirt texture.
  • Fixed a few issues that would cause the memory usage to slightly increase over time.
  • Fixed melanin conversion for inverse reflectance mapping in hair material.
  • Fixed secondary bounce rough limit for the azimuthal roughness in hair material.
  • Fixed some edge cases where hair material was producing wrong values.
  • Fixed auto bump map for projection types other than mesh UV.
  • Fixed vertex displacement not being properly applied to primitives using motion.
  • Fixed some resolution issues in Retina displays.
  • Fixed issue breaking some noise functions in OSL.
  • Fixed broken batch rendering Lua scripts due to recent changes in the API.
  • Fixed crash while updating a scene and device peering (NVlink) is enabled.
  • Fixed issue causing mix material being ignored when it is connected to a layered material.
  • Fixed fake shadow being switched off when albedo is greater than zero in universal material.
  • Fixed broken connection caused after an externally linked camera node changed to a universal camera.
  • Fixed crash when expanding a universal camera.
  • Fixed application settings pane being cut off on the right depending on the system font size.
  • Fixed crash when importing FBX geometry containing more than 3 UV sets.
  • Fixed stale rendering stats on finished render when upsampler is enabled.
  • Fixed issue that would require unused shared libraries on Linux.
  • Fixed issue with AI light when using RTX causing dark renders.
  • Fixed issue with volume scattering not rendering as expected.
  • Fixed issue when connecting texture nodes to dirt radius input.
  • Disable the RTX performance script if RTX is not supported.
  • Disable the RTX on/off checkbox from the device manager if RTX is not supported.

Known bugs:

  • Some operators do not currently work with vectron when using scatter nodes.
  • Crash rendering some animated scenes after a number of frames in some plugins.
  • Missing geometry for some scenes when RTX is enabled.

TODO:

  • Accurate rounded edges shader support with RTX.
  • Dirt shader support with RTX.


Downloads

Downloads for Enterprise subscription users:

OctaneRender Enterprise 2020.1 XB2 Standalone for Windows (installer)
OctaneRender Enterprise 2020.1 XB2 Standalone for Windows (ZIP archive)
OctaneRender Enterprise 2020.1 XB2 Standalone for Linux
OctaneRender Enterprise 2020.1 XB2 Standalone for OSX

OctaneRender Enterprise 2020.1 XB2 Slave for Windows (installer)
OctaneRender Enterprise 2020.1 XB2 Slave for Windows (ZIP archive)
OctaneRender Enterprise 2020.1 XB2 Slave for Linux
OctaneRender Enterprise 2020.1 XB2 Slave for MacOS

Downloads for Studio subscription users:

OctaneRender Studio 2020.1 XB2 Standalone for Windows (installer)
OctaneRender Studio 2020.1 XB2 Standalone for Windows (ZIP archive)
OctaneRender Studio 2020.1 XB2 Standalone for Linux
OctaneRender Studio 2020.1 XB2 Standalone for OSX


Happy rendering
Your OTOY NZ team
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 945
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby funk » Mon Dec 23, 2019 9:58 pm

funk Mon Dec 23, 2019 9:58 pm
Thanks team
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 819
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby funk » Mon Dec 23, 2019 10:07 pm

funk Mon Dec 23, 2019 10:07 pm
Dirt nodes with composite materials aren't completely fixed. If you have multiple materials (and multiple dirt nodes), only the first material shows the dirt

In the screenshot, you can see the red material has dirt when its rendered on it's own, but is missing the dirt when used in a composite.

composite_material_breaks_multiple_dirt_mats.png


EDIT: This was also reported by silverwing in 2019.1.5 viewtopic.php?p=374935#p374935
Attachments
composite_material_breaks_multiple_dirt_mats.orbx
(389.97 KiB) Downloaded 6 times
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 819
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby divasoft » Tue Dec 24, 2019 12:21 am

divasoft Tue Dec 24, 2019 12:21 am
Hi, why i get invalid version message?
Attachments
Снимок.PNG
User avatar
divasoft
Licensed Customer
Licensed Customer
 
Posts: 231
Joined: Thu Jul 01, 2010 3:59 am
Location: Russia

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby mojave » Tue Dec 24, 2019 12:32 am

mojave Tue Dec 24, 2019 12:32 am
divasoft wrote:Hi, why i get invalid version message?


It seems that you are using the 2020.1 XB2 slave but your plugin is still on 2020.1 XB1.

Master and slaves must always use the exact same version so until plugins are released for 2020.1 XB2 you will be able to use network rendering with standalone.
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 945
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby mojave » Tue Dec 24, 2019 12:32 am

mojave Tue Dec 24, 2019 12:32 am
funk wrote:Dirt nodes with composite materials aren't completely fixed. If you have multiple materials (and multiple dirt nodes), only the first material shows the dirt

In the screenshot, you can see the red material has dirt when its rendered on it's own, but is missing the dirt when used in a composite.

composite_material_breaks_multiple_dirt_mats.png


EDIT: This was also reported by silverwing in 2019.1.5 viewtopic.php?p=374935#p374935


Thank you for the heads up.
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 945
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby divasoft » Tue Dec 24, 2019 12:54 am

divasoft Tue Dec 24, 2019 12:54 am
mojave wrote:
divasoft wrote:Hi, why i get invalid version message?


It seems that you are using the 2020.1 XB2 slave but your plugin is still on 2020.1 XB1.

Master and slaves must always use the exact same version so until plugins are released for 2020.1 XB2 you will be able to use network rendering with standalone.

Ok. But i can render well with 2019.4 cinema plug & 2019.5 slave.
User avatar
divasoft
Licensed Customer
Licensed Customer
 
Posts: 231
Joined: Thu Jul 01, 2010 3:59 am
Location: Russia

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby mojave » Tue Dec 24, 2019 1:02 am

mojave Tue Dec 24, 2019 1:02 am
divasoft wrote:
mojave wrote:
divasoft wrote:Hi, why i get invalid version message?


It seems that you are using the 2020.1 XB2 slave but your plugin is still on 2020.1 XB1.

Master and slaves must always use the exact same version so until plugins are released for 2020.1 XB2 you will be able to use network rendering with standalone.

Ok. But i can render well with 2019.4 cinema plug & 2019.5 slave.


Please double check this is correct and if so could you report this as a bug in the relevant forum section? Thank you.
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 945
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby rohandalvi » Tue Dec 24, 2019 6:01 am

rohandalvi Tue Dec 24, 2019 6:01 am
Hi,

I can’t find the cinema4d noises in standalone.
rohandalvi
Licensed Customer
Licensed Customer
 
Posts: 118
Joined: Tue Apr 20, 2010 7:39 am

Re: OctaneRender™ 2020.1 XB2 [latest 2020.1.x]

Postby aoktar » Tue Dec 24, 2019 11:24 am

aoktar Tue Dec 24, 2019 11:24 am
rohandalvi wrote:Hi,

I can’t find the cinema4d noises in standalone.

It requires to use from some special osl node. It will be available with C4D plugin.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12831
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye
Next

Return to Development Build Releases


Who is online

Users browsing this forum: enricocerica and 2 guests

Thu Jan 23, 2020 6:24 am [ UTC ]