OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Forums: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]
A forum where development builds are posted for testing by the community.
Forum rules
NOTE: The software in this forum is not %100 reliable, they are development builds and are meant for testing by experienced octane users. If you are a new octane user, we recommend to use the current stable release from the 'Commercial Product News & Releases' forum.

OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby mojave » Thu Aug 15, 2019 4:59 am

mojave Thu Aug 15, 2019 4:59 am
Dear all,

We are happy to share our second experimental build of Octane 2019.2 As with all experimental software please do not use this for production purposes.

This release is mostly a maintenance update. There are still some outstanding issues at this point, but we are making good progress for more fixes to arrive soon.

Please also ensure that you have a NVIDIA driver version 419.x or newer.

Changes since OctaneRender 2019.2 XB1:

New features:

  • Replaced pin to enable RTX from the kernel settings with a flag in the device settings that enables RTX persistently for all devices.
  • New relase flag disableRtx to completely disable RTX even if enabled in the device settings.
Bugfixes:

  • Displacement: Fixed unnecessary updates in some more scenarios when using vertex displacement.
  • Geometry: Fixed ghosting issue when modifying instance positions and RTX was enabled.
  • Geometry: Fixed lack of motion blur for some objects when RTX was enabled.
  • Geometry: Fixed issue that would cause some objects to appear transparent when using an environment medium when RTX was eanbled.
  • Lua: Fixed denoise devices always matching the devices using priority.
  • Material: Fixed issue with glossy materials which would always trigger a full update.
  • Material: Fixed shared toon materials only rendering correctly on one object, the rest rendered black.
  • Material: Fixed toon outline always rendering black.
  • Material: Fixed texture projections other than mesh uv not working with scattering and absorption.
  • Material: Fixed dirt texture being ignored for layered materials.
  • Material: Fixed universal material pins to specify transmission type.
  • Material: Fixed universal material layer with thin wall and single sided geometry behavior.
  • Network Render: Fixed network rendering when RTX was enabled in render slaves.
  • Picking: Fixed picking when upsampling was enabled.
  • Picking: Fixed error after using mesh or material picking when RTX was enabled.
  • Render Pass: Fixed layered material diffuse direct contribution being output into the reflection direct pass.
  • Render Pass: Fixed smooth normals when geometric and vertex normals would be in opposite hemispheres.
  • Stability: Fixed crash when using texture displacement and accurate rounded edges.
  • Stability: Fixed CUDA crash when using AI light and RTX primitives.
  • Stability: Fixed CUDA crash with meshes with more than one material and emission wen RTX was enabled.
  • Stability: Fixed CUDA crash in scene with emission and various geometry types when RTX was enabled.
  • Stability: Fixed crash while loading some meshes with polygons of different sizes when RTX was enabled.
  • UI: Fixed issue with displaying and updating the device priority flag in the device settings.
  • UI: Fixed memory tracking when RTX was enabled.
Known bugs:

  • Scenes that contain not just triangles can be slower when RTX mode is enabled.
  • Dirt texture applied to triangles will evaluate as black when RTX mode is enabled.
  • Round edges will not be evaluated when using accurate mode and RTX mode is enabled.


Downloads

Downloads for users with an Enterprise subscription license

OctaneRender Enterprise 2019.2 XB2 (Windows installer)
OctaneRender Enterprise 2019.2 XB2 (Windows zip)

Downloads for users with a Studio subscription license

OctaneRender Studio 2019.2 XB2 (Windows installer)
OctaneRender Studio 2019.2 XB2 (Windows zip)

Downloads for users with a regular V4 license

OctaneRender 2019.2 XB2 (Windows installer)
OctaneRender 2019.2 XB2 (Windows zip)


Happy rendering
Your OTOY NZ team
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 883
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby funk » Thu Aug 15, 2019 11:25 am

funk Thu Aug 15, 2019 11:25 am
Thanks team
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 768
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby funk » Thu Aug 15, 2019 11:45 am

funk Thu Aug 15, 2019 11:45 am
Toggling fake shadow doesnt update render:

1. Right click and render the universal material
2. Toggle fake shadows on. NOTE: nothing updates in the render
3. Stop the render
4. Right click and render the universal material. NOTE: Now the render updates


EDIT: Another test... If you set coating color to white, toggling fake shadows works in real time, but the render is wrong until you stop and restart it
Attachments
universal_fake_shadow_no_update.ocs
(37.29 KiB) Downloaded 11 times
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 768
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby funk » Thu Aug 15, 2019 11:58 am

funk Thu Aug 15, 2019 11:58 am
Universal transmission bug. When specular and transmission are 0, and you add coating, the material becomes transparent

1. Right click and render the universal material. NOTE: Its transparent, which is incorrect
2. Set coating color to 0 (black). NOTE: The material is now black
Attachments
universal_transparent_with_transmission_zero_and_coating.ocs
(37.29 KiB) Downloaded 15 times
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 768
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby SRCOBB » Thu Aug 15, 2019 6:36 pm

SRCOBB Thu Aug 15, 2019 6:36 pm
No MAC installers?
SRCOBB
Licensed Customer
Licensed Customer
 
Posts: 22
Joined: Thu Nov 02, 2017 5:42 am

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby mojave » Thu Aug 15, 2019 8:24 pm

mojave Thu Aug 15, 2019 8:24 pm
SRCOBB wrote:No MAC installers?


OSX and Linux are coming but some extra work is still required until we can share them.
User avatar
mojave
OctaneRender Team
OctaneRender Team
 
Posts: 883
Joined: Sun Feb 08, 2015 10:35 pm

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby wallace » Thu Aug 15, 2019 9:02 pm

wallace Thu Aug 15, 2019 9:02 pm
funk wrote:Universal transmission bug. When specular and transmission are 0, and you add coating, the material becomes transparent

1. Right click and render the universal material. NOTE: Its transparent, which is incorrect
2. Set coating color to 0 (black). NOTE: The material is now black


Thanks for reporting, this is now fixed.
User avatar
wallace
OctaneRender Team
OctaneRender Team
 
Posts: 85
Joined: Sun Dec 18, 2016 10:38 pm

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby wallace » Thu Aug 15, 2019 9:48 pm

wallace Thu Aug 15, 2019 9:48 pm
funk wrote:Toggling fake shadow doesnt update render:

1. Right click and render the universal material
2. Toggle fake shadows on. NOTE: nothing updates in the render
3. Stop the render
4. Right click and render the universal material. NOTE: Now the render updates


EDIT: Another test... If you set coating color to white, toggling fake shadows works in real time, but the render is wrong until you stop and restart it


Hi,

Fake shadow should not have any effect on diffusely transmissive material, it's only for specular materials. This means the first bug you have reported is actually a correct behavior, I have only avoided a shader recompilation in this case as it can be quite an expensive operation for plugins, as it's basically meaningless to rebuild the shader if it doesn't change the rendering.

However, fake shadow on diffuse transmission + coating should not be affecting the rendering of the material, so that means your second bug is a real bug, and I have fixed it.

Thanks for reporting.
User avatar
wallace
OctaneRender Team
OctaneRender Team
 
Posts: 85
Joined: Sun Dec 18, 2016 10:38 pm

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby funk » Fri Aug 16, 2019 1:21 am

funk Fri Aug 16, 2019 1:21 am
wallace wrote:
funk wrote:Toggling fake shadow doesnt update render:

1. Right click and render the universal material
2. Toggle fake shadows on. NOTE: nothing updates in the render
3. Stop the render
4. Right click and render the universal material. NOTE: Now the render updates


EDIT: Another test... If you set coating color to white, toggling fake shadows works in real time, but the render is wrong until you stop and restart it


Hi,

Fake shadow should not have any effect on diffusely transmissive material, it's only for specular materials. This means the first bug you have reported is actually a correct behavior, I have only avoided a shader recompilation in this case as it can be quite an expensive operation for plugins, as it's basically meaningless to rebuild the shader if it doesn't change the rendering.

However, fake shadow on diffuse transmission + coating should not be affecting the rendering of the material, so that means your second bug is a real bug, and I have fixed it.

Thanks for reporting.


Thanks for checking it out Wallace. You say the first is not a bug, but I want to make sure you noticed that the material changes in appearance AFTER you restart (step 4). So if toggling fake shadows should do nothing (as it does in step 2), then step 4 is still incorrect.
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 768
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.2 XB2 [latest 2019.2.x]

Postby divasoft » Fri Aug 16, 2019 12:01 pm

divasoft Fri Aug 16, 2019 12:01 pm
In this update, my castle scene does not render at all. Including switched off rtx. As soon as I start the render, a crash occurs.
https://drive.google.com/open?id=1XVfLt ... EpCRSe06cB
Attachments
1_DeMain_0000.jpg
User avatar
divasoft
Licensed Customer
Licensed Customer
 
Posts: 175
Joined: Thu Jul 01, 2010 3:59 am
Location: Russia
Next

Return to Development Build Releases


Who is online

Users browsing this forum: rohandalvi and 1 guest

Sun Oct 20, 2019 3:51 am [ UTC ]