Proper Linear Workflow in Blender

Forums: Proper Linear Workflow in Blender
Blender (Export script developed by yoyoz; Integrated Plugin developed by JimStar)

Proper Linear Workflow in Blender

Postby AndreasResch » Wed Aug 08, 2018 9:08 am

AndreasResch Wed Aug 08, 2018 9:08 am
Hey.

I've already posted this issue on Facebbok, but haven't got any good response. So I'll try it again here. Maybe somebody has a solution.

I can't really get a good linear result ouf of the Octane Imager. It's always too punchy and the highlights are gone very fast. Interestingly the sRGB response type is less contratsy than the linear one, which is completely different in Filmic Blender. The result works well will Octane Imager OFF and Filmic Blender ON. But I was told, that I should not use Filmic Blender in combination with Octane. So how can I get the result that I want with just the Octane Imager. Here are some tests. The lighting is intentionally overexposed to enhance the effect.

Here's the result I want. Octane Imager is OFF anf Filmic Blender is ON. The highlights are well preserved.
Octane_Issue_04.jpg


Here's the result with Octane Imager OFF and Filmic Blender OFF (Compression is 0).
Octane_Issue_05.jpg


Here's the result with Octane Imager OFF and Filmic Blender OFF (Compression is 1).
Octane_Issue_06.jpg


I've also uploaded the scene to check out. You might have to use an HDRI of your own for the environment.

http://www.andreasresch.at/upload/Octane_Test_07.zip

Any suggestions?

Cheers,
Andreas
AndreasResch
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 25, 2018 4:53 pm

Re: Proper Linear Workflow in Blender

Postby J.C » Wed Aug 08, 2018 10:03 am

J.C Wed Aug 08, 2018 10:03 am
The Blender's Color Management should be turned off. Display device set to None, Exposure to 0 and Gamma to 1.

The proper workflow for Octane is to use Octane Camera imager if you want tonemapped images in 8-16bit depth.

For more control you can save it as 32 bit exr format which will be untonemapped after the save.
CPU – i7 8700k 4.8Ghz + 32GB RAM
GPU – 2xGTX 980 Ti
System – OS X 10.12.6, Windows 10
Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio
Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 596
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Proper Linear Workflow in Blender

Postby AndreasResch » Wed Aug 08, 2018 10:13 am

AndreasResch Wed Aug 08, 2018 10:13 am
Hey, JC.

I've used all these settings (as you can see in the blend file). Yet the highlights are blown out, even if I set Highlight Compression to 1. Even in the EXR the details in the highlights are gone.

Cheers,
Andreas
AndreasResch
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 25, 2018 4:53 pm

Re: Proper Linear Workflow in Blender

Postby J.C » Wed Aug 08, 2018 10:25 am

J.C Wed Aug 08, 2018 10:25 am
You have set HDRI image Power to 5. Thats way to much. I always keep it at 1or below if the hdri lighting is to strong.
CPU – i7 8700k 4.8Ghz + 32GB RAM
GPU – 2xGTX 980 Ti
System – OS X 10.12.6, Windows 10
Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio
Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 596
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Proper Linear Workflow in Blender

Postby J.C » Wed Aug 08, 2018 10:29 am

J.C Wed Aug 08, 2018 10:29 am
If you want to rotate HDRI you only need Octane Full Transform node plugged to Transform input of the texture. To rotate the map use Translation X value.
transform.png
CPU – i7 8700k 4.8Ghz + 32GB RAM
GPU – 2xGTX 980 Ti
System – OS X 10.12.6, Windows 10
Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio
Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 596
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Proper Linear Workflow in Blender

Postby AndreasResch » Wed Aug 08, 2018 10:52 am

AndreasResch Wed Aug 08, 2018 10:52 am
Hey, JC.

Thanks for the tip. But with my version I can rotate the map more precise. The Translation slider is a bit aggressive even when using SHIFT.

But I assume this has nothing to do with the linear workflow, right?

Cheers,
Andreas
AndreasResch
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 25, 2018 4:53 pm

Re: Proper Linear Workflow in Blender

Postby J.C » Wed Aug 08, 2018 10:54 am

J.C Wed Aug 08, 2018 10:54 am
Yes, the transform has nothing to do with it.
Can you provide the hdri map you have used in your example?
CPU – i7 8700k 4.8Ghz + 32GB RAM
GPU – 2xGTX 980 Ti
System – OS X 10.12.6, Windows 10
Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio
Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 596
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Proper Linear Workflow in Blender

Postby AndreasResch » Wed Aug 08, 2018 11:12 am

AndreasResch Wed Aug 08, 2018 11:12 am
Hey.

You can download the HDRI here ... https://hdrihaven.com/hdri/?c=outdoor&h=delta_2

I used the 2K version for the test although that doesn't really matter here.

Cheers,
Andreas
AndreasResch
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 25, 2018 4:53 pm

Re: Proper Linear Workflow in Blender

Postby J.C » Wed Aug 08, 2018 11:29 am

J.C Wed Aug 08, 2018 11:29 am
As I've written before the hdri image power is too high. Set it to 1 and Highlight compression to 1. The image will not be overblown.
In Color Management set the "Display Device" to "None"
render.png
CPU – i7 8700k 4.8Ghz + 32GB RAM
GPU – 2xGTX 980 Ti
System – OS X 10.12.6, Windows 10
Octane 3.0x/4, Blender Plugin 15.3.4 and 16.x.x
My Behance portfolio
Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 596
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Proper Linear Workflow in Blender

Postby AndreasResch » Wed Aug 08, 2018 12:32 pm

AndreasResch Wed Aug 08, 2018 12:32 pm
Hey.

I know that my settings were too high. They were cranked up to test the highligh compression og both Filmic Blender and Octane. As you can see, Filmic Blender does not mind.

The scene with your settings is too dark. The ground is pure white and in your rendering it comes out at 70% gray.

I'll see what method I will use in the future. I can always fall back to the Filmic color management if I should need it. I might have been lucky with a LUT version of the Filmic management, but so far i was not able to find a CUBE vesion that I can load into Octane.

Cheers,
Andreas
AndreasResch
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Wed Jul 25, 2018 4:53 pm
Next

Return to Blender


Who is online

Users browsing this forum: Baidu [Spider] and 2 guests

Tue Dec 11, 2018 7:37 am [ UTC ]