Beauty alpha and background compositing using vdb

Forums: Beauty alpha and background compositing using vdb
Maxon Cinema 4D (Export script developed by abstrax, Integrated Plugin developed by aoktar)

Moderator: aoktar

Beauty alpha and background compositing using vdb

Postby jeremyshin » Fri Jul 05, 2019 5:11 am

jeremyshin Fri Jul 05, 2019 5:11 am
Hello,
I have a problem compositing my background in After Effects.
I have a few OpenVDB in my scene. I rendered a pass for Environment and in the Kernel setting I enabled "Alpha channel" and "keep environment".

In After Effects, when I enable the alpha channel on my Beauty pass and put my Environment pass below, the transparency from the VDB is messed up. In the attachment files you can see the expected result when I set the Alpha channel on "copy". But in this case I loose the transparency to composite my background.

Any solution ? Does my problem come from Octane bad setting or After Effects bad compositing technic ?

Thank you,
Jeremy
Attachments
beauty-alpha-copy.png
Alpha-channel-copy
beauty-alpha-on.png
Alpha-channel-on
jeremyshin
Licensed Customer
Licensed Customer
 
Posts: 40
Joined: Thu May 04, 2017 5:59 pm

Re: Beauty alpha and background compositing using vdb

Postby jeremyshin » Mon Jul 08, 2019 7:20 am

jeremyshin Mon Jul 08, 2019 7:20 am
Nobody can help ? Feel free to tell me if my post was not clear enough, I can provide any additional informations if necessary.

I am doing animation, not stills. Using EXR tonemapped 16bit (not working in Linear). I just wanted to have my background separated from other layers but I have problem with alpha channel on the volumes.

I'm sure somebody can help :)

Thanks,
J.
jeremyshin
Licensed Customer
Licensed Customer
 
Posts: 40
Joined: Thu May 04, 2017 5:59 pm

Re: Beauty alpha and background compositing using vdb

Postby jeremyshin » Fri Jul 12, 2019 8:07 pm

jeremyshin Fri Jul 12, 2019 8:07 pm
Another exemple in a little test.
If you see the pictures attached below :
- First one is the beauty without any passes.
- Second one is a composition using Render Layer for the volume object. Using Alpha Channel in Octane.

It is obvious that the volume rendered with Render Layer Pass is way more transparent than when render within the beauty.
Attachments
volume-beauty-desired-effect.png
volume-beauty-desired-effect
volume-render-layer-pass-too-much-transparency.png
volume-render-layer-pass-too-much-transparency
jeremyshin
Licensed Customer
Licensed Customer
 
Posts: 40
Joined: Thu May 04, 2017 5:59 pm

Re: Beauty alpha and background compositing using vdb

Postby jeremyshin » Fri Jul 19, 2019 11:13 am

jeremyshin Fri Jul 19, 2019 11:13 am
If I cant find any help here, please let me know who and where to ask to.
jeremyshin
Licensed Customer
Licensed Customer
 
Posts: 40
Joined: Thu May 04, 2017 5:59 pm

Re: Beauty alpha and background compositing using vdb

Postby ceen » Wed Sep 11, 2019 9:46 am

ceen Wed Sep 11, 2019 9:46 am
I don't know if it is still a problem but it looks like you have maybe a tonemapping problem in the passes or in AE?
ceen
Licensed Customer
Licensed Customer
 
Posts: 35
Joined: Wed Jun 10, 2015 9:43 pm

Re: Beauty alpha and background compositing using vdb

Postby Raoul » Sun Sep 15, 2019 6:16 am

Raoul Sun Sep 15, 2019 6:16 am
You're not mad, i've had this problem too.. The only ( hacky) solution i've had is to play around with material qualitites of the VDB in octane to make it a thicker material. I cant remember the exact setting as im not near my work comp, but it is possible to thicken up the alpha matte without totally changing the look of the smoke.. i have to jump back and forth to see the alpha matte to see if its working.
then i uses curves in after effects to fill out the alpha a little.. its a long way from a simple effective pipeline.
if anyones knows why/how this happening would love a quick fix.
Raoul
Licensed Customer
Licensed Customer
 
Posts: 47
Joined: Sun May 25, 2014 8:24 am

Return to Maxon Cinema 4D


Who is online

Users browsing this forum: J.C and 12 guests

Mon Dec 09, 2019 8:53 pm [ UTC ]