TDR delay

Forums: TDR delay
3D Studio Max Plugin (Export Script Plugins developed by [gk] and KilaD; Integrated Plugin developed by Karba)
Forum rules
Please post only in English in this subforum. For alternate language discussion please go here viewforum.php?f=18

TDR delay

Postby paride4331 » Thu Dec 06, 2018 10:39 am

paride4331 Thu Dec 06, 2018 10:39 am
Hi guys,
for anyone who installed Octane v4 SA and / or Octane 2018 SA or who have not previously modified TDRdelay and encounter lags, I recommend setting it to 60 again.
I will ask 3dsMax developers if they can add this registry modification during the installation.

The specific error message is related to a timeout issue.
What happens is that the Windows system instantly disable the GPU drivers, if it does not receive a signal after some seconds.
By default the TdrDelay is set to 2s, i.e. if one kernel call takes more than 2s, Windows kills the driver.
If you install the Standalone via installer, we change some Windows registry to better work with GPU Rendering.
To change the timeout, either run the Standalone installer or manually set the TdrDelay key to something like 10s or so. See here:
In the Standalone installer we set these values:
WriteRegDWORD HKLM ""SYSTEM\CurrentControlSet\Control\GraphicsDrivers"" TdrLevel 3
WriteRegDWORD HKLM ""SYSTEM\CurrentControlSet\Control\GraphicsDrivers"" TdrDelay 10jh
Some users have set the TdrDelay at 60, to solve their stability issues with CUDA.
2 x Evga Titan X Hybrid / 3 x Evga RTX 2070 super Hybrid
User avatar
Octane Guru
Octane Guru
Posts: 3026
Joined: Fri Sep 18, 2015 7:19 am

Return to Autodesk 3Ds Max

Who is online

Users browsing this forum: No registered users and 4 guests

Fri Jul 10, 2020 1:13 pm [ UTC ]