OctaneRender™ 2019.1.2

Forums: OctaneRender™ 2019.1.2
VIP Information, news and announcements regarding new Octane Render commercial products and releases.

OctaneRender™ 2019.1.2

Postby abstrax » Thu Oct 10, 2019 10:54 pm

abstrax Thu Oct 10, 2019 10:54 pm
Hi all,

This release contains more fixes on top of 2019.1.1. Please note that the Enterprise Octane network slave is now distributed in its own package.

To find an overview of the features of 2019.1 please go here.

Also make sure that you have a NVIDIA driver of version 419.x or higher.


Changes since OctaneRender 2019.1.1:

  • Fixed toon material rendering incorrectly for camera toon light.
  • Fixed toon material causing a render failure in the material preview.
  • Fixed multi-layered material not outputting multi-layered bump mapped / mapped normals in info passes
  • Fixed volume render inconsistency when using legacy mode.
  • Fixed incorrect denoiser output when enablign some light passes.
  • Fixed upsampler not working properly for the very first time on some GPUs (this does not fix the upsampler on Win 7, which is still an unsolved problem).
  • Fixed kernel crash when using accurate rounded edges if adjacent geometry of an edge is a displacement triangle.
  • Fixed discontinuities in shading normals for some cases when using fast rounded edges.
  • Fixed a bug in the vertex normal calculation of vertex displacement geometry which was causing the geometry to look facetted when using the join unwelded vertices option.
  • Fixed net render slave crash when a scene contains images compressed on the master.
  • Updated the universal camera:
    • All camera modes now conform to a unique set of pins.
    • Added equirectangular and cubemap cameras.
    • Added aberration, coma, field curvature, astigmatism and spherical aberration to the thin lens camera.
    • Added keep-upright to all cameras.
    • Added clipping and pixel aspect ratio to fisheye and panoramic cameras.
    • Added lens shift to panoramic cameras.
    • Fixed autofocus and focus picking.
    • Fixed bokeh in fisheye camera for polygonal apertures.

Downloads

Downloads for Enterprise subscription users:

OctaneRender Enterprise 2019.1.2 Standalone for Windows (installer)
OctaneRender Enterprise 2019.1.2 Standalone for Windows (ZIP archive)
OctaneRender Enterprise 2019.1.2 Standalone for MacOS
OctaneRender Enterprise 2019.1.2 Standalone for Linux

OctaneRender Enterprise 2019.1.2 Slave for Windows (installer)
OctaneRender Enterprise 2019.1.2 Slave for Windows (ZIP archive)
OctaneRender Enterprise 2019.1.2 Slave for MacOS
OctaneRender Enterprise 2019.1.2 Slave for Linux

Downloads for Studio subscription users:

OctaneRender Studio 2019.1.2 Standalone for Windows (installer)
OctaneRender Studio 2019.1.2 Standalone for Windows (ZIP archive)
OctaneRender Studio 2019.1.2 Standalone for MacOS
OctaneRender Studio 2019.1.2 Standalone for Linux

Demo downloads:

OctaneRender Demo 2019.1.2 Standalone for Windows (installer)
OctaneRender Demo 2019.1.2 Standalone for Windows (ZIP archive)
OctaneRender Demo 2019.1.2 Standalone for MacOS
OctaneRender Demo 2019.1.2 Standalone for Linux


Happy rendering
Your OTOY NZ team
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5105
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby J.C » Fri Oct 11, 2019 9:45 am

J.C Fri Oct 11, 2019 9:45 am
Hello, thank you for the new release!

Can you tell us if shading errors with Vertex displacement (Auto bump) and Rounded edges will be fixed? They still exist in this release.
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPUs: 2xRTX 2080, 2xGTX 980 Ti.
System – Windows 10, OS X 10.12.6. Octane 4-2019, Blender Plugin 17.x-20.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 1081
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby J.C » Fri Oct 11, 2019 11:34 am

J.C Fri Oct 11, 2019 11:34 am
Clouds has intersecting issues when "Emulate old volume" is enabled.
You do not have the required permissions to view the files attached to this post.
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPUs: 2xRTX 2080, 2xGTX 980 Ti.
System – Windows 10, OS X 10.12.6. Octane 4-2019, Blender Plugin 17.x-20.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 1081
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby funk » Fri Oct 11, 2019 12:17 pm

funk Fri Oct 11, 2019 12:17 pm
Thanks team
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 788
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby Notiusweb » Sun Oct 13, 2019 3:35 am

Notiusweb Sun Oct 13, 2019 3:35 am
I would also like to take a moment to congratulate team on the releases.
Excellent and so creatively ground-breaking with the progression.

***APPLAUSE***
Win 10 Pro 64, Xeon E5-2687W v2 (8x 3.40GHz), G.Skill 64 GB DDR3-2400, ASRock X79 Extreme 11
Mobo: 1 Titan Xp, 1 Titan X Pascal
External: 6 Titan X Pascal - 1600W EVGA T2
Plugs: 3DSMax, C4D, Daz, Houdini, Lightwave, Sketchup
User avatar
Notiusweb
Licensed Customer
Licensed Customer
 
Posts: 1159
Joined: Mon Nov 10, 2014 4:51 am

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby Daniel_Brok » Tue Oct 15, 2019 9:13 am

Daniel_Brok Tue Oct 15, 2019 9:13 am
Hi,

i am getting a Error when i use AI-upsampler:

Started logging on 15.10.19 10:55:25

OctaneRender Enterprise 2019.1.2 (6000102)

Up-sampling error: CUDA_ERROR_LAUNCH_FAILED: unspecified launch failure

CUDA error 719 on device 0: unspecified launch failure
-> failed to copy pitched memory from device


its happen on : Windows 8.1 pro and NVIDIA GeForce GTX 970, latest Driver!


i hope, this will go fixed!?
THX
Daniel_Brok
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Sun Mar 02, 2014 4:41 pm

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby Silverwing » Tue Oct 15, 2019 1:57 pm

Silverwing Tue Oct 15, 2019 1:57 pm
Hi there to the Developers of Octane.

First of thanks a lot for all the time ans effort you pit in the steady development and making Octane better.

I am hoping to catch your attention just for a moment:

Upon testing the Universal Camera I compiled a list of (for me) essential features, and nice to haves:

Essential:
Please change the Aperture Texture be read at least gray-scale data (right now its binary either black or white). Color would be even better.
This is limiting in many ways as: Not being able to bring the subtleties that a lot of lenses have into the bokeh.
With color there is the possibility to simulate lens chromatic aberration by using bokeh maps like this:

Subtle Variations that a Bokeh map has that makes the render look infinitely more realistic:

aperture_map_realworld04.png


Bokeh for generating a lens chromatic aberration effect:

bokeh_RGB2_Tighter.jpg


Essential:
Being able to control the other aperture settings simultaneously to an Aperture Texture
Right now using an Aperture Texture disables Aperture Edge, Bokeh Side Count Bokeh roundness and all the other features.
So for example right now its impossible to have a Aperture Texture with a bokeh that has some uneven brightness contribution (Aperture Edge) since the texture is read in as binary black and white (not able to produce gradients) I can´t either set it inside the map nor can I set it in the Aperture Edge settings since it wont let me use those together with an Aperture Image.

Nice to have:
Lens Bokeh Cateye Effect (of course including using all the other effects combined with it)
Nice to have:
Dedicated lens chromatic aberration slider (That just splits your bokeh into colors so you get some aberration)

Nice to have:
When being able to use grayscale / color images inside the Aperture Map setting, rendering can get darker. Therefore a lot of render-engines that allow for Aperture Map use have brightness compensation built in, so your renderings brightness is not depended on the brightness level of your map[/list][/list].

I hope some of the changes could be implemented into 2019.1.x already. Or later in 2019.2

Thanks for your attention!
Cheers,
Raphael
You do not have the required permissions to view the files attached to this post.
WIN 10 PRO 64 | ASUS X99 DELUXE | 3 X GTX 980ti | i7 5960X 8X 3,33GHz | 64GB RAM
User avatar
Silverwing
Licensed Customer
Licensed Customer
 
Posts: 266
Joined: Wed Jun 15, 2011 8:36 pm
Location: Ludwigsburg Germany

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby Zay » Wed Oct 16, 2019 1:55 pm

Zay Wed Oct 16, 2019 1:55 pm
Updated my slave PC to this version but when I start it, it shuts down immediately. Does the slave work on Win 7 ?
Win 7 64bit | 3.4GHz I7 | 64GB ram | 2x GTX 1080Ti - driver 431.36| Modo/ZBrush/Poser
Zay
Licensed Customer
Licensed Customer
 
Posts: 1001
Joined: Sun Jan 17, 2010 2:53 am

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby haze » Wed Oct 16, 2019 9:54 pm

haze Wed Oct 16, 2019 9:54 pm
J.C wrote:Clouds has intersecting issues when "Emulate old volume" is enabled.


The legacy volume rendering had issues like this, which is why we fixed it. To avoid breaking older scenes, we kept the option there so that existing scenes that may or may not rely on that behaviour don't get broken. For newer scenes please leave the emulate option disabled.
User avatar
haze
OctaneRender Team
OctaneRender Team
 
Posts: 801
Joined: Sun Feb 08, 2015 8:57 pm

Re: OctaneRender™ 2019.1.2 [current 2019.1.x]

Postby funk » Thu Oct 17, 2019 2:59 am

funk Thu Oct 17, 2019 2:59 am
The UVW transform node is not working if you plug OSL textures into it.

Here is an example where Im rotating Z 45 degrees. It's not working on the OSL texture.

osl_and_uvw_transform_not_working.png
You do not have the required permissions to view the files attached to this post.
Win10 Pro 64 / Core i7-975 3.33GHz / 12GB RAM / GTX 1080 Ti + GTX 670 / 2x1920x1200 / MODO 13
"I am the resurrection, and the life: he that believeth in me, though he were dead, yet shall he live" - Jesus Christ
User avatar
funk
Licensed Customer
Licensed Customer
 
Posts: 788
Joined: Mon Feb 07, 2011 1:24 pm
Location: Australia
Next

Return to Commercial Product News & Releases (Download here)


Who is online

Users browsing this forum: No registered users and 1 guest

Sun Nov 17, 2019 11:58 am [ UTC ]