Poke through issues in Octane renders?

Forums: Poke through issues in Octane renders?
DAZ Studio (Export Script Plugin developed by Tugpsx; Integrated Plugin maintained by Paul Kinnane)

Moderator: face_off

Forum rules
Please keep character renders sensibly modest, please do not post sexually explicit scenes of characters.

Re: Poke through issues in Octane renders?

Postby itou31 » Fri Mar 29, 2013 9:31 pm

itou31 Fri Mar 29, 2013 9:31 pm
Just test an animation, and cannot get these "poke through" off completely.
the smoothing and interaction iteration is a bit long. I have uncheck all live update and base shape.
For still image it's OK. But for animation I notice that the plugin get the info too early, (the collision iteration process is not finished on the DS viewport (progress bar do not get to 100%), and then some "poke through" get visible.

@linvanchene, could you just do a simple animation with your figure to confirme my issue ? thanks
I7-3930K 64Go RAM Win8.1pro , main 3 titans + 780Ti
Xeon 2696V3 64Go RAM Win8.1/win10/win7, 2x 1080Ti + 3x 980Ti + 2x Titan Black
User avatar
itou31
Licensed Customer
Licensed Customer
 
Posts: 377
Joined: Tue Jan 22, 2013 8:43 am

Re: Poke through issues in Octane renders?

Postby t_3 » Fri Mar 29, 2013 10:24 pm

t_3 Fri Mar 29, 2013 10:24 pm
itou31 wrote:Just test an animation, and cannot get these "poke through" off completely.
the smoothing and interaction iteration is a bit long. I have uncheck all live update and base shape.
For still image it's OK. But for animation I notice that the plugin get the info too early, (the collision iteration process is not finished on the DS viewport (progress bar do not get to 100%), and then some "poke through" get visible.

@linvanchene, could you just do a simple animation with your figure to confirme my issue ? thanks

i can not directly confirm this, but can say it might be easily possible that this happens; the plugin iterates through all nodes, tells them to finalize their geometry, and afterwards collects the geometry. i had several circumstances were similar things happened, so this might be the case here too. means i need to find a way to make sure, ds has really finished all geometry changes when the plugin starts to transfer it to octane; i will check back with daz to see if there is any sort of event, that will tell this for sure...
The obvious is that which is never seen until someone expresses it simply

1x i7 2600K @5.0 (Asrock Z77), 16GB, 2x Asus GTX Titan 6GB @1200/3100/6200
2x i7 2600K @4.5 (P8Z68 -V P), 12GB, 1x EVGA GTX 580 3GB @0900/2200/4400
User avatar
t_3
 
Posts: 2871
Joined: Tue Jul 05, 2011 5:37 pm

Re: Poke through issues in Octane renders?

Postby itou31 » Fri Mar 29, 2013 11:45 pm

itou31 Fri Mar 29, 2013 11:45 pm
thanks t_3,
the more I discover your plugin, the more I love it !!
No more transfer to 3dsmax for animation....
I7-3930K 64Go RAM Win8.1pro , main 3 titans + 780Ti
Xeon 2696V3 64Go RAM Win8.1/win10/win7, 2x 1080Ti + 3x 980Ti + 2x Titan Black
User avatar
itou31
Licensed Customer
Licensed Customer
 
Posts: 377
Joined: Tue Jan 22, 2013 8:43 am

Re: Poke through issues in Octane renders?

Postby t_3 » Sat Mar 30, 2013 12:51 am

t_3 Sat Mar 30, 2013 12:51 am
itou31 wrote:thanks t_3,
the more I discover your plugin, the more I love it !!
No more transfer to 3dsmax for animation....
i really love to read such sentences :)
just head away form the current issues (until i have resolved them,)so the love can grow undisturbed :lol:
The obvious is that which is never seen until someone expresses it simply

1x i7 2600K @5.0 (Asrock Z77), 16GB, 2x Asus GTX Titan 6GB @1200/3100/6200
2x i7 2600K @4.5 (P8Z68 -V P), 12GB, 1x EVGA GTX 580 3GB @0900/2200/4400
User avatar
t_3
 
Posts: 2871
Joined: Tue Jul 05, 2011 5:37 pm

Re: Poke through issues in Octane renders?

Postby itou31 » Wed Apr 03, 2013 9:21 pm

itou31 Wed Apr 03, 2013 9:21 pm
Hi,

I just update with the build 2121, something better but not perfect at some keyframe, the "poke thru" get back, due to more time to DAZ for smoothing. I can see the progress bar and viewport from DAZ not get full update, but the render viewport of octane is already done !?
I7-3930K 64Go RAM Win8.1pro , main 3 titans + 780Ti
Xeon 2696V3 64Go RAM Win8.1/win10/win7, 2x 1080Ti + 3x 980Ti + 2x Titan Black
User avatar
itou31
Licensed Customer
Licensed Customer
 
Posts: 377
Joined: Tue Jan 22, 2013 8:43 am

Re: Poke through issues in Octane renders?

Postby t_3 » Wed Apr 03, 2013 9:28 pm

t_3 Wed Apr 03, 2013 9:28 pm
itou31 wrote:Hi,

I just update with the build 2121, something better but not perfect at some keyframe, the "poke thru" get back, due to more time to DAZ for smoothing. I can see the progress bar and viewport from DAZ not get full update, but the render viewport of octane is already done !?
to be honest, there wasn't yet a fix for this (i just missed to write it into the "todo" list in the update info post)... a hopefully final fix is to expect for the next update, which should arrive around the weekend...
The obvious is that which is never seen until someone expresses it simply

1x i7 2600K @5.0 (Asrock Z77), 16GB, 2x Asus GTX Titan 6GB @1200/3100/6200
2x i7 2600K @4.5 (P8Z68 -V P), 12GB, 1x EVGA GTX 580 3GB @0900/2200/4400
User avatar
t_3
 
Posts: 2871
Joined: Tue Jul 05, 2011 5:37 pm

Re: Poke through issues in Octane renders?

Postby t_3 » Thu Apr 04, 2013 12:23 am

t_3 Thu Apr 04, 2013 12:23 am
itou31 wrote:Hi,

I just update with the build 2121, something better but not perfect at some keyframe, the "poke thru" get back, due to more time to DAZ for smoothing. I can see the progress bar and viewport from DAZ not get full update, but the render viewport of octane is already done !?

some update about this: what the plugin might do - and what you may already test (if you like to help) is, to activate the "interactive update" for all nodes that have smoothing applied. in theory this should let the plugin already now wait until all the smoothing is done; it would be also interesting to know if and how this works for collisions...

ps; there is next to no documentation about these ds4 features (i mean their use through the daz sdk), so i can make good use of any findings in that area...
The obvious is that which is never seen until someone expresses it simply

1x i7 2600K @5.0 (Asrock Z77), 16GB, 2x Asus GTX Titan 6GB @1200/3100/6200
2x i7 2600K @4.5 (P8Z68 -V P), 12GB, 1x EVGA GTX 580 3GB @0900/2200/4400
User avatar
t_3
 
Posts: 2871
Joined: Tue Jul 05, 2011 5:37 pm

Re: Poke through issues in Octane renders?

Postby itou31 » Thu Apr 04, 2013 7:56 pm

itou31 Thu Apr 04, 2013 7:56 pm
Hi t_3,

Yes ! "interactive update" is the key. The plugin now "wait the DAZ viewport" .
thanks for the tip !
Ok, let's play more in deep with the plugin ...
I7-3930K 64Go RAM Win8.1pro , main 3 titans + 780Ti
Xeon 2696V3 64Go RAM Win8.1/win10/win7, 2x 1080Ti + 3x 980Ti + 2x Titan Black
User avatar
itou31
Licensed Customer
Licensed Customer
 
Posts: 377
Joined: Tue Jan 22, 2013 8:43 am

Re: Poke through issues in Octane renders?

Postby t_3 » Thu Apr 04, 2013 8:00 pm

t_3 Thu Apr 04, 2013 8:00 pm
itou31 wrote:Hi t_3,

Yes ! "interactive update" is the key. The plugin now "wait the DAZ viewport" .
thanks for the tip !
Ok, let's play more in deep with the plugin ...

great! thanks for checking that out - this will be included into the geometry building process for animations, so you don't have to care about changing it by hand...
The obvious is that which is never seen until someone expresses it simply

1x i7 2600K @5.0 (Asrock Z77), 16GB, 2x Asus GTX Titan 6GB @1200/3100/6200
2x i7 2600K @4.5 (P8Z68 -V P), 12GB, 1x EVGA GTX 580 3GB @0900/2200/4400
User avatar
t_3
 
Posts: 2871
Joined: Tue Jul 05, 2011 5:37 pm

Re: Poke through issues in Octane renders?

Postby linvanchene » Thu Apr 04, 2013 10:47 pm

linvanchene Thu Apr 04, 2013 10:47 pm
edited and removed by user
Last edited by linvanchene on Sat Sep 06, 2014 11:46 pm, edited 2 times in total.
User avatar
linvanchene
Licensed Customer
Licensed Customer
 
Posts: 783
Joined: Mon Mar 25, 2013 10:58 pm
Location: Switzerland
PreviousNext

Return to DAZ Studio


Who is online

Users browsing this forum: No registered users and 5 guests

Sun Sep 27, 2020 6:23 pm [ UTC ]