Bugs & Features

Forums: Bugs & Features
SketchUp Integrated Plugin (Integrated Plugin maintained by OTOY)

Bugs & Features

Postby fuzzybro » Sat Sep 06, 2014 12:34 am

fuzzybro Sat Sep 06, 2014 12:34 am
Hi all,

I release new version every 2-3 weeks so it's quite hard to keep track of all the feedback in all these topics.
So let's build a list of all bugs and feature requests here.
Please be concise, one sentence per bug/feature. Screenshots are welcome.

Also don't hesitate to write a PM to remind me of a thing that I might forget.

Yours,
Bro
User avatar
fuzzybro
OctaneRender Team
OctaneRender Team
 
Posts: 562
Joined: Mon Jun 03, 2013 7:10 am
Location: Los Angeles, California

Re: Bugs & Features

Postby smicha » Sat Sep 06, 2014 11:47 am

smicha Sat Sep 06, 2014 11:47 am
Here you are Bro :) Some comments are from my previous posts. Good luck :) And thank you for your hard work.

1. Move along plugin causes SU crash when Octane is active. It crashes when I want to move and copy a group (+ctrl while moving)
http://sketchucation.com/forums/viewtop ... 23&t=57337

2. SketchUV plugin causes crash. Selecting box faces and applying box map causes crash.
http://sketchucation.com/forums/viewtopic.php?t=44501

3. Curviloft causes crash. First a black screen appears and then crash goes.
http://sketchucation.com/forums/viewtopic.php?t=28586
Win7, Modo 10.1, Octane for Modo and Sketchup, nVidia latest, TITAN+3x780 6GB, 2600K, P8P67WS, 32GB, 1350W
SMH10, EK, Airplex_480, SR1_560, 20xNB_PL2, 2xD5, Aquaero 6XT
build-log http://render.otoy.com/forum/viewtopic.php?f=9&t=42540
User avatar
smicha
Licensed Customer
Licensed Customer
 
Posts: 3145
Joined: Wed Sep 21, 2011 4:13 pm
Location: Warsaw, Poland

Re: Bugs & Features

Postby tetrochuan » Fri Jan 23, 2015 6:01 pm

tetrochuan Fri Jan 23, 2015 6:01 pm
feature request(s)

hi there again,
after my first day with the plugin i have some humble requests - most of them are maybe already on a list somewhere or may have been already mentioned but neverrtheless i wanted to share my thougts

1.
2d perspective is there already - if you could make it work in a way that it is in sync also after one moves the sketchup viewport with the hand tool that would be awesome=)

2.
make it possible for the white balance tool to sample colors directly in the octane viewport

3.
materials, texture/image nodes - would be cool if the textures/images already in the scene and used from su and or octane could be fast selected?! maybe a right click solution or dropdown menue inside the material editor?! some kind of copy and paste feature=)

4.
node - color corection -> if selected the before active node should automatically reconnect inside the cc node - this behaiviour should be identical and standard for some other nodes also

5.
settings of octane plugin should be saveable - it would be perfect if they automatically attach themself to the scenes of su...=)
[as i found out settings actually do connect to scenes?! - a bit of info here would be nice, maybe we can have some reset or copy paste features here too or at least a button which makes certain settings of octane standart for some selected scenes..]

6.
settings for individual nodes should be resetable =) - i have found out its difficult to find the standard values for some settings....

7.
materials - images - texture coordinates - there should be a possibility/option that says "use sketchup´s coordinates/scaling etc..." or at lease something to reset this also to what sketchup suggests...

8.
on/off button for all material input main features like displacement or normal/bump etc...

9.
global on/off for features like displacement ?!

10.
make the "," from the number block on the keyboard work ... when inputting stuff i always use the num pad which in europe has a "," only...

11.
drag and drop textures/images from the explorer into the material nodes =)


possible bug(s)

1.
also in the latest beta for su 15 64 bit i have found that sometimes the "connection gets lost" meaning that the material browser and the octane viewport stop showing anything - although there is no error or something! if i manage to find a relation from some user action to the loss of connection i will share the info

2.
if environment texture is kind a sticky... if used once in a session it keeps being there even if a new file is created and the delete octane data button is used =)...

3.
the "invert" does not work for me?!

4.
texture coordinates get lost or are not there - especially for nested nodes it doesnt take the uvs of sketchup into account!?!

5.
after sample or time limit is reached and image is finished its not possible to alter the camera response/imager....

6.
when using texture environment with ambient occlusion kernel i get absolut black ceilings?! in diffuse kernel everything is ok..

7.
after changing the kernels, the max samplessetting in general tab is no more like it should - the info line on the bottom viewport shoes other then the settings...


greetings and happy rendering=)



used is su 15 64 bit with the latest beta plugin...
win7 ultimate 64bit | intel i7-3930k @ 42x100 | asus p9x79 pro | 32 gb ddr3-1600 | 3x780ti @ 1ghz | 2x asus proart pa246 24" | main hdd ocz vertex 4 | some mice keyboard and a wacom intuos4
tetrochuan
Licensed Customer
Licensed Customer
 
Posts: 65
Joined: Tue Mar 23, 2010 6:52 pm

Re: Bugs & Features

Postby rfox » Fri Apr 03, 2015 2:19 am

rfox Fri Apr 03, 2015 2:19 am
Ok, Just tried out the latest update version. I found out Materials window stays blank sometimes and it need to restart Sketchup.
I'm still investigating this version.
3x GTX Titan - Win7 Pro x64 - Intel i7-3930K - ASUS Rampage IV Formula-X79
User avatar
rfox
Licensed Customer
Licensed Customer
 
Posts: 86
Joined: Sat May 01, 2010 5:32 am
Location: State of Lincoln

Return to SketchUp


Who is online

Users browsing this forum: No registered users and 3 guests

Sun Jan 19, 2020 4:46 pm [ UTC ]