Baked textured quality look doesn't match

Forums: Baked textured quality look doesn't match
Maxon Cinema 4D (Export script developed by abstrax, Integrated Plugin developed by aoktar)

Moderator: aoktar

Baked textured quality look doesn't match

Postby vesta » Fri Sep 06, 2019 5:52 pm

vesta Fri Sep 06, 2019 5:52 pm
Hello
I'm testing the export workflow of a baked texture object.
I test a simple cube, I UV uwrapped it and exported the texture map with camera baking tag selected but the material quality doesn't match, when I render the cube in standard mode looks awful. I attached the two cubes (octane one and standard result) for comparison.
thanks a lot!
Peppe
Attachments
cube_standard.png
cube_octane.png
vesta
Licensed Customer
Licensed Customer
 
Posts: 20
Joined: Sun Feb 19, 2017 7:33 am

Re: Baked textured quality look doesn't match

Postby frankmci » Fri Sep 06, 2019 7:49 pm

frankmci Fri Sep 06, 2019 7:49 pm
With a simple one-shot bake like you are doing, you're including illumination info into the texture, as well as the color. Try killing all your lights and piping the baked texture into a black Diffuse Material's Texture Emission slot, and bring the Emission power down to 1.

On the left is the source scene, one material, one light source. On the right is the same scene with three materials, each flat black with the baked textures driving surface emission, and no other light sources.

Screen Shot 2019-09-06 at 3.29.28 PM.png
Simple Baked Scene


You can do multi-pass baking to break out the illumination, diffuse, etc into separate layers, but that's a bit more involved.
Technical Director - C4D, Maya, AE, - Washington DC
frankmci
Licensed Customer
Licensed Customer
 
Posts: 356
Joined: Fri May 26, 2017 2:00 pm

Re: Baked textured quality look doesn't match

Postby vesta » Sat Sep 07, 2019 6:42 am

vesta Sat Sep 07, 2019 6:42 am
thanks a lot for reply, very helpful.
Well, it's the first time doing this kind of things, just a couple of questions:
First I did UV UNWRAP of the whole scene geometry, then with baked camera option on I exported the scene from live viewer, then I cancelled everything beside geometry and applied the texture in standard render mode, now light and shading/shadow works but there is some black wrong parts as you can see from the screenshots attached.

Maybe I'm doing mistakes in UV UNWRAP ?

thanks a lot!
Giuseppe
Attachments
openGL_render.png
octane_render.png
vesta
Licensed Customer
Licensed Customer
 
Posts: 20
Joined: Sun Feb 19, 2017 7:33 am

Return to Maxon Cinema 4D


Who is online

Users browsing this forum: No registered users and 6 guests

Thu Dec 12, 2019 1:50 am [ UTC ]