Unbearable Max UI lag with Octane viewport open

Forums: Unbearable Max UI lag with Octane viewport open
Sub forum for bug reports
Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Re: Unbearable Max UI lag with Octane viewport open

Postby senorpablo » Mon Jan 14, 2019 11:33 pm

senorpablo Mon Jan 14, 2019 11:33 pm
coilbook wrote:
senorpablo wrote:
paride4331 wrote:Hi senorpablo,
I think fps is not so precise and seems discontinuous. As you can see, Octane does not use GPUs after rendering.
Did you use "Quick update mode" in OctaneRender Viewport?
Regards
Paride


In my tests, even when rendering is complete, the performance is severely degraded compared with no open Octane Viewport. I expect you will get the same results. Perhaps my assumption that this is due to GPU utilization is incorrect. Maybe the Octane plugin is slowing Max down on the CPU when the viewport is open? There is also no good reason for the material editor to be so slow. It takes one second for the UI to refresh clicking from one shader to the next, with no parameters changing. It doesn't matter if an Octane viewport is open or not. What is Octane doing in this case that makes it so slow? It takes me back to 1995.

As for the Max fps counter not being accurate, when you get down to below 10 fps you can see and feel that accurately without a readout I think you'll agree.

The Quick update does seem to help the framerate. What does that do and why wouldn't someone want this on all the time?

I have tried my scene on another computer and it's significantly faster at the minimum(down to 10-20 or so instead of 3), but the slowdown is still very significant, compared to 150 fps with no open Octane viewport. And, the material editor is still extremely slow.

Is Octane using callbacks to get messages from Max to decide when to update things, or is it just somehow manually checking all the time, because that's what it feels like.


This is my problem (video attached) similar to yours. Also if octane viewport is opened and I have phoenix fd smoke in the scene and I move time slider then scene gets slow even after closing and reopening it. Octane permanently ruins the scene.


Yeah, in addition to the material editor being slow, I get the modify panel slowdown just like you do.
senorpablo
Licensed Customer
Licensed Customer
 
Posts: 144
Joined: Sun Jun 28, 2015 2:52 am

Re: Unbearable Max UI lag with Octane viewport open

Postby neonZorglub » Tue Jan 15, 2019 2:50 am

neonZorglub Tue Jan 15, 2019 2:50 am
Hi senorpablo,

It sounds like your scene objects or settings generate many unwanted updates..
It could come from some object modifier, or some other plugin.

-Could you try Reset Default settings in Octane Global Preferences menu 'Preset'
-The Quick mode should definitely be enabled.
-In Kernel settings, set the Notify objects on render to Never, or Per object if you use modifier with viewport simpler mesh.
-In the Troubleshooting tab of Global preferences, could you try to enable 'Ignore Base node change' ?
it might disable the real time update of some objects, so it may not be a good solution, but please let me know if that improves the speed.
-Also could you tell me if the render restarts when you navigate in the modifiers or material UI ?

Thanks
neonZorglub
OctaneRender Team
OctaneRender Team
 
Posts: 192
Joined: Sun Jul 31, 2016 10:08 pm

Re: Unbearable Max UI lag with Octane viewport open

Postby coilbook » Tue Jan 15, 2019 4:42 pm

coilbook Tue Jan 15, 2019 4:42 pm
neonZorglub wrote:Hi senorpablo,

It sounds like your scene objects or settings generate many unwanted updates..
It could come from some object modifier, or some other plugin.

-Could you try Reset Default settings in Octane Global Preferences menu 'Preset'
-The Quick mode should definitely be enabled.
-In Kernel settings, set the Notify objects on render to Never, or Per object if you use modifier with viewport simpler mesh.
-In the Troubleshooting tab of Global preferences, could you try to enable 'Ignore Base node change' ?
it might disable the real time update of some objects, so it may not be a good solution, but please let me know if that improves the speed.
-Also could you tell me if the render restarts when you navigate in the modifiers or material UI ?

Thanks


I think there is a problem with octane max. It's just slow. material editor is slow, Hopefully you ca optimize it better
coilbook
Licensed Customer
Licensed Customer
 
Posts: 2262
Joined: Mon Mar 24, 2014 2:27 pm

Re: Unbearable Max UI lag with Octane viewport open

Postby lunarstudio » Mon Jan 21, 2019 6:21 pm

lunarstudio Mon Jan 21, 2019 6:21 pm
I have three monitors on three different GPUs. With the Octane viewport open or even paused, after a while I receive major slowdowns as well. My windows will actually blink on and off with the program not responding.
It almost seems as if it is running into memory issues as textures are added to the material editor.
Running the latest NVidia Drivers on 3 1080s. Didn't have this issue prior to v4.

One other thing I should add is that I updated Octane with the latest Windows updates and NVidia drivers at the same time. Separately, I noticed the latest updates (I believe a Windows update) made one of my Displayports stop functioning and monitor go black and not work at all. I had to switch it back to HDMI. At first I thought it was driver related but even after reverting back to older drivers, the issue still persisted.
lunarstudio
Licensed Customer
Licensed Customer
 
Posts: 49
Joined: Fri May 16, 2014 12:36 pm
Location: Boston, MA

Re: Unbearable Max UI lag with Octane viewport open

Postby coilbook » Mon Jan 21, 2019 7:24 pm

coilbook Mon Jan 21, 2019 7:24 pm
417.35 drivers made my pc very slow. Mouse can barely move.
coilbook
Licensed Customer
Licensed Customer
 
Posts: 2262
Joined: Mon Mar 24, 2014 2:27 pm

Re: Unbearable Max UI lag with Octane viewport open

Postby paride4331 » Tue Jan 22, 2019 3:52 pm

paride4331 Tue Jan 22, 2019 3:52 pm
Hi there,
could you try this too please?
https://render.otoy.com/forum/viewtopic.php?f=80&t=70062&p=355577#p355577
Regards
Paride
Win 7 / i7 5930 - 32gb / 1 x quadro K620 / 2 x Evga Titan X Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 2281
Joined: Fri Sep 18, 2015 7:19 am
Previous

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Fri Mar 22, 2019 1:59 pm [ UTC ]