Page 1 of 4

Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 10, 2010 12:20 pm
by TIG
Here's Version 1022-06
Octane_1022-06.zip
(500.87 KiB) Downloaded 229 times
It has improved error-reporting if the Project-Path has accented/special-characters.
The lingvo files have been updated to suit the changes.
Using an Existing-Project [.ocs] now correctly adjusts the dialog's Project-Path to match.

Everyone is recommended to upgrade to this version. Please consult the README / Help file about installing the files and sub-folders in ../Plugins/ ...

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 10, 2010 1:07 pm
by GuyWydouw
TIG,

With version 06 i get the same error messages like i had with version 05, when i replace it with version 04 everything works.

Error: #<Exception: Invalid Dialog>
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2288:in `get_element_value'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2288:in `getIDvalues'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2288:in `each'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2288:in `getIDvalues'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:247:in `deactivate'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2860:in `select_tool'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2860:in `octane'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane_1022.rb:2861
Error: #<NoMethodError: undefined method `tr!' for nil:NilClass>
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:234:in `activate'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:255:in `select_tool'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2860:in `octane'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane_1022.rb:2861

regards,

Guy

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 10, 2010 8:32 pm
by TIG
Guy

It's working fine for me and many others... :?
Can you confirm that you have all of the files in the correct folders...
I'm pretty sure that there is nothing significant changed in the html file - between the versions you listed...
Can you double-check that the OctaneDialog.html file in the ../Plugins/Octane/ folder is the one currently listed in the zip file.
Have you tried deleting the relevant registry entries for the WebDialogs as I explained in the other post ?

Have you overwritten-files or deleted the earlier versions and then saved the files a 'new' install ???

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sat Sep 11, 2010 4:31 am
by GuyWydouw
TIG,

I've tried overwrite the files, i've tried first delete the old files and copy the new ones. I removed the registry files and i still get the same error. Do you have tested on SU 8 pro?

regards,

Guy

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sat Sep 11, 2010 9:43 am
by TIG
Guy

It's working fine for Sketchup Pro 8 [in fact it was tested many weeks ago, even before that version was made public...]

Here's a screen-shot of the file/folder structure needed in v8 [which is the same as v7] - for the avoidance of doubt...
You should also have the loader Octane_loader.rb, deBableizer.rb and FixReversedFaceMaterials.rb in the ../Plugins/ folder itself.
The sub-folders listed should contain several other files, as itemized in the README...
Capture.PNG

PS: You do need Admin rights etc to make changes to files/folders inside 'Program Files'... I know in Vista it's possible to think you've moved/updated files - as they look as if they are in the right place... BUT they are actually held in a 'compatibility files' folder waiting for an Admin to move them over 'properly'... I don't know if that might be the case in your OS ?

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Wed Sep 15, 2010 7:18 am
by moronicjoker
Same error for me...
Cleaned, reinstalled, edited registry, checked files stucture.

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Wed Sep 15, 2010 10:42 am
by TIG
moronicjoker

Do you have all of the files/sub-folders exactly as illustrated in my recent post - no more no less...
AND are you sure there are no 'rogue copies' of any of these left inside the Plugins folder too - if there are then they could both be partially loading and causing a 'clash' when they do not find files where they should be etc...
If you have inadvertently put some files directly into the Plugins folder and then later you correctly put copies into the correct sub-folders etc, you must ensure those Plugins folder's files are cleaned-up

Also...
Can you open the Ruby Console and the run the Octane Render tool and report any error-messages.
Can you also screen-shot the error message you are getting otherwise...

This is a real puzzle as it's working fine on most v8 installations... :?

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Wed Sep 15, 2010 11:47 am
by moronicjoker
- i followed the readme.txt step by step...
- deleted, uninstalled everything
- tried it on a clean installed new system

... get the same error message like GuyWydouw

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Wed Sep 15, 2010 12:17 pm
by TIG
moronicjoker

Please confirm these error messages and the Ruby Console output.

Also have you checked the contents of the Plugins folder for any rogue files ?

Have you looked at the Registry entries as mentioned in earlier posts - can you take a screen shot of that too...

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Wed Sep 15, 2010 12:30 pm
by GuyWydouw
TIG,

I hope you can find the problem...

CaptureRegedit.JPG

CaptureRuby.JPG

CapturePlugin part 1.JPG

CapturePlugin part 2.JPG

Capture Plugins subdir.JPG


regards,

Guy