Memory leaks in 2019.1.1.0

Forums: Memory leaks in 2019.1.1.0
Sub forum for bug reports

Moderator: juanjgon

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Memory leaks in 2019.1.1.0

Postby aLeXXtoR » Wed Oct 16, 2019 10:00 am

aLeXXtoR Wed Oct 16, 2019 10:00 am
I am rendering a pretty simple scene with growing ivy and every 14-18 frames I need to restart Houdini because of "Not enough GPU memory" error (it renders last 3-4 frames incorrectly — with transparent ivy geomerty and then fails saying that "restart required")

Viewport screenshot: https://i.imgur.com/Aj53Qu8.png
Rendering Stats screenshot: https://i.imgur.com/47yHBzC.png

A. Windows 10
B. GeForce GTX 1660Ti 6Gb
C. 32 Gb RAM
D. Driver version 436.48, 10/01/2019
E. Octane Render Standalone 2019.1
F. 2019.1.1.0
G. Houdini Indie 17.5.360
Win 10 Pro 64bit | GeForce RTX 2070 SUPER 8Gb | AMD Ryzen 7 3700X | 32GB RAM
WebSite
Showreel
User avatar
aLeXXtoR
Licensed Customer
Licensed Customer
 
Posts: 294
Joined: Sat Oct 29, 2011 5:38 pm
Location: Russia, St. Ptetersburg

Re: Memory leaks in 2019.1.1.0

Postby juanjgon » Wed Oct 16, 2019 10:16 am

juanjgon Wed Oct 16, 2019 10:16 am
Hi,

Sorry, this problem can be related to a memory leak that I'm investigating that happens while rendering sequences in full scene reload mode from the main Houdini GUI. I hope to know more about it soon, but meanwhile, the workaround is to render the scene frame by frame, perhaps using a script, hqueue or deadline. You are rendering in full scene reload mode, so the render times while rendering frame by frame should be near the same.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7799
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Memory leaks in 2019.1.1.0

Postby juanjgon » Wed Oct 16, 2019 10:26 am

juanjgon Wed Oct 16, 2019 10:26 am
Can you please send me this scene to use it as a unit test while evaluating the fix for this issue?

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7799
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Memory leaks in 2019.1.1.0

Postby aLeXXtoR » Wed Oct 16, 2019 10:49 am

aLeXXtoR Wed Oct 16, 2019 10:49 am
Sent via PM.

Yes, I have to use the "Full reload" rendering method to make it render animation properly.
Win 10 Pro 64bit | GeForce RTX 2070 SUPER 8Gb | AMD Ryzen 7 3700X | 32GB RAM
WebSite
Showreel
User avatar
aLeXXtoR
Licensed Customer
Licensed Customer
 
Posts: 294
Joined: Sat Oct 29, 2011 5:38 pm
Location: Russia, St. Ptetersburg

Re: Memory leaks in 2019.1.1.0

Postby juanjgon » Thu Oct 17, 2019 12:48 pm

juanjgon Thu Oct 17, 2019 12:48 pm
The new plugin build 2019.1.2.0 just released should have all these memory leaks while rendering in full scene reload mode fixed.

Thanks!
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7799
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Memory leaks in 2019.1.1.0

Postby aLeXXtoR » Thu Oct 17, 2019 2:47 pm

aLeXXtoR Thu Oct 17, 2019 2:47 pm
Thank you! I'll give it a try!
Win 10 Pro 64bit | GeForce RTX 2070 SUPER 8Gb | AMD Ryzen 7 3700X | 32GB RAM
WebSite
Showreel
User avatar
aLeXXtoR
Licensed Customer
Licensed Customer
 
Posts: 294
Joined: Sat Oct 29, 2011 5:38 pm
Location: Russia, St. Ptetersburg

Re: Memory leaks in 2019.1.1.0

Postby aLeXXtoR » Fri Oct 25, 2019 11:05 pm

aLeXXtoR Fri Oct 25, 2019 11:05 pm
Looks like everything works well! Thank you very much!
Win 10 Pro 64bit | GeForce RTX 2070 SUPER 8Gb | AMD Ryzen 7 3700X | 32GB RAM
WebSite
Showreel
User avatar
aLeXXtoR
Licensed Customer
Licensed Customer
 
Posts: 294
Joined: Sat Oct 29, 2011 5:38 pm
Location: Russia, St. Ptetersburg

Re: Memory leaks in 2019.1.1.0

Postby galleon27 » Wed Nov 13, 2019 12:07 am

galleon27 Wed Nov 13, 2019 12:07 am
I think there are still memory leaks in 2019.1.2.0 when using network rendering. I had an issue where it render 100 out of 900 frames then crashes cause not enough memory. It works just fine when i disable network rendering.
Win 10 64bit // GTX 1080 + GTX 1080 Ti // i7 4790k // 16GB // SideFX Houdini // C4D
User avatar
galleon27
Licensed Customer
Licensed Customer
 
Posts: 81
Joined: Wed Jul 15, 2015 11:55 am

Re: Memory leaks in 2019.1.1.0

Postby juanjgon » Wed Nov 13, 2019 9:06 am

juanjgon Wed Nov 13, 2019 9:06 am
galleon27 wrote:I think there are still memory leaks in 2019.1.2.0 when using network rendering. I had an issue where it render 100 out of 900 frames then crashes cause not enough memory. It works just fine when i disable network rendering.


Where do you have the crash, in the master computer or in the render nodes? This sounds like some kind of core issue because there is no code related to the network rendering on the plugin side.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7799
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: Memory leaks in 2019.1.1.0

Postby galleon27 » Wed Nov 13, 2019 10:26 pm

galleon27 Wed Nov 13, 2019 10:26 pm
juanjgon wrote:
galleon27 wrote:I think there are still memory leaks in 2019.1.2.0 when using network rendering. I had an issue where it render 100 out of 900 frames then crashes cause not enough memory. It works just fine when i disable network rendering.


Where do you have the crash, in the master computer or in the render nodes? This sounds like some kind of core issue because there is no code related to the network rendering on the plugin side.

Thanks,
-Juanjo


On the master computer for sure, but it could be on both. Cant really remember.
Win 10 64bit // GTX 1080 + GTX 1080 Ti // i7 4790k // 16GB // SideFX Houdini // C4D
User avatar
galleon27
Licensed Customer
Licensed Customer
 
Posts: 81
Joined: Wed Jul 15, 2015 11:55 am

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Thu Oct 01, 2020 8:27 am [ UTC ]