WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Forums: WEIRD: (C4D Plugin) Live-view not matching Picture Viewer
A public forum for discussing and asking questions about OctaneVR.

WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Postby keeganrms » Tue Oct 16, 2018 1:06 am

keeganrms Tue Oct 16, 2018 1:06 am
Hey there! This is a simple but also very strange problem. Basically, my scene has (cached and baked) dynamics of a skeleton exploding. The Octane Preview looks good, reflecting exactly what I see in the C4d Workspace. But when I send to the Picture Viewer in C4D, none of the dynamics seem to carry over. The attached pictures should make it clear.

I've scoured the forums and other resources to soo what the problem was. The only similar results are things back ~2014 when you had to tell Octane to update the scene continuously. But that seems like it's since been resolved.

Helpful Info:
-Windows 10
-Cinema R19
-Octane Plugin
-GTX 1080ti
-32GB DDR4
Attachments
LiveUpdateProblem_2.jpg
keeganrms
 
Posts: 4
Joined: Mon Jun 06, 2016 4:23 pm

Re: WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Postby aoktar » Tue Oct 16, 2018 1:26 am

aoktar Tue Oct 16, 2018 1:26 am
I don't suppose we have problems like you say. Did you test your objects with standard renderer before octane?
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12672
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Postby keeganrms » Tue Oct 16, 2018 1:39 am

keeganrms Tue Oct 16, 2018 1:39 am
Great question!

I just checked the Standard Renderer and the same problem is occurring. So It's probably not Octane and I'll have to inquire about it on the Maxon forums.

But still, I wonder why it properly sends to the Octane Live Window but not the picture viewer?

Thanks for your help!!
keeganrms
 
Posts: 4
Joined: Mon Jun 06, 2016 4:23 pm

Re: WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Postby aoktar » Tue Oct 16, 2018 2:58 am

aoktar Tue Oct 16, 2018 2:58 am
keeganrms wrote:Great question!

I just checked the Standard Renderer and the same problem is occurring. So It's probably not Octane and I'll have to inquire about it on the Maxon forums.

But still, I wonder why it properly sends to the Octane Live Window but not the picture viewer?

Thanks for your help!!

Yup bingo! It's a common mistake to assume that's a Octane problem!
You see well beucase Live Viewer is using the geometry data from viewport. As what you see in viewport.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12672
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: WEIRD: (C4D Plugin) Live-view not matching Picture Viewer

Postby keeganrms » Tue Oct 16, 2018 3:21 pm

keeganrms Tue Oct 16, 2018 3:21 pm
Follow-Up for anyone else searching online for a fix:

Apparently, C4D's native dynamics engine won't send your cached simulations to render.

If you've baked and cached any dynamics, clear the cache and then your render will work. The problem is now your perfectly art-directed dynamics systems will have to be re-calculated during the rendering process, leading to slightly different (albeit similar) results. So maybe the lesson is to switch to X-Particles? :lol:
keeganrms
 
Posts: 4
Joined: Mon Jun 06, 2016 4:23 pm

Return to OctaneVR Questions & Discussion


Who is online

Users browsing this forum: No registered users and 2 guests

Fri Dec 06, 2019 3:35 am [ UTC ]