Page 1 of 1

Getting Octane to work on Linux

PostPosted: Sat Feb 29, 2020 4:33 am
by itaki
Running NukeX 12.0v5 I'm having problems getting octane to run. I try to make the most simple scene with just a camera, a sphere and an octane node and it's just black.

It's notable that I can create a camera node before creating an octane node just fine, but as soon as I create an octane node, every time I try to create a camera node it errors and says " undefined symbol:_ZN6fbxsdk12FbxAllocSizeEmm

It's also notable that I was able to both run the standalone and the Blender plugin without issue.

As a side note, the manual says to add the plugin location to the NUKE_PATH environment variable and set the LD_PRELOAD variable. I tried dropping this into .bashrc, but it didn't work, so I added the location of the plugin to my file. But thinking that I probably wasn't still setting the LD_PRELOAD variable and that may be the problem, I manually set both of these in my terminal before starting the application, but still have the same problem.

Still wondering where I can set these 2 things permanently. I'm still a noob when it comes to some things on Linux. I'm a VFX artist after all. Not a developer.

Ubuntu 19.10
Nuke 12.0v5
Nvidia 440.59
CUDA 10.1
2 1080ti
128 GB Ram

Re: Getting Octane to work on Linux

PostPosted: Sun Mar 01, 2020 3:59 am
by face_off

I don't think your .bashrc or solutions will work.

My script for running the plugin on Mint 19.2 (which is Ubuntu 18.04) is:

Code: Select all
export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/
export NUKE_PATH=/usr/local/NUKE/12.0/plugins/OctaneRender.bundle
cd /usr/local/Nuke12.0v2

Which specific plugin installer did you use?

Also, FYI, the next version of the plugin will be for Nuke12.1.



Re: Getting Octane to work on Linux

PostPosted: Sun Mar 01, 2020 8:28 pm
by itaki
I see, launching from a script works.