Random Walk / Light Problem

Forums: Random Walk / Light Problem
Generic forum to discuss Octane Render, post ideas and suggest improvements.
Forum rules
Please add your OS and Hardware Configuration in your signature, it makes it easier for us to help you analyze problems. Example: Win 7 64 | Geforce GTX680 | i7 3770 | 16GB

Random Walk / Light Problem

Postby Banti » Sat Jan 23, 2021 6:56 pm

Banti Sat Jan 23, 2021 6:56 pm
I am encountering a strange problem when working with random walk/specular material. Here is a scene in which the model is inside a room which has only 1 big light plane right under the ceiling. There is a second light plane outside the room, it does not effect the interior since it faces away from the room and I dont have a material applied to the window glass. The problem is, when i turn on this second emitter, the skin gets really really dark. It reminds me of when i turn of fake shadow in the specular material.

Here is a picture of the scene when the second (outside of the interior) emitter is turned off, everything is normal:
Without-Second-Emitter.png


And here is how the skin looks like when i turn on the emitter:
With-Second-Emitter.png


Notice that only the skin (specular material with random walk medium) is effected. I tried using diffuse and glossy materials for the skin and this problem does not arise.
Can anyone explain what is going on here? I tried all kinds of settings on the emitters, turning on and off surface brightness and/or normalization.
I really dont know why this is happening.

Here is a link to the orbx file if anyone wants to check the scene. The ceiling emitter is called "Plane"- The emitter outside is called "LightPlane":
https://www.mediafire.com/file/fy0093lh ... .orbx/file
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby Banti » Sun Apr 11, 2021 10:13 am

Banti Sun Apr 11, 2021 10:13 am
Can really no one help with this problem? I just downloaded the newest Octane release and this problem still occurs. Every time I add a light the skin becomes darker....
I could try and make a simpler scene to see if this happens to simple geometries like cubes and spheres too, but I am pretty sure it does...
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby Banti » Sun Apr 11, 2021 10:44 am

Banti Sun Apr 11, 2021 10:44 am
I created a way simpler scene to test this again. I have a Genesis 8 Base Figure from DAZ inside a closed cube primitive. This figure has a specular material + random walk medium applied.
The characters is lighted with a single plane-emitter inside the cube. Now I add another plane-emitter outside the closed cube. The skin immediately becomes dark when I turn on the emitter outside. That is the problem in a nutshell. I dont know why this is happening still.

Skin looks normal without the emitter outside:
Plane_Inside_Only.png



Skin looks dark with the emitter outside:
Plane_Outside_Added.png



Here is the small text scene orbx:
https://www.mediafire.com/file/d8ztsi1a ... .orbx/file

I really hope someone can help here.
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby Erick » Mon Apr 12, 2021 7:42 pm

Erick Mon Apr 12, 2021 7:42 pm
I'm not having one of the later versions of Octane, but could this be related to having the option "Fake shadows" enabled/disabled, in the Specular material?
Does the outcome of the render changes, if ticking/unticking the aforementioned option?
Erick
Licensed Customer
Licensed Customer
 
Posts: 221
Joined: Thu Sep 13, 2012 9:40 am

Re: Random Walk / Light Problem

Postby Banti » Mon Apr 12, 2021 7:58 pm

Banti Mon Apr 12, 2021 7:58 pm
Erick wrote:I'm not having one of the later versions of Octane, but could this be related to having the option "Fake shadows" enabled/disabled, in the Specular material?
Does the outcome of the render changes, if ticking/unticking the aforementioned option?

As far as I am aware, fake shadows always needs to be enabled on specular material if you want to use it as skin material. Fake shadows are enabled in both pictures, I did not change the skin material at all, which is exactly the problem. But I agree, when I turn on the second emitter (outside of the cube) the look of the skin then reminds me of when fake shadows are turned off. But that shouldn happen (since I didnt turn it off obviously). I guess it has to be a bug at this point.


This is how the skin look with fake shadows disabled and the outside emitter is off:
fake-shadows-off_No Emitter.png


And with the outside emitter on:
fake-shadows-off_With Emitter.png


Its barely noticable but the skin still becomes darker ever so slightly, and it shoulnd't because the cube is completely closed, and why would it become darker anyway, I dont get whats going on...
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby Banti » Tue Apr 13, 2021 6:08 pm

Banti Tue Apr 13, 2021 6:08 pm
After some more testing I noticed that this also happens when I turn on and HDRI or Daylight Environment instead of having other light emitters, BUT when I turn off "Importance Sampling" the skin stays the same, no darkening is happening. I tried if the same would happen if I turn down the sampling rate of the light emitters that don't illuminate the skin directly and it does indeed work, but I need to turn down the sampling rate of all other emitters to nearly 0 for the skin to not become dark.

So all in all the skin gets darker with EVERY additional light source that is not directly illuminating the skin and can only be countered by turing down the sampling rate of these sources no nearly zero.

I really hope a dev can help with this issue.
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby wallace » Tue Apr 13, 2021 9:18 pm

wallace Tue Apr 13, 2021 9:18 pm
Banti wrote:I created a way simpler scene to test this again. I have a Genesis 8 Base Figure from DAZ inside a closed cube primitive. This figure has a specular material + random walk medium applied.
The characters is lighted with a single plane-emitter inside the cube. Now I add another plane-emitter outside the closed cube. The skin immediately becomes dark when I turn on the emitter outside. That is the problem in a nutshell. I dont know why this is happening still.

Skin looks normal without the emitter outside:
Plane_Inside_Only.png



Skin looks dark with the emitter outside:
Plane_Outside_Added.png



Here is the small text scene orbx:
https://www.mediafire.com/file/d8ztsi1a ... .orbx/file

I really hope someone can help here.


Hi,

I can't seem to produce the first case in your first image, I assumed that it would just be a matter of disconnecting the emitter outside node, but I still get the darker version (albeit consistently).

Can you confirm a few things:
1. Which Octane version you are using?
2. Are you using RTX on/off?
3. What GPU you are using?

Thanks,
Wallace
User avatar
wallace
OctaneRender Team
OctaneRender Team
 
Posts: 166
Joined: Sun Dec 18, 2016 10:38 pm

Re: Random Walk / Light Problem

Postby Banti » Tue Apr 13, 2021 10:11 pm

Banti Tue Apr 13, 2021 10:11 pm
Hi Wallace,

Thanks for the fast response. I tested this particular scene again and also cannot reproduce it anymore. I uploaded a different scene in which I am able to reproduce it every time (this one is a bit bigger tho, 500mb). Here is the link: https://mega.nz/file/IsxwGawb#9W4be_saxUhITJbZh0hsPC7qwQ5V1jatvynPmZVavAA

To reproduce do the following:
Set the emitter power of "Light Hall" to 50 --> The skin will become dark.
Set the emitter power "Light Hall" to 0 and the skin looks normal again.


1. I use Octane Standalone version 2020.2.3
2. RTX is enabled
3. I use 2x RTX 2070 Super | Windows 10 (20H2) | NVIDIA Driver Version 465.89

Thanks for investigating
Banti
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm

Re: Random Walk / Light Problem

Postby wallace » Wed Apr 14, 2021 5:42 am

wallace Wed Apr 14, 2021 5:42 am
So the issue is that basically fake shadow was meant to only be used for glass with very low roughness with no scattering, so that sun light can get into the rooms with windows that are using this fake shadowed material, inherently it introduces some bias due to the fact you are tracing a direct light straight past the fake shadowed material. Playing with sampling rate increases this bias.

I would suggest you to drop the fake shadow on the specular material or use a diffuse material with the random walk SSS medium.

If you do find this approach being too noisy, you can try increasing the bias to 1.0 in the random walk medium node (for skin).
User avatar
wallace
OctaneRender Team
OctaneRender Team
 
Posts: 166
Joined: Sun Dec 18, 2016 10:38 pm

Re: Random Walk / Light Problem

Postby Banti » Wed Apr 14, 2021 7:53 am

Banti Wed Apr 14, 2021 7:53 am
wallace wrote:So the issue is that basically fake shadow was meant to only be used for glass with very low roughness with no scattering, so that sun light can get into the rooms with windows that are using this fake shadowed material, inherently it introduces some bias due to the fact you are tracing a direct light straight past the fake shadowed material. Playing with sampling rate increases this bias.

I would suggest you to drop the fake shadow on the specular material or use a diffuse material with the random walk SSS medium.

If you do find this approach being too noisy, you can try increasing the bias to 1.0 in the random walk medium node (for skin).



Thank you for the reply and explanation. Unfortunately, disabling the fake shadow for the skin material is not an option since it will darken the skin completely and makes in unusable. Using a diffuse material instead is an option but changes the look of the skin drastically, and not for the better. Is there any chance that the fake shadows function will see a change in the future to circumvent this? Or have an option to use random walk medium with specular materials without fake shadows and have said material not become incredibly dark in the first place?

The reason I am so interestedin this is because in my experience specular material + random walk as a skin material gives the best and most realistic look by far, it seems using anything else is a major step down in regards of realistic skin material.

Anyway, thanks again for your efforts and your reply.

Banti
Banti
Licensed Customer
Licensed Customer
 
Posts: 78
Joined: Sat Nov 16, 2019 9:45 pm
Next

Return to General Discussion


Who is online

Users browsing this forum: No registered users and 9 guests

Fri May 14, 2021 8:31 am [ UTC ]