Octane Network Render Crashes C4D

Forums: Octane Network Render Crashes C4D
Sub forum for bug reports

Moderator: aoktar

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)
H. A detailed description of the issue and steps to reproduce it (Include Screenshots or video capture), as well as an example scene if applicable.
I. Copies of the Octane Log window and Console window outputs (full text attached as a file to your post is recommended).


Please note that reports of issues inside existing threads will be ignored/removed, and reports may be closed if the reporter does not respond to subsequent queries in the thread.

Octane Network Render Crashes C4D

Postby FryD » Sat Jan 30, 2021 10:47 pm

FryD Sat Jan 30, 2021 10:47 pm
Hi,

I've recently upgraded to the enterprise subscription with Network rendering. I have had consistent problems with it either not finishing frames or crashing C4D, resulting in it being quicker not to use it at all or have to consistently babysit the render process.

I am using version 1.5 and 1.5R4 C4D plugin. All versions match on the master and slave and all card drivers are up to date.

I have read as many forum posts as i can find with similar issues. Mine seem to be similar in the fact that it may render 10 frames or it may render 100 but it will eventually crash or hang on a particular frame.

I've attached the log file from C4D and the daemon log.

Really hoping you guys can help as i've got some deadlines coming up and need to get sorted asap.

Thanks in advance for your time!

Windows 10
1 x RTX 2080 on both master and slave
32 GB RAM (master) 16GB Ram (slave)
Cinema 4D R20
Nvidia Driver 461.40
Attachments
octane_daemon_log.txt
Slave Log
(28.96 KiB) Downloaded 21 times
octanelog_report.zip
Master render log
(141.05 KiB) Downloaded 21 times
FryD
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Thu May 30, 2019 12:25 pm

Re: Octane Network Render Crashes C4D

Postby aoktar » Sat Jan 30, 2021 11:12 pm

aoktar Sat Jan 30, 2021 11:12 pm
Are you checking free VRAM during render operation?
What happens without using the network render?
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14087
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Octane Network Render Crashes C4D

Postby FryD » Sun Jan 31, 2021 9:34 am

FryD Sun Jan 31, 2021 9:34 am
The scene only uses 2GB of VRAM and I have just under 8 to play with.

Without Network Rendering on it works fine, I've been rendering off the network since last night and its worked fine with no crashes and weirdly faster than usual per frame, which is confusing.

The project i have coming up will require both master and slave to meet the deadline. I have tried Network with two seperate projects now since purchase and neither has worked smoothly as of yet. Both have been within the VRAM limitations also.
FryD
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Thu May 30, 2019 12:25 pm

Re: Octane Network Render Crashes C4D

Postby aoktar » Sun Jan 31, 2021 11:45 am

aoktar Sun Jan 31, 2021 11:45 am
What's polygon counts and texture amount? Are they heavy to send over network? Data send part could be taking more time than render time
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 14087
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: Octane Network Render Crashes C4D

Postby FryD » Sun Jan 31, 2021 11:56 am

FryD Sun Jan 31, 2021 11:56 am
Tri count is 2.04m. Only 8 textures, no C4D shaders and no external textures like 4k or 8k.

I have attached the scene file for you. Although this has happened on more than one scene so not scene specific, either crash or frame hang as mentioned.

Could it be having xparticles system still in there? or fog volume? Files that previously had issues both had fog but not XP.
Attachments
RIPPLE EFFECT PACKAGE.zip
(8.07 MiB) Downloaded 22 times
FryD
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Thu May 30, 2019 12:25 pm

Re: Octane Network Render Crashes C4D

Postby bepeg4d » Mon Feb 01, 2021 8:37 am

bepeg4d Mon Feb 01, 2021 8:37 am
Hi,
I have tried with your scene, but I have a missing plugin, and the VDB file is missing:
A2A1E78E-4CD2-4DF8-B66B-0B7AA387C986.jpeg


Anyway, please try with the following version and report back:
RIPPLE EFFECT PACKAGE_b.zip
(3.82 MiB) Downloaded 19 times


All the MoGraph cloners didn’t have the render Instance option active, and I have disabled the Subdivision object, and enabled the same option into the Octane Object tag, to apply the subdivision only at render time.

Looking forward for your feedback,
ciao Beppe
User avatar
bepeg4d
Octane Guru
Octane Guru
 
Posts: 8191
Joined: Wed Jun 02, 2010 6:02 am
Location: Italy

Re: Octane Network Render Crashes C4D

Postby FryD » Tue Feb 02, 2021 9:48 am

FryD Tue Feb 02, 2021 9:48 am
Thanks for your work on this Beppe.

I ran the render again last night... no crashes however the skinner object under the octane object tag rendered for frame 1 then the remaining frames it looks like its only rendered the motion blur or something. See attached images...

Other than what the issue is with this particular scene i have an another important question which is:

What are the main things to look out for when rendering a scene with Network Rendering to avoid crashes or frames hanging?

I want to be be able to understand it better and avoid crashes on projects in the future if you may be able to help with this!
Attachments
NETWORK TEST0001.png
NETWORK TEST0000.png
FryD
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Thu May 30, 2019 12:25 pm

Re: Octane Network Render Crashes C4D

Postby bepeg4d » Wed Feb 03, 2021 7:48 am

bepeg4d Wed Feb 03, 2021 7:48 am
Great to hear that it is working again also for you :D

About Motion blur issue, have you tried to reduce the Shutter speed in the camera tag, it seems pretty high now :roll:

In my experience, the most important thing to check for Network rendering, is to not have any c4d shader in the scene, unless it is a Noise or Gradient shader, and only the OSL translation is active in c4doctane Settings/C4D Shaders panel, no auto bake to texture with Net render.

It is also very import to always enable the Render Instance or Multi Instance option for all the c4d objects that have this option, to keep the poly count down, and reduce at minimum the amount of data that needs to be sent per frame.

Always keep the Geometry Control to All Movable Objects in Render Settings/Octane Render /Main tab, and disable the Minimize Net Traffic option in the Kernel panel, unless you have a very slow Network connection.

ciao Beppe
User avatar
bepeg4d
Octane Guru
Octane Guru
 
Posts: 8191
Joined: Wed Jun 02, 2010 6:02 am
Location: Italy

Re: Octane Network Render Crashes C4D

Postby FryD » Wed Feb 03, 2021 9:48 am

FryD Wed Feb 03, 2021 9:48 am
Haha! That would make sense yeah...

Really appreciate these tips mate, thanks again for your time!
FryD
Licensed Customer
Licensed Customer
 
Posts: 5
Joined: Thu May 30, 2019 12:25 pm

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 1 guest

Wed Apr 21, 2021 7:39 pm [ UTC ]