OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Forums: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT
Sub forum for bug reports

Moderator: aoktar

Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)
H. A detailed description of the issue and steps to reproduce it (Include Screenshots or video capture), as well as an example scene if applicable.
I. Copies of the Octane Log window and Console window outputs (full text attached as a file to your post is recommended).


Please note that reports of issues inside existing threads will be ignored/removed, and reports may be closed if the reporter does not respond to subsequent queries in the thread.

OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby Cyticre » Thu Feb 06, 2020 10:19 pm

Cyticre Thu Feb 06, 2020 10:19 pm
--Octane 2019 1.5 crashes every time I open up a scene--

A) WINDOWS 10 1809 HOME
B) 2X NVIDIA (evga) GEFORCE GTX 1080 TIs
C) 64GB RAM
D) NVIDIA STUDIO DRIVER 442.19 RELEASE DATE 2/03/20
E) OCTANE STANDALONE VERSION 2019 1.5 (octane render enterprise
F) OctaneRender plugin version - 2019 1.5
G) CINEMA 4D R20 .059

-----

The scene was built in Octane 2019 1.4. Everytime I open the scene it crashes. If it does not, as soon as I start the live viewer it crashes.

**Please note this does not happen with every file from this project. I opened up these files just a week or two ago. Likely before updating the Nvidia driver and to 2019 1.5.

Any ideas why this is happening?

I am 300+ hours into this project and hoping to resolve this issue as soon as possible.

-----

Please see 2 screen captures of the crash on google drive here:


001-
https://drive.google.com/open?id=1dHYcw ... 9IDedLnYX6


Here is another file from the same project crashing: 002

https://drive.google.com/open?id=1t-syb ... ZKVXroTeJs

------

Thanks for your help.
Cyticre
Licensed Customer
Licensed Customer
 
Posts: 17
Joined: Sat Jan 13, 2018 7:06 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby aoktar » Thu Feb 06, 2020 11:29 pm

aoktar Thu Feb 06, 2020 11:29 pm
CAN YOU PLEASE send BUGREPORT.ZIP and SCENES?
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13697
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby Cyticre » Fri Feb 07, 2020 2:04 pm

Cyticre Fri Feb 07, 2020 2:04 pm
Hi Aoktar,

I just PM you a link to the scene files - I am attaching the bug report here as well.

Thank you for your time.
Attachments
_BugReport.txt
(432.06 KiB) Downloaded 40 times
Cyticre
Licensed Customer
Licensed Customer
 
Posts: 17
Joined: Sat Jan 13, 2018 7:06 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby Cyticre » Fri Feb 07, 2020 2:06 pm

Cyticre Fri Feb 07, 2020 2:06 pm
**Also here is one of the full Bug Reports (.zip) from yesterday which crashed on one of the files**
Attachments
_BugReport.zip
(109.7 KiB) Downloaded 33 times
Cyticre
Licensed Customer
Licensed Customer
 
Posts: 17
Joined: Sat Jan 13, 2018 7:06 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby frankmci » Fri Feb 07, 2020 3:47 pm

frankmci Fri Feb 07, 2020 3:47 pm
Sounds like something has been corrupted in the scene file itself. One of the first things I'd try is start with a fresh scene and import the problem scene into it. Sometimes that's all it takes.

Since it sometimes opens as long as nothing renders, I'd guess it's a shader that's gone bad, or maybe some corrupt geometry. If you can get it open at least, try the old, "delete half of the objects/shaders and see if it works. If not, try deleting the other half. If you can narrow it down that far, do it again, in quarters, then eighths, etc., until the problem is isolated."

Or try opening the scene without the Octane plugin loaded and export the contents to a fresh scene. Then reload the Octane plugin and open the exported scene.

In my experience, it's usually possible to recover from a file corruption, but of course, incremental saves are always your best bet.
Technical Director - C4D, Maya, AE, - Washington DC
frankmci
Licensed Customer
Licensed Customer
 
Posts: 563
Joined: Fri May 26, 2017 2:00 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby Cyticre » Fri Feb 07, 2020 7:07 pm

Cyticre Fri Feb 07, 2020 7:07 pm
@Frankmci - thanks a bunch that seemed to be the best way to fix it for now.

I was able to narrow it down out of the 8 leaves (each had a mix texture) that Leaf #4 was causing a crash every time I clicked on it.

I then deleted the jpg and normal map that Leaf 4 was referencing from the folder under "tex" this allowed me to be able to click on the material without it crashing.

So I tried:

1) Reimporting the material to the folder and reconnecting to the image texture in the nodes - This Caused a Crash
2) Reconnecting a different image to the image texture - DID NOT cause a crash!
3) RENAMING THE FILENAME ON MY HDD OF ALL IMAGE TEXTURES THE NODES WERE REFERENCING - Success!

The images look fine, and nothing has changed about them over the course of the project. They were in fact purchased off of turbo squid as part of the plant model.

But, for some reason they mysteriously were causing octane to crash the second I clicked on just that one material in the materials window.

---
For the next Octane users sake!:

IF YOU ARE HAVING MYSTERIOUS CRASHES TRY RENAMING THE FILENAME ON YOUR HARD DRIVE FOR THE IMAGE TEXTURE(S) BEING REFERENCED BY YOUR IMAGE TEXTURE NODES!

Thanks again Frankmci
Cyticre
Licensed Customer
Licensed Customer
 
Posts: 17
Joined: Sat Jan 13, 2018 7:06 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby frankmci » Fri Feb 07, 2020 9:28 pm

frankmci Fri Feb 07, 2020 9:28 pm
I'm glad that did the trick!

I've seen similar situations where simply re-naming a problem file and re-linking to it fixed some weird behavior, not just render crashes. My best guess is that a cached version of the file gets corrupted, and by changing the name, you force the cache to refresh with uncorrupted data. I've seen this in lots of places, not just Octane or even just in rendering, but in computing in general.

Flushing caches is a very useful, general-purpose problem solving trick, but there's so much caching done on so many levels by so many different processes these days, it's nearly impossible to know where they might have gone bad. And system designers rarely give users the option to manually flush them. Most of the time, they work fine, but when they don't, it can be a bugger to track down.

It's still worth passing on the crash data to Otoy, since the system really should fail more elegantly than crashing out. Bad/corrupted data should cause an error, not a crash, but it's impossible to foresee every contingency.
Technical Director - C4D, Maya, AE, - Washington DC
frankmci
Licensed Customer
Licensed Customer
 
Posts: 563
Joined: Fri May 26, 2017 2:00 pm

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby aoktar » Fri Feb 07, 2020 10:42 pm

aoktar Fri Feb 07, 2020 10:42 pm
Thanks for scene, but no crashes on me. Probably needs missing textures. Also crashes seem at octane.dll, so not directly a plugin issue. Worth to try to activate "Debug" mode in driver control panel. Also disable overclocking and try older drivers.
Activate log outputs and send me c4doctanelog.txt if problem persist after previous steps.
Octane For Cinema 4D developer / 3d generalist

3930k / 16gb / 780ti + 1070/1080 / psu 1600w / numerous hw
User avatar
aoktar
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 13697
Joined: Tue Mar 23, 2010 8:28 pm
Location: Türkiye

Re: OCTANE 2019 1.5 CRASHES EVERYTIME I OPEN A PROJECT

Postby Cyticre » Sat Feb 08, 2020 4:08 pm

Cyticre Sat Feb 08, 2020 4:08 pm
@ Frankmci - awesome thanks again for the info and good to know about the multilayered intricacies of caching. You are right about renaming, I cant tell you how many times renaming a file, a folder, or a layer, whether its Cubase, C4D, Photoshop or even Windows (when trying to delete a folder that apparently cannot be deleted!) has done the trick.

I do wish C4D had options like After Effects to Clear the Cache but from what I understand it does that automatically upon closing the software.

-----

@ Aoktar

Thanks for taking a look at my scene.

Im unfamiliar with what the .dll file does but I will take a look into how to run Debug Mode for the Nvidia 1080 Tis.

Ill be sure to follow those other steps if the problem persists as well.

Thanks again for your help.
Cyticre
Licensed Customer
Licensed Customer
 
Posts: 17
Joined: Sat Jan 13, 2018 7:06 pm

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 4 guests

Tue Dec 01, 2020 7:11 pm [ UTC ]