Camera imager settings not working in exr format

Forums: Camera imager settings not working in exr format
Sub forum for bug reports
Forum rules
Before posting a bug report, please check the following:
1. That the issue has not already been disclosed
2. That the issue is specific to this plugin, and not Octane in general (Try reproducing it in Standalone)
Bugs related to the Octane Engine itself should be posted into the Standalone Support sub-forum.


All bug reports should include the information below, along with a detailed description of the issue and steps to reproduce it.
A. Operating System, including version (i.e. Win 7, OSX 10.11.2, Ubuntu 14.04, etc.)
B. Graphics Card(s) model (i.e. GTX 580 - 3GB, TITAN, etc.)
C. RAM Capacity (i.e. 6 GB)
D. Nvidia driver version (i.e. 7.50, 7.5.22)
E. OctaneRender Standalone version, if installed (i.e. 2.24.2, 2.23, etc.)
F. OctaneRender plugin version (i.e. v2.25 - 2.21)
G. Host application version, including build number if available (i.e. 3ds Max 2016 Build 18.0)

Camera imager settings not working in exr format

Postby anifex3D » Fri Aug 25, 2017 8:20 pm

anifex3D Fri Aug 25, 2017 8:20 pm
When saving an exr file format the camera imager controls are not transferring to the saved exr. I tried with 3ds max gamma hack and without still does not work. All other formats save the camera imager controls when the file saves. This worked before as we always used .exr file format in the past.

3ds Max 2018 with Octane Render 3.06.4 - 4.39
https://anifex.com/ | Win 10 64Bit | i9 - 9920x -128gb ram | (4) RTX Titan 24gb | 3dsMax 2020 Octane Plugin
anifex3D
Licensed Customer
Licensed Customer
 
Posts: 44
Joined: Mon May 20, 2013 1:56 pm

Re: Camera imager settings not working in exr format

Postby paride4331 » Mon Aug 28, 2017 8:11 am

paride4331 Mon Aug 28, 2017 8:11 am
Hi anifex3D,
I gueess I don't fully understand what you mean.
Has not changed anything from previous versions; .exr using linear 1 does not retain information about camera imager unless you save in nonlinear tone mapping.
If so, could you share some screenshots about your workflow?
Regards
Paride
2 x Evga Titan X Hybrid / 3 x Evga RTX 2070 super Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 3010
Joined: Fri Sep 18, 2015 7:19 am

Re: Camera imager settings not working in exr format

Postby anifex3D » Mon Aug 28, 2017 12:27 pm

anifex3D Mon Aug 28, 2017 12:27 pm
See images. Not sure how else to explain it better. Somehow the setting are not correct when saving a .exr file it doesn't matter if you try to save it from the max framebuffer or directly render to a file the .exr is not correct. All other formats, .jpg, .png .tif all keep the correct settings and look. If I uncheck the Nonlinear tone mapping box (which is checked) then it completely changes the image in the live view port not desired.

I am not sure when this difference in the .exr may have occurred as we just recently switched to Max 2018 from Max 2017 and we also made the switch from the older version of Octane 3.06-4.33 to 3.06-4.39. It was working correctly in Max 2017 Octane 3.06-4.33. Thanks.

Octane-1.jpg
Octane-2.jpg
https://anifex.com/ | Win 10 64Bit | i9 - 9920x -128gb ram | (4) RTX Titan 24gb | 3dsMax 2020 Octane Plugin
anifex3D
Licensed Customer
Licensed Customer
 
Posts: 44
Joined: Mon May 20, 2013 1:56 pm

Re: Camera imager settings not working in exr format

Postby paride4331 » Mon Aug 28, 2017 1:37 pm

paride4331 Mon Aug 28, 2017 1:37 pm
Hi anifex3D,
Thanks for your screenshots; I do not think it's a 3dsMax or 4.39 issue, I think 3ds max Gamma & LUT setting was changed since your previous setup:
Rendering> Gamma / LUT set up>
What do you think about it?
Regards
Paride
2 x Evga Titan X Hybrid / 3 x Evga RTX 2070 super Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 3010
Joined: Fri Sep 18, 2015 7:19 am

Re: Camera imager settings not working in exr format

Postby anifex3D » Mon Aug 28, 2017 10:30 pm

anifex3D Mon Aug 28, 2017 10:30 pm
Thanks. :D That was the problem. In Max 2018 by default the Gamma/LUT check box is not checked. I checked it on and the .exr file type now works correctly. Hopefully I can remember to turn that on next year in Max 2019.
https://anifex.com/ | Win 10 64Bit | i9 - 9920x -128gb ram | (4) RTX Titan 24gb | 3dsMax 2020 Octane Plugin
anifex3D
Licensed Customer
Licensed Customer
 
Posts: 44
Joined: Mon May 20, 2013 1:56 pm

Re: Camera imager settings not working in exr format

Postby paride4331 » Tue Aug 29, 2017 8:28 am

paride4331 Tue Aug 29, 2017 8:28 am
Hi anifex3D,
Happy to hear that!
Regards
Paride
2 x Evga Titan X Hybrid / 3 x Evga RTX 2070 super Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 3010
Joined: Fri Sep 18, 2015 7:19 am

Return to Bug Reports


Who is online

Users browsing this forum: No registered users and 2 guests

Thu Jul 02, 2020 9:41 am [ UTC ]