Page 2 of 2


PostPosted: Thu Nov 07, 2013 6:07 pm
by kryptek
I tried specifying my GUID manually in the instance user data and when it came up it had a different GUID in the task manager. When I tried to connect using the GUID in the task manager, the connection kept on timing out. When I used the GUID I specified in the User Data it connected just fine. Just thought I'd share this in case it helps anyone


PostPosted: Thu Nov 07, 2013 8:12 pm
by rogerrabit
By the way, sophos thinks the launch.exe app contains a virus called FakeAV-CX.


PostPosted: Thu Nov 07, 2013 8:24 pm
by Goldorak
Hi Rogerrabit,

Could you send a PM to "CharlieX" with a screenshot so he can look into this. This is the first time we have seen a virus check block the exe, but usually it is installed as part of Autodesk Remote which is an MSI app.

Otherwise, does the native launcher work for you when you try it from

We are trying to get a better understand of the performance differences between pure JavaScript decoder and the native version in different scenarios. The main difference is decoding speed (which is larger on lower end systems) and UDP, which is able to adapt the stream precisely and handle latency better over long distances.

We are very interested in any feedback you could provide, as we plan to tune ORBX monthly with user feedback we get - do we focus on bandwidth, decode speed, etc.

The goal is you should never get less than 60 hz, with at most 80 ms latency even if you are 3000 miles away (i..e East to West coast US).


PostPosted: Fri Nov 08, 2013 2:26 pm
by rogerrabit
I can't try the launch.exe app on my home computer, it crash at startup with a tcp/ip problem. I'm on vista 64bit. I may already be using the port the app tries to use or something.

Here's a screenshot of the info bar running while openctm with a mesh loaded within the browser.


PostPosted: Thu Dec 12, 2013 1:26 am
by thegoldrush
I tried accessing the instance using the url (which I believe should give me a blank screen given that I am using the Linux game console) I get a timeout error.

I tried to provide the GUID using the AWS console and then access url but it didn't work. When I did ssh and tried to obtain to GUID, it did not show up.

Any help would be much appreciated. Thanks


PostPosted: Sat Dec 14, 2013 2:16 am
by Jax
Hi thegoldrush,

Re: the Black screen issue - If you are using the Linux Game Console, and if you did not specify an app/game to run with the START= parameter or via SSH, the black screen is an expected behavior.

This AMI is configure to be launched without a desktop manager, you could test by connecting to the instance with the following URL (replace instance IP/GUID): ... CK=0;GUID=<GUID>;START=/usr/bin/gnome-terminal

Re GUID issue:
In order to specify your own GUID within the User Data under the EC2 console, the instance must be in a stopped state. Once the instance is stopped, you could then select the instance you wish to edit by right clicking on the highlighted instance and select View/Change User Data, then simply fill in the predefined GUID: GUID=xxxxxxxxx


Where the <guid> field is replaced by a randomly generated GUID token. If you require other data to be present in your userdata field, then the GUID field should come first, and must be separated from any other data by an ampersand (&) character, a semicolon (;) character or a newline character.

Note that case is important, and any letters should be the same case as they are supplied to the host.

Note also that if a user supplied token is present, then it overrides the automatic generated token.

Once the above steps have been completed, you could then restart the instance and reconnect with the predefined GUID in your connection URL.

Please PM me if you have any further issues with the service and I'll be happy to assists you.




PostPosted: Thu Dec 19, 2013 6:37 pm
by Albator
Dear Goldorak,

Would you please contact me in PM.

Thank you in advance.


PostPosted: Tue Dec 24, 2013 4:39 am
by Goldorak
Hi Albator,

Got your PM. Love the screen name.

I may have to pass your request along to one of the others as I am not online much this week. We'll help out all we can ;)