Invisible material that casts shadows

Forums: Invisible material that casts shadows
Graphisoft ArchiCAD (Integrated Plugin developed by Paul Kinnane)

Moderator: face_off

Invisible material that casts shadows

Postby ArchPrime » Tue Jul 17, 2018 9:15 am

ArchPrime Tue Jul 17, 2018 9:15 am
Hi, has anyone figured out how to make certain elements in ArchiCAD invisible to the camera, but still cast shadows?

I want to do an ArchiCAD sun study using Octane engine, where from a camera view looking down on the whole building, the roof of the building is invisible so the daylight & shadows cast by walls and windows can be seen, without any daylight getting through the invisible roof.

I saw a reference elsewhere to an option in Octane standalone to make objects invisible to camera - but that does not seem to help in the plugin. I need to use the plugin rather than standalone, so that the ArchiCAD sun study tool can overlay time of day and date information on each frame.

As far as I can tell, the only ArchiCAD model attributes accessible to the plugin are surface materials?
Octane Render for ArchiCAD 21 plugin v3.x | Octane Standalone 3.x
(2 x Nvidia GTX780 + 2x Nvidia 980 Ti) x 6MB VRAM | Intel I7 4470K | 16GB RAM | Windows 10
ArchPrime
Licensed Customer
Licensed Customer
 
Posts: 72
Joined: Thu Sep 25, 2014 11:39 am
Location: New Zealand

Re: Invisible material that casts shadows

Postby paride4331 » Tue Jul 17, 2018 9:43 am

paride4331 Tue Jul 17, 2018 9:43 am
Hi ArchPrime,
I'm not an ArchiCAD skilled but you would check shadow catcher option in diffuse material that you will apply to catch the shadow.
Regards
Paride
Attachments
shc.jpg
Win 7 / i7 5930 - 32gb / 1 x quadro K620 / 2 x Evga Titan X Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 1909
Joined: Fri Sep 18, 2015 7:19 am

Re: Invisible material that casts shadows

Postby ArchPrime » Tue Jul 17, 2018 10:05 am

ArchPrime Tue Jul 17, 2018 10:05 am
paride4331 wrote:Hi ArchPrime,
I'm not an ArchiCAD skilled but you would check shadow catcher option in diffuse material that you will apply to catch the shadow.
Regards
Paride


Thanks Paride

I tried that, but applying material to roof, for me all that enabling the shadow catcher toggle does is make the applied roof material a solid grey (i.e no shadows are being cast upon the roof material). If I reduce opacity to 0, the roof disappears, but then lets the light through rather than casting the required shadow on the floor below.

Am I missing something? Shadow catcher seems to affect whether shadows are cast upon a material rather than by a material...?
Octane Render for ArchiCAD 21 plugin v3.x | Octane Standalone 3.x
(2 x Nvidia GTX780 + 2x Nvidia 980 Ti) x 6MB VRAM | Intel I7 4470K | 16GB RAM | Windows 10
ArchPrime
Licensed Customer
Licensed Customer
 
Posts: 72
Joined: Thu Sep 25, 2014 11:39 am
Location: New Zealand

Re: Invisible material that casts shadows

Postby paride4331 » Tue Jul 17, 2018 12:03 pm

paride4331 Tue Jul 17, 2018 12:03 pm
Hi Archprime,
you should activate "alpha chanel" in your kernel setting. This option removes the background and renders it as transparant (zero alpha).
This can be useful if the user wants to composite the render over another image and does not want the background to be present when shadow catcher is active.
Regards
Paride
Win 7 / i7 5930 - 32gb / 1 x quadro K620 / 2 x Evga Titan X Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 1909
Joined: Fri Sep 18, 2015 7:19 am

Re: Invisible material that casts shadows

Postby ArchPrime » Tue Jul 17, 2018 12:12 pm

ArchPrime Tue Jul 17, 2018 12:12 pm
paride4331 wrote:Hi Archprime,
you should activate "alpha chanel" in your kernel setting. This option removes the background and renders it as transparant (zero alpha).
This can be useful if the user wants to composite the render over another image and does not want the background to be present when shadow catcher is active.
Regards
Paride

THanks Paride

For me enabling alpha channel removes the scene background and makes the roof material black but opaque. If I set opacity to zero for material, it still cast no shadows on the floor below...
Is there something else I should be setting?
Octane Render for ArchiCAD 21 plugin v3.x | Octane Standalone 3.x
(2 x Nvidia GTX780 + 2x Nvidia 980 Ti) x 6MB VRAM | Intel I7 4470K | 16GB RAM | Windows 10
ArchPrime
Licensed Customer
Licensed Customer
 
Posts: 72
Joined: Thu Sep 25, 2014 11:39 am
Location: New Zealand

Re: Invisible material that casts shadows

Postby paride4331 » Tue Jul 17, 2018 12:44 pm

paride4331 Tue Jul 17, 2018 12:44 pm
Hi Archprime,
you have not set opacity to 0.
You can see how to in 3ds Max but sould be the same in Archicad.
https://render.otoy.com/forum/viewtopic.php?f=27&t=60496&p=309529&hilit=+shadow+catcher#p309529
Regards
Paride
Attachments
01.jpg
Win 7 / i7 5930 - 32gb / 1 x quadro K620 / 2 x Evga Titan X Hybrid
User avatar
paride4331
Octane Guru
Octane Guru
 
Posts: 1909
Joined: Fri Sep 18, 2015 7:19 am

Re: Invisible material that casts shadows

Postby ArchPrime » Tue Jul 17, 2018 1:07 pm

ArchPrime Tue Jul 17, 2018 1:07 pm
paride4331 wrote:Hi Archprime,
you have not set opacity to 0.
You can see how to in 3ds Max but sould be the same in Archicad.
https://render.otoy.com/forum/viewtopic.php?f=27&t=60496&p=309529&hilit=+shadow+catcher#p309529
Regards
Paride


Hi, please see attached screenshots showing results with opacity=o vs. opacity=1
You can see that when opacity=o, the roof material cast no shadows, and when it is 1, the roof material is solid black
This is with Alpha Chanel set to enabled in kernel.

roof material opacity 1.jpg
Opacity=1
roof material opacity 0.jpg
Opacity=0
Octane Render for ArchiCAD 21 plugin v3.x | Octane Standalone 3.x
(2 x Nvidia GTX780 + 2x Nvidia 980 Ti) x 6MB VRAM | Intel I7 4470K | 16GB RAM | Windows 10
ArchPrime
Licensed Customer
Licensed Customer
 
Posts: 72
Joined: Thu Sep 25, 2014 11:39 am
Location: New Zealand

Return to Graphisoft ArchiCAD


Who is online

Users browsing this forum: No registered users and 1 guest

Tue Oct 23, 2018 8:05 pm [ UTC ]