Page 1 of 1

Trace Back Error

PostPosted: Sun Aug 04, 2013 8:56 pm
by morphious2013
Getting this error upon initiating Octane Plugin.
Traceback (most recent call last):
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\addons\OctaneRender for Poser\__init__.py", line 73, in Render
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\addons\OctaneRender for Poser\UiManager.py", line 3993, in ShowSetupForm
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\addons\OctaneRender for Poser\MaterialManager.py", line 102, in CreateNodesFromPoserScene
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\addons\OctaneRender for Poser\UiManager.py", line 1143, in fillOctaneMaterialsArray
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\addons\OctaneRender for Poser\UiManager.py", line 1914, in createOctaneMaterial
AttributeError: 'NoneType' object has no attribute 'Value'


Is this an object in the scene that is causing the error? Also, after that the "Converting Material" window stays open forever, and if I close it, open Octane view port, no textures are rendering. Also, in the Materials Tab, nothing is there. Oh Also, I'm using 2014, but traceback references 2012.

Thanks.

Re: Trace Back Error

PostPosted: Sun Aug 04, 2013 10:32 pm
by face_off
From the traceback info, it looks like it is a corrupt Poser material - potentially a bump map issue.

Yes, it is likely caused by a particular object in the scene.
Can you email or post the octaneplugin.log file pls, and I can tell you which material or object is causing the issue.

Paul

Re: Trace Back Error

PostPosted: Sun Aug 04, 2013 11:10 pm
by morphious2013
Yep. Hair object on V4. Deleted it, replaced it. Works fine. How can I determine if a object or the objects material is corrupt? Renders fine in Poser Firefly.

Re: Trace Back Error

PostPosted: Sun Aug 04, 2013 11:40 pm
by face_off
Any geometry which raises an exception will generally be listed as the last item in the octaneplug.log file.

Paul