Page 1 of 1

Live Viewport sometimes doesn't update changes in scene

PostPosted: Tue Nov 19, 2019 7:11 am
by tapanojum
I've had this issue as long as I remember and so does another fellow Daz/Octane user I know. The Viewport doesn't automatically render changes to the scene when rendering. This is very hit and miss. On fresh scenes, it always works. Eventually it will stop auto updating and require a Rebuild Scene for every non-Octane change. To be clear, if I make any changes to an Octane material it will automatically reflect that in the render 100%. However, if I'm changing a pose in a character or some other setting within Daz, it won't work without a rebuild.

I've emailed about this in the past and was recommended to delete the OctaneRender_settings.oczdb. This may have helped temporarily but the problem always returns. I'm posting here to see if anyone else has experienced this and has a solution.

It's obviously not the end of the world to have to rebuild the scene each time. It's a minor inconvenience having to readjust camera focus and wait for the rebuild to occur. Also the option to spot render is removed if you don't notice that the scene didn't update until after the render is finished... although that seems more like the user being at fault :D Any help would be appreciated.

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Tue Nov 19, 2019 7:24 am
by birdovous
I'm encountering this issue as well - time to time. I sort of learned to live with it and am accepting it as a nuisance as it usually goes away after restarting DAZ.

Another similar issue I'm experiencing that requires a scene rebuild is that in some situations when I open the Octane viewport for the first time, characters in the scene are rotated incorrectly and a scene rebuild is required to fix that.

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Tue Nov 19, 2019 9:30 am
by face_off
Hi. Yes, I have encountered this from time to time, but not been able to identify the cause. If you encounter a way to reproduce this issue with 100% certainty, I can investigate further.

Paul

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Wed Nov 20, 2019 12:48 am
by tapanojum
face_off wrote:Hi. Yes, I have encountered this from time to time, but not been able to identify the cause. If you encounter a way to reproduce this issue with 100% certainty, I can investigate further.

Paul


If you work on a scene long enough, you will 100% reproduce this issue. I work 4-6 hours as a minimum daily and end up not being able to see the Viewport update live at at some point in the day, every single day. I've now migrated to a brand new dedicated rig and am experiencing this issue just as often as I did on my old setup. I would argue that this issue is experienced by all Daz Octane users.

I will test to see if closing/reopening Daz temporarily fixes the issue. I know for certain that starting a fresh scene temporary fixes it. Really unproductive to have to re-render an entire scene when all you needed to do was spot render a facial expression change for example.

Edit: Rereading this, I realize I sound like I'm asking you to play around with a scene for 6 hours in hopes of recreating it. I only meant that there seems to be some connection with length of use for creating this bug.

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Sat Nov 23, 2019 9:40 am
by rajib
Yes, this happens a lot when one is continuously using Daz and rendering in Octane for a couple of hours. It is a known issue.

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Sun Nov 24, 2019 8:28 am
by tapanojum
rajib wrote:Yes, this happens a lot when one is continuously using Daz and rendering in Octane for a couple of hours. It is a known issue.


It's a known issue that I've experienced every day since I first started using Octane 11 months ago. There's got to be a way to address it. Really slows down production when you have to re-render or close Daz and reload the entire scene.

Re: Live Viewport sometimes doesn't update changes in scene

PostPosted: Sat Dec 21, 2019 4:32 am
by rajib
It probably can be addressed if Paul commits to a rewrite of the Daz Plugin. But he has already said many times that it is not going to be possible for him.... and so we continue to suffer the many issues with the plugin year after year....