Page 2 of 6

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Fri Mar 22, 2019 12:18 am
by face_off
May I request that licensing/upgrade discussions not be held in this thread - as it is meant for the 2018 build of the plugin. Licensing/upgrade comments can be made in the thread at https://render.otoy.com/forum/viewtopic.php?f=7&t=69646.

Thanks

Paul

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Fri Apr 05, 2019 7:25 pm
by rajib
Hi Paul,

I got the 2018.1 plug today. So far okay. Will let you know if I find anything particular. V4 still crashes on me often. Trying a fairly heavy scene with 740+ textures loaded and with volumetric fog / mist. Will see if it finishes the render or crashes.

Best regards,
Rajib

Update :
Pretty good. Have been at it for some time now. Things that would have easily crashed the V4 plugin for me seems to be fine in this version. Fingers cossed that it stays that way. It is 4:30am. Gotta get some sleep. Will continue the testing later.

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Fri Apr 05, 2019 8:42 pm
by rajib
Hi Paul,

Before I log off I have a question. I have been playing with the Emission / Texture Emission of the volumetric medium (Octane -> Environment -> Medium / Scattering) for testing the fog / mist. Does it always light the volume from back to front ? It there a way to control the direction of the Emission / Texture Emission ? I tried the scattering direction but that did nothing.

Best regards,
Rajib

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Mon Apr 08, 2019 3:43 am
by face_off
Before I log off I have a question. I have been playing with the Emission / Texture Emission of the volumetric medium (Octane -> Environment -> Medium / Scattering) for testing the fog / mist. Does it always light the volume from back to front ? It there a way to control the direction of the Emission / Texture Emission ? I tried the scattering direction but that did nothing.
May I suggest posting this question in the general Octane forums.

Paul

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Mon Apr 08, 2019 11:38 am
by rajib
face_off wrote:
Before I log off I have a question. I have been playing with the Emission / Texture Emission of the volumetric medium (Octane -> Environment -> Medium / Scattering) for testing the fog / mist. Does it always light the volume from back to front ? It there a way to control the direction of the Emission / Texture Emission ? I tried the scattering direction but that did nothing.
May I suggest posting this question in the general Octane forums.

Paul


Will do Paul.

Also an update of my use of 2018.1 version until now. It is a lot more stable. Whatever code changes Otoy did, it has resulted in better stability for me. 3 crashes in 3 days. That is nothing compared to very frequent crashes I used to get. I will update further once I do some further testing.

Update :
Enabling Denoiser on more than one GPU is still fairly unstable for me. So for the time being setting it to use only one GPU. The Denoiser effect is pretty okay even with one GPU.

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Sun Apr 21, 2019 6:03 am
by Sorel
Greetings Paul.

on v2018.1.0 I appear to be having a problem with a set using instances. I dont know if it was like this in v4 but I guess instances have always been an issue with this plug-in. I have attached some screenshots.

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Sun Apr 21, 2019 6:36 am
by RGUS
Sorel wrote:Greetings Paul.

on v2018.1.0 I appear to be having a problem with a set using instances. I dont know if it was like this in v4 but I guess instances have always been an issue with this plug-in. I have attached some screenshots.


Yes, it is a problem with v4 as well... everything is compatible except the things that aren't.

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Sun Apr 21, 2019 7:43 am
by rajib
Sorel wrote:Greetings Paul.

on v2018.1.0 I appear to be having a problem with a set using instances. I dont know if it was like this in v4 but I guess instances have always been an issue with this plug-in. I have attached some screenshots.


Yup, instances have always been a problem since V3 (Not sure regarding V2 because never used instances with V2). Though I must say Paul has worked with us to solve a lot of the instances issues and I would say they are mostly usable now but there are situations where they are still a problem. I am preparing a test file for him and will PM him that this coming week. Hopefully that will help to debug some of the unresolved issues. One thing you can try to do is do the rebuild scene. That sometimes helps.

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Sun Apr 21, 2019 12:11 pm
by rajib
Hi Paul,

There is a bug in all the version (2018.1, V4, V3). If an wearable object (shoes / clothing) has a surface named 'Face' and the wearable object is fitted to the character, the plugin does not show the surface name 'Face' under the Materials Tab for that wearable object. You cannot set any materials for it as the surface is not recoganized. I had faced this earlier but never could figure out why the material would not set on that surface. Today I noticed that the 'Face' surface itself was not being shown in the Octane Material Tab. Clicking on the surface in Octane Viewport to edit it in NGE actually loaded the 'Face' material of the character in the NGE.

DazSurfaces.jpg
Original Daz Surfaces which includes 'Face'
DazSurfaces.jpg (13.82 KiB) Viewed 1122 times


OctaneSurfaces.jpg
In Octane, the 'Face' is missing
OctaneSurfaces.jpg (8.63 KiB) Viewed 1122 times


TextureMissingInOctane.jpg
Sample render that show the material in the Daz Viewport and the missing material in the Octane Viewport


Now if I were to load the same wearable object (shoes in my case) in an empty scene, the 'Face' will show up under the Octane Material Tab and in the Octane Viewport everything will be okay.

FacePresentIfNoCharacterIsLoaded.jpg
'Face' surface present if there are no characters present on the scene it is fitted to.
FacePresentIfNoCharacterIsLoaded.jpg (8.75 KiB) Viewed 1122 times


AllOkIfNoCharacterInTheScene.jpg
The 'Face' material renders in Octane Viewport as long as there is no character on the scene it is fitted to.


Hope you can resolve this.

Best regards,
Rajib

Re: OctaneRender 2018 for DAZ Studio [TEST and STABLE]

PostPosted: Thu Apr 25, 2019 12:16 am
by face_off
on v2018.1.0 I appear to be having a problem with a set using instances. I dont know if it was like this in v4 but I guess instances have always been an issue with this plug-in. I have attached some screenshots.
I believe that issue has been there for a long time. I have been gradually trying to fix instance issues, but there are still some problems. I suspect in most cases, the issue is if you have nested instances - which do not directly translate to the DAZStudio plugin - which only support a single Scatter node. If you can send me a small sample scene which reproduces this issue, please send it to me and I will take another look.

Paul