OctaneRender 3 for DAZ Studio [TEST and STABLE]

Forums: OctaneRender 3 for DAZ Studio [TEST and STABLE]
DAZ Studio (Export Script Plugin developed by Tugpsx; Integrated Plugin maintained by Paul Kinnane)
Forum rules
Please keep character renders sensibly modest, please do not post sexually explicit scenes of characters.

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Sun May 20, 2018 6:56 pm

Fanthomas Sun May 20, 2018 6:56 pm
If I want to mess around with the textures, or render a more complex layout, the rendering engine gets stuck.
Even reloading the geometry does not change it.
I already thought my video cards were broken and have my old installed, but is the same problem.
Have my old Windows 7 loaded where once everything has worked, again the same problem.
Here is the logg with 2 GTX 970 cards from MSI:
19: 04: 08.127: +++++ plugin running.
19: 11: 08.772: CUDA error 719 on device 0: unspecified launch failure
19: 11: 08.776: -> kernel execution failed (kernel25)
19: 11: 08.781: CUDA error 719 on device 1: unspecified launch failure
19: 11: 08.785: CUDA error 719 on device 0: unspecified launch failure
19: 11: 08.790: -> kernel execution failed (kernel25)
19: 11: 08.796: -> failed to launch kernel (kernel34)
19: 11: 08.804: CUDA error 719 on device 1: unspecified launch failure
19: 11: 08.814: device 0: path tracing kernel failed
19: 11: 08.828: -> failed to launch kernel (kernel34)
19: 11: 08.828: device 1: path tracing kernel failed
19: 11: 08.829: Render engine failure occured! (WARNING)
19: 11: 11.836: Render engine failure occured! (WARNING)

Since the logg with a GTX 780 and a GTX 760:
19: 51: 33.072: +++++ plugin running.
20: 35: 15.426: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.436: -> kernel execution failed (kernel25)
20: 35: 15.445: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.454: -> failed to launch kernel (kernel34)
20: 35: 15.463: device 0: path tracing kernel failed
20: 35: 15.481: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.481: Render engine failure occured! (WARNING)
20: 35: 15.490: -> failed to set texture format (__ data24__)
20: 35: 15.499: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.508: -> failed to set texture format (__ data26__)
20: 35: 15.509: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.517: -> failed to set texture format (__ data29__)
20: 35: 15.525: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.531: -> failed to set texture format (__ data30__)
20: 35: 15.540: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.546: -> failed to set texture format (__ data27__)
20: 35: 15.555: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.564: -> failed to deallocate device memory
20: 35: 15.573: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.582: -> could not get memory info
20: 35: 15.591: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.599: -> failed to deallocate device memory
20: 35: 15.607: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.613: -> could not get memory info
20: 35: 15.618: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.623: -> failed to deallocate device memory
20: 35: 15.625: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.630: -> could not get memory info
20: 35: 15.631: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.636: -> failed to deallocate device memory
20: 35: 15.637: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.642: -> could not get memory info
20: 35: 15.646: Failed to free page-locked memory
20: 35: 15.650: Failed to free page-locked memory
20: 35: 15.654: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.659: -> failed to deallocate device memory
20: 35: 15.663: CUDA error 700 on device 0: illegal memory access was encountered
20: 35: 15.667: -> could not get memory info

Current Nvida driver version. v397.64
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Mon May 21, 2018 9:18 am

Fanthomas Mon May 21, 2018 9:18 am
Octane Render for DAZ Studio v3.6.5.33
Current Nvidia driver version: v397.64
Loog:
09:57:58.213: +++++ Plugin running.
11:10:55.006: CUDA error 2 on device 1: out of memory
11:10:55.007: -> failed to allocate device memory
11:10:55.007: device 1: failed to upload data texture 1 of context 0
11:10:55.115: Render engine failure occured! (WARNING)

Also with this version I have the same problem
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Mon May 21, 2018 9:59 am

Fanthomas Mon May 21, 2018 9:59 am
Octane Render for DAZ Studio v3.5.3.30
Current Nvidia driver version: v397.64

Loog:
11:24:53.417: +++++ Plugin running.
11:37:19.265: CUDA error 2 on device 0: out of memory
11:37:19.265: -> failed to allocate device memory
11:37:19.265: device 0: failed to upload data texture 4 of context 0
11:37:19.265: device 0: detected an error on render device! trying to recover...
11:37:22.088: CUDA error 719 on device 1: unspecified launch failure
11:37:22.097: -> kernel execution failed(report)
11:37:22.104: CUDA error 719 on device 1: unspecified launch failure
11:37:22.112: -> failed to launch kernel(ptBrdf2)
11:37:22.121: device 1: path tracing kernel failed
11:37:22.126: device 1: detected an error on render device! trying to recover...
11:37:22.131: CUDA error 719 on device 0: unspecified launch failure
11:37:22.137: CUDA error 719 on device 1: unspecified launch failure
11:37:22.141: -> failed to launch kernel(init4)
11:37:22.145: -> failed to deallocate device memory
11:37:22.149: device 0: path tracing kernel failed
11:37:22.153: device 0: the device failed immediately after the recovery -> giving up and switching the device into error state
11:37:22.164: CUDA error 719 on device 1: unspecified launch failure
11:37:22.164: -> could not get memory info
11:37:22.165: Render engine failure occured! (WARNING)
11:37:22.167: CUDA error 719 on device 1: unspecified launch failure
11:37:22.171: -> failed to deallocate device memory
11:37:22.175: CUDA error 719 on device 1: unspecified launch failure
11:37:22.178: -> could not get memory info
Deleted repetitions
11:37:22.537: CUDA error 719 on device 1: unspecified launch failure
11:37:22.541: -> failed to deallocate device array
11:37:22.544: CUDA error 719 on device 1: unspecified launch failure
11:37:22.547: -> could not get memory info
11:37:22.551: CUDA error 719 on device 1: unspecified launch failure
11:37:22.555: -> failed to deallocate device array
11:37:22.558: CUDA error 719 on device 1: unspecified launch failure
11:37:22.562: -> could not get memory info
11:37:22.566: Failed to free page-locked memory
11:37:22.569: Failed to free page-locked memory
11:37:22.572: CUDA error 719 on device 1: unspecified launch failure
Deleted repetitions
11:37:22.642: CUDA error 719 on device 1: unspecified launch failure
11:37:22.645: -> could not get memory info
11:37:22.649: CUDA error 719 on device 1: unspecified launch failure
11:37:22.652: -> failed to deallocate device array
11:37:22.656: CUDA error 719 on device 1: unspecified launch failure
11:37:22.659: -> could not get memory info
11:37:22.662: Failed to free page-locked memory
11:37:22.667: CUDA error 719 on device 1: unspecified launch failure
11:37:22.671: -> failed to deallocate device array
11:37:22.674: CUDA error 719 on device 1: unspecified launch failure
11:37:22.677: -> could not get memory info
11:37:22.681: CUDA error 719 on device 1: unspecified launch failure
11:37:22.684: -> failed to deallocate device array
Deleted repetitions
11:37:22.774: CUDA error 719 on device 1: unspecified launch failure
11:37:22.781: -> could not get memory info
11:37:22.785: Failed to free page-locked memory
11:37:22.788: CUDA error 719 on device 1: unspecified launch failure
11:37:22.791: -> failed to deallocate device array
11:37:22.795: CUDA error 719 on device 1: unspecified launch failure
11:37:22.798: -> could not get memory info
11:37:22.801: Failed to free page-locked memory
11:37:22.805: Failed to free page-locked memory
11:37:22.808: CUDA error 719 on device 1: unspecified launch failure
11:37:22.811: -> failed to deallocate device array
11:37:22.814: CUDA error 719 on device 1: unspecified launch failure
11:37:22.817: -> could not get memory info
11:37:22.821: CUDA error 719 on device 1: unspecified launch failure
11:37:22.825: -> failed to deallocate device array
11:37:22.828: CUDA error 719 on device 1: unspecified launch failure
11:37:22.831: -> could not get memory info
11:37:22.834: Failed to free page-locked memory
Deleted repetitions
11:37:22.840: CUDA error 719 on device 1: unspecified launch failure
11:37:22.844: -> failed to deallocate device memory
Deleted repetitions
11:37:23.271: -> failed to bind device to current thread
11:37:23.279: device 1: failed to initialize resources
11:37:23.287: device 1: failed to recover - giving up and switching device to failed
11:37:25.171: Render engine failure occured! (WARNING)


Actually I did not have these problems until version 3.6, now no version seems to work anymore.

I have uninstalled the previous version cleanly and even made a reboot then installed the v.3.5.3.30 first, but it did not work.
I'm finished with my Latin, so I can not use Octane Render.

Greetings Thomas
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby face_off » Tue May 22, 2018 11:30 pm

face_off Tue May 22, 2018 11:30 pm
11:10:55.006: CUDA error 2 on device 1: out of memory
Hi Thomas - it looks like you are running out of VRAM. Have you got out-of-core textures turned on? What are your system and graphics card specs pls?

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12434
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Wed May 23, 2018 3:57 pm

Fanthomas Wed May 23, 2018 3:57 pm
The data is actually in my signature anyway, out-of-core memory, I put on highest setting, but this setting is zero after each restart.
But even in the full out of core attitude, I had the problem.
Now I have returned to version v3.7.0.37 with the same old Nvidia driver v390.65 and this works so far without problems.

Motherboard Model: MSI X99A SLI PLUS (MS-7885)
Processor Name: Intel Core i7-5820K
Total Memory Size: 32 GB
Video Chipset: 2X NVIDIA GeForce GTX 970 4GB
Windows 10 ultimate

Thomas
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby face_off » Thu May 24, 2018 1:12 am

face_off Thu May 24, 2018 1:12 am
The data is actually in my signature anyway, out-of-core memory, I put on highest setting, but this setting is zero after each restart.
But even in the full out of core attitude, I had the problem.
Now I have returned to version v3.7.0.37 with the same old Nvidia driver v390.65 and this works so far without problems.
Thomas, could you pls try to export the scene as ORBX and see if that error occurs in Octane Standalone 3.08.1 with that scene?

Thanks

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12434
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby face_off » Thu May 24, 2018 1:18 am

face_off Thu May 24, 2018 1:18 am
Also Thomas.....

I see references to Device 0 and Device 1, which implies you have 2 graphics cards, but you have only listed the GTX 970. Is there another card in your system?

And is this error happening with all scenes, or just one?

If the Out-Of-Core settings are not saving, try deleting OctaneRender_settings.oczdb as instructed at the top of this thread.

Thanks

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12434
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Thu May 24, 2018 4:29 pm

Fanthomas Thu May 24, 2018 4:29 pm
I have 2 graphics cards: Video Chipset: 2X NVIDIA GeForce GTX 970 4GB
I'll try it with the deleting OctaneRender_settings.oczdb

Thomas
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby Fanthomas » Fri May 25, 2018 4:20 pm

Fanthomas Fri May 25, 2018 4:20 pm
I deleted Octane Render settings.ocz.
After a few material settings came again the error.
Octane-System-Settings3.gif
Motherboard Model:MSI X99A SLI PLUS(MS-7885)
Processor Name:Intel Core i7-5820K
Total Memory Size:32 GBytes
Video Chipset:2X NVIDIA GeForce GTX 970 4GB
GeForce Game Ready Driver Version: 376.33
User avatar
Fanthomas
 
Posts: 18
Joined: Thu Jul 28, 2011 6:33 pm
Location: Austria, Burgenland

Re: OctaneRender 3 for DAZ Studio [TEST and STABLE]

Postby face_off » Wed May 30, 2018 12:32 pm

face_off Wed May 30, 2018 12:32 pm
I deleted Octane Render settings.ocz.
After a few material settings came again the error.
It is saying it's running out of VRAM. 4GB is not enough to handle the geometry and textures you are using in the scene (together with the overhead that Windows requires).

Paul
Win7/Win10/Mavericks/Mint 17 - GTX550Ti/GT640M
Octane Plugin Support : Poser, ArchiCAD, Revit, Inventor, AutoCAD, Rhino, Modo, Nuke, DAZ Studio
Pls read before submitting a support question
User avatar
face_off
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 12434
Joined: Fri May 25, 2012 10:52 am
Location: Adelaide, Australia
PreviousNext

Return to DAZ Studio


Who is online

Users browsing this forum: No registered users and 4 guests

Mon Jul 16, 2018 4:35 am [ UTC ]