OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Forums: OctaneRender 2019.1 LightWave Production build 2019.1.2.0
Newtek Lightwave 3D (exporter developed by holocube, Integrated Plugin developed by juanjgon)

OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby juanjgon » Fri Oct 18, 2019 3:33 pm

juanjgon Fri Oct 18, 2019 3:33 pm
Hi,

This is a stable release of the OctaneRender™ 2019.1 for LightWave™ plugin version 2019.1.2.0, available for LightWave 11.6, 2015.3, 2018.0 and 2019.0/2019.1 Windows x64 and OSX. This build has been compiled using the Octane 2019.1.2 core.

To use Octane 2019.1, you need to have a Studio or Enterprise subscription license. We recommend that you upgrade your NVIDIA driver to version 419.17 or newer.

New features
To learn more about the new features and improvements of OctaneRender 2019.1, please check out the 2019.1 release post, but this a quick list of the main new features that have been added:

  • Improved volume AI Denoiser.
  • OSL and procedural vertex displacement and displacement mixer, including auto-bump shading.
  • OSL Shaders for volume textures.
  • Layered materials, including all the new material layers nodes.
  • Composite material node.
  • Universal material thin wall option.
  • New rounded edges, including the new round edges nodes replacing the old options available in the material nodes.
  • Bloom/glare threshold.
  • AI Up-sampler options in the imager node.
  • Increase maximum number of alpha intersections to 200. This fixes some scenes that have a huge amount of alpha maps.
  • Added the affect roughness option to kernel nodes "The percentage of roughness affecting subsequent layers' roughness"
  • Spectron volumetric spot lights.


Release 2019.1.2.0 Enterprise subscription license
https://render.otoy.com/customerdownloa ... rprise.zip
https://render.otoy.com/customerdownloa ... rprise.zip

Release 2019.1.2.0 Studio subscription license
https://render.otoy.com/customerdownloa ... studio.zip
https://render.otoy.com/customerdownloa ... studio.zip

Release 2019.1.2.0 Demo versionlicense
https://render.otoy.com/plugindownloads ... 4_demo.zip
https://render.otoy.com/plugindownloads ... X_demo.zip

Standalone 2019.1.2 version for the network rendering nodes
viewtopic.php?f=24&t=72891


Release Notes:
=============================================
RELEASE 2019.1.2.0
=============================================

* PLUGIN FEATURES AND FIXES:

- Fixed a bug in the procedural mesh volume objects rendering.
- Fixed a minor text overlapping issue in the render window.

* OCTANE FEATURES AND BUGS FIXED:
- Fixed toon material rendering incorrectly for camera toon light.
- Fixed toon material causing a render failure in the material preview.
- Fixed multi-layered material not outputting multi-layered bump mapped / mapped normals in info passes
- Fixed volume render inconsistency when using legacy mode.
- Fixed incorrect denoiser output when enablign some light passes.
- Fixed upsampler not working properly for the very first time on some GPUs (this does not fix the upsampler on Win 7, which is still an unsolved problem).
- Fixed kernel crash when using accurate rounded edges if adjacent geometry of an edge is a displacement triangle.
- Fixed discontinuities in shading normals for some cases when using fast rounded edges.
- Fixed a bug in the vertex normal calculation of vertex displacement geometry which was causing the geometry to look facetted when using the join unwelded vertices option.
- Fixed net render slave crash when a scene contains images compressed on the master.


=============================================
RELEASE 2019.1.1.0
=============================================

* OCTANE FEATURES AND BUGS FIXED:

- Fixed incorrect rendering of net render slaves.
- Fixed crash when trying to render preview if a material that uses vertex displacement.
- Fixed the diffuse channel of the metal material node to render black if it's not connected.
- Fixed render failure in the material preview of shadow catcher materials.
- Fixed anisotropy not working with values ranged between [-1 .. 0).
- Fixed render failure when rendering volumes with scattering media.
- Fixed fall off node not taking bump/normal map into account.
- Fixed dielectric 1/IOR map not working with dielectric layer.
- Fixed incorrect rendering of sheen when the diffuse and specular channels are both 0.
- Fixed incorrect compilation of OSL code in some cases.
- Fixed legacy volume render not matching between 2018.1. (To enable the legacy mode tick Emulate old volume behavior in the kernel settings)
- Disabled AI upsampling if the output is a linear (unclamped) HDR image, because it is currently not supported.


=============================================
RELEASE 2019.1.0.5
=============================================

* PLUGIN FEATURES AND FIXES:

- Addressed the image distortion problems when the upsampling was enabled.
- New Octane String and Enum nodes that can be used with the OSL nodes to support these kinds of parameters.

* OCTANE FEATURES AND BUGS FIXED:
- Improved AI Denoiser
- Fixed mix material not consistent with rendering specular layer + diffuse material when swapping input pins.
- Fixed energy conservation for universal layer BSDF
- Fixed _getUV() and getattribute("hit:uv", uvs) not working in some cases
- Fixed picking when upsampling is enabled
- Fixed toon outline always rendering black
- Fixed shared toon materials only rendering correctly on one object, the rest black
- Fixed glossy material always triggering full shader rebuilds
- Fixed render failure when using accurate rounded edges with displacement triangles.
- Fixed issue that would cause discontinuities in interpolated vertex normals in primitives which geometric and vertex normals would be in opposite hemispheres.
- Moved affect roughness setting into specular layer and sheen layer node.
- Layered material: Fixed incorrect direct reflection renderpass from layered material.
- Layered material: Fixed dirt texture when used with layered materials
- Fixed multiple cases of unnecessary rebuilding of geometry that were assigned with vertex displacement
- Fixed refract alpha issue not renering the transparency on specular material
- Universal material: Fixed universal material pins to specify transmission type instead of multiple BxDF types as it was confusing
- Universal material: Fixed universal material layer with thin wall, and also planar behavior
- Universal material: Fixed universal material rendering specular material when given no diffuse, no transmission and coating only.
- Universal material: Fixed universal material fake shadow rendering incorrectly on diffusely transmissive materials
- Universal material: Fixed universal material not emitting light (when specular reflection is not black)
- Universal material: Fixed universal material inconsistency when refraction or transmission is not black
- Universal material: Fixed universal material not doing total internal reflection when diffuse color is not black
- Fixed universal material not updating when switching metallic mode.
- Fixed denoiser issues with layered material + fake shadow + diffuse layer on top of specular materials.
- Fixed incorrect render pass behaviour sometimes when there are no volumes in the scene.
- Fixed denoiser beauty pass getting garbage when certain denoiser passes are enabled.
- Fixed missing self-shadowing in the general and layered shadow passes.
- Fixed alpha channel in alpha passes if alpha is disabled in the kernel settings.


Happy rendering,
Your OTOY Team
Last edited by juanjgon on Mon Nov 11, 2019 5:57 pm, edited 1 time in total.
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7056
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby nico_cad » Fri Oct 18, 2019 3:53 pm

nico_cad Fri Oct 18, 2019 3:53 pm
but this version are for 2019? or too 2018?
need upgdrade? now use 4.05.
thanks for answers!
User avatar
nico_cad
Licensed Customer
Licensed Customer
 
Posts: 73
Joined: Fri Aug 22, 2014 2:12 pm
Location: Latina

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby juanjgon » Fri Oct 18, 2019 3:56 pm

juanjgon Fri Oct 18, 2019 3:56 pm
This is an Octane 2019.1.2 version, so you need an active Enterprise or Studio subscription license to work with it.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7056
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby nico_cad » Fri Oct 18, 2019 3:59 pm

nico_cad Fri Oct 18, 2019 3:59 pm
juanjgon wrote:This is an Octane 2019.1.2 version, so you need an active Enterprise or Studio subscription license to work with it

ok thanks :)
User avatar
nico_cad
Licensed Customer
Licensed Customer
 
Posts: 73
Joined: Fri Aug 22, 2014 2:12 pm
Location: Latina

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby hkleton » Fri Oct 18, 2019 4:02 pm

hkleton Fri Oct 18, 2019 4:02 pm
Hi Juanjo,

At the end of August I was able to render large scenes, and even do other stuff that took GPU memory while rendering.
That Octane version is no longer able to run, so I had to update.
Now, and even with this version, I am unable to render single frames after having rendered one frame.
With this version I was able to render at least one frame (yippie) , and the following F9 frames just will fail.
Restarting LW allows me to render one more frame using F9, and the next F9 render fails.

Things that changed since August:
Octane plugin to latest build
NVIDIA Drivers updated to latest version

Hardware setup has not changed, so GPU memory is the same as in August when I was able to render.
2x 2080TI
2x 1080TI

Fun fact: I was able to render the scene that now fails in August when I was playing World of Warcraft on 5 accounts :)

Error log reports this:

00:01:33 (0093.95) | >>> Draw preview window progress bar
00:01:33 (0093.95) | >>> Refresh preview window done
00:01:33 (0093.95) | Render setup Ok.
00:01:33 (0093.95) |
00:01:33 (0093.95) | [profile] Function "LWOctane_renderScene" over "" execution time: 8.603 seconds
00:01:33 (0093.95) | <> Mem Used/Free/Total: 6215 / 1986 / 11264
00:01:33 (0093.95) | <> Triangles/DisplaceTris/Hairs/Objects/Voxels rendered: 9162578 / 7504 / 0 / 79548 / 0
00:01:33 (0093.95) | <> Textures RGB32/RGB64/GREY8/GREY16 used: 306 / 14 / 36 / 0
00:01:33 (0093.95) |
00:01:33 (0093.95) | ... Init rendering ...
00:01:33 (0093.97) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:33 (0093.97) * OCTANE API MSG: -> failed to create link
00:01:33 (0093.97) * OCTANE API MSG: device 2: failed to create OSL compile context:

00:01:33 (0093.97) * OCTANE API MSG: device 2: failed to compile module 0
00:01:33 (0093.97) |
00:01:33 (0093.97) | ++++++++++++++++++++++
00:01:33 (0093.97) | +++ RENDER FAILURE +++ processing the failure callback
00:01:33 (0093.97) | ++++++++++++++++++++++
00:01:33 (0093.97) |
00:01:33 (0093.97) |
00:01:33 (0093.97) | Aborting rendering detected
00:01:33 (0093.97) | >>> Refresh preview window
00:01:33 (0093.97) | >>> Draw preview window progress bar
00:01:33 (0093.97) | >>> Refresh preview window done
00:01:33 (0093.97) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:33 (0093.97) * OCTANE API MSG: -> failed to create link
00:01:33 (0093.97) * OCTANE API MSG: device 0: failed to create OSL compile context:

00:01:33 (0093.97) * OCTANE API MSG: device 0: failed to compile module 0
00:01:33 (0093.97) * OCTANE API MSG: CUDA error 2 on device 3: out of memory
00:01:33 (0093.97) * OCTANE API MSG: -> failed to create link
00:01:33 (0093.97) * OCTANE API MSG: device 3: failed to create OSL compile context:

00:01:33 (0093.97) * OCTANE API MSG: device 3: failed to compile module 0
00:01:33 (0093.97) | ... Finish Rendering ...
00:01:33 (0093.97) |
00:01:33 (0093.97) | ... reset image callback ...
00:01:33 (0093.97) | ... wait for the getPreviewImage function ...
00:01:33 (0093.97) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:33 (0093.97) * OCTANE API MSG: -> failed to create link
00:01:33 (0093.97) * OCTANE API MSG: device 1: failed to create OSL compile context:

00:01:33 (0093.97) * OCTANE API MSG: device 1: failed to compile module 0
00:01:34 (0094.07) | Close and free scene, free buffer: 1, reset scene: 1
00:01:34 (0094.07) | ... freeBuffers
00:01:34 (0094.08) | ... setRenderTargetNode(NULL)
00:01:34 (0094.20) | ... update()
00:01:34 (0094.20) | ... getRootNodeGraph()->clear()
00:01:35 (0095.14) | >>> Refresh preview window
00:01:35 (0095.14) | >>> Draw preview window progress bar
00:01:35 (0095.14) | >>> Refresh preview window done
00:01:35 (0095.14) | Scene closed
00:01:35 (0095.14) |
00:01:35 (0095.14) | Close preview window
00:03:24 (0204.07) |
00:03:24 (0204.07) | Octane Render for Lightwave, end of log system


Another error log displays this:
00:01:34 (0094.20) | >>> Draw preview window progress bar
00:01:34 (0094.20) | >>> Refresh preview window done
00:01:34 (0094.20) | Render setup Ok.
00:01:34 (0094.20) |
00:01:34 (0094.20) | [profile] Function "LWOctane_renderScene" over "" execution time: 8.633 seconds
00:01:34 (0094.20) | <> Mem Used/Free/Total: 6253 / 1632 / 11264
00:01:34 (0094.20) | <> Triangles/DisplaceTris/Hairs/Objects/Voxels rendered: 9162578 / 7504 / 0 / 79548 / 0
00:01:34 (0094.20) | <> Textures RGB32/RGB64/GREY8/GREY16 used: 306 / 14 / 36 / 0
00:01:34 (0094.20) |
00:01:34 (0094.20) | ... Init rendering ...
00:01:36 (0096.85) * OCTANE API MSG: CUDA error 2 on device 3: out of memory
00:01:36 (0096.85) * OCTANE API MSG: -> failed to copy 2D memory to device
00:01:36 (0096.85) * OCTANE API MSG: device 3: failed to upload data texture 5 '0:__data7__'
00:01:36 (0096.85) * OCTANE API MSG: CUDA error 2 on device 3: out of memory
00:01:36 (0096.85) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.85) * OCTANE API MSG: CUDA error 2 on device 3: out of memory
00:01:36 (0096.85) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.85) |
00:01:36 (0096.85) | ++++++++++++++++++++++
00:01:36 (0096.85) | +++ RENDER FAILURE +++ processing the failure callback
00:01:36 (0096.85) | ++++++++++++++++++++++
00:01:36 (0096.85) |
00:01:36 (0096.85) |
00:01:36 (0096.85) | Aborting rendering detected
00:01:36 (0096.85) | >>> Refresh preview window
00:01:36 (0096.85) | >>> Draw preview window progress bar
00:01:36 (0096.86) | >>> Draw preview window progress bar
00:01:36 (0096.86) | ... Finish Rendering ...
00:01:36 (0096.86) |
00:01:36 (0096.86) | ... reset image callback ...
00:01:36 (0096.86) | ... wait for the getPreviewImage function ...
00:01:36 (0096.87) | >>> Refresh preview window done
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to clear linear device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 2: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to load symbol data to the device(deep_data)
00:01:36 (0096.89) * OCTANE API MSG: device 2: failed to upload the deep params
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to copy memory to device.
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 0: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to copy memory to device.
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> failed to deallocate device memory
00:01:36 (0096.89) * OCTANE API MSG: CUDA error 2 on device 1: out of memory
00:01:36 (0096.89) * OCTANE API MSG: -> could not get memory info
00:01:36 (0096.92) * OCTANE API MSG: denoiserThread0 : Initialization failed. Restart required
00:01:36 (0096.96) | Close and free scene, free buffer: 1, reset scene: 1
00:01:36 (0096.96) | ... freeBuffers
00:01:36 (0096.97) | ... setRenderTargetNode(NULL)
00:01:37 (0097.03) * OCTANE API MSG: denoiserThread3 : Initialization failed. Restart required
00:01:37 (0097.06) * OCTANE API MSG: denoiserThread2 : Initialization failed. Restart required
00:01:37 (0097.06) * OCTANE API MSG: denoiserThread1 : Initialization failed. Restart required
00:01:37 (0097.24) | ... update()
00:01:37 (0097.24) | ... getRootNodeGraph()->clear()
00:01:38 (0098.22) | >>> Refresh preview window
00:01:38 (0098.22) | >>> Draw preview window progress bar
00:01:38 (0098.22) | >>> Refresh preview window done
00:01:38 (0098.22) | Scene closed
00:01:38 (0098.22) |
00:01:38 (0098.22) | Close preview window
00:01:46 (0106.59) |
00:01:46 (0106.59) | Octane Render for Lightwave, end of log system


I do not use OSL as far as I know.
Something wrong with releasing memory?

Smaller scenes render without problems.

Hope you can find something. If you want me to do some tests, please let me know.
Octane is unusable for me, now I cannot rerender big scenes which I was able to render before

Thanks!
Hans
hkleton
Licensed Customer
Licensed Customer
 
Posts: 64
Joined: Wed Apr 06, 2016 6:17 am
Location: Netherlands

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby juanjgon » Fri Oct 18, 2019 4:16 pm

juanjgon Fri Oct 18, 2019 4:16 pm
This seems some kind of hardware or system issue. Are you working with the latest Studio NVIDIA drivers 431.86, not the game ready ones? Also, do you know if you have this problem while rendering with only one GPU? Try to render using only one GPU, enabling them one by one, to check if you have a hardware issue in any of them.

Thanks,
-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7056
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby hkleton » Fri Oct 18, 2019 6:10 pm

hkleton Fri Oct 18, 2019 6:10 pm
Hi Juanjo!

I _was_ using the GameReady drivers. Switched to Studiodrivers and now it's rendering again!

To answer your question, yesterday (with the Gameready driver) I tried each card individually, but failed on all 4.

In short:
* Gameready driver failes
* Studiodriver renders everything again.

Do you have any insight on why the gameready driver is acting up? Different calls in the driver?

Anyway,This frustrating issue is solved now!

Thanks , and have a good weekend!

Hans
hkleton
Licensed Customer
Licensed Customer
 
Posts: 64
Joined: Wed Apr 06, 2016 6:17 am
Location: Netherlands

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby WoutTgh » Mon Oct 21, 2019 4:54 pm

WoutTgh Mon Oct 21, 2019 4:54 pm
Thank you juanjgon !

I was having a looot of crashes with the previous version. Especially on reloading scenes/adding removing objects.

I will try this version, also I'm installing the Studio NVIDIA drivers 431.86. Let's see how it goes :)
WoutTgh
Licensed Customer
Licensed Customer
 
Posts: 31
Joined: Sat Jul 27, 2019 8:39 pm

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby gristle » Tue Oct 22, 2019 7:34 am

gristle Tue Oct 22, 2019 7:34 am
I still have an issue with the layered material, in LW 11.6.
layering a specular material over a glossy results in black; no transmission.
Windows 7 64, 12 gig ram, Intel 920, 2 X 780, 1 X 980ti, 1 X 660.
http://ajdesignstudio.co.nz/
gristle
Licensed Customer
Licensed Customer
 
Posts: 300
Joined: Wed Jan 20, 2010 10:42 am
Location: Wellington

Re: OctaneRender 2019.1 LightWave Production build 2019.1.2.0

Postby WoutTgh » Tue Oct 22, 2019 10:29 pm

WoutTgh Tue Oct 22, 2019 10:29 pm
I'm still having the crashes. IPR is open and running, I press "-" to remove an object: boom crash.. (LW 2015.3 )
IPR is paused, I clone some objects, and rename one press pause to resume. crash.

Maybe it has to do with renaming/ object name updates..?
WoutTgh
Licensed Customer
Licensed Customer
 
Posts: 31
Joined: Sat Jul 27, 2019 8:39 pm
Next

Return to Lightwave 3D


Who is online

Users browsing this forum: Bing [Bot] and 3 guests

Thu Nov 21, 2019 1:03 am [ UTC ]