2 more notes

Forums: 2 more notes
Newtek Lightwave 3D (exporter developed by holocube, Integrated Plugin developed by juanjgon)

2 more notes

Postby karanis » Thu Nov 14, 2013 2:11 am

karanis Thu Nov 14, 2013 2:11 am
Dear Juan,

Although I can feel that these are not your primary concerns nowadays, I`d like to mention about those 2 notes of mine :

1.) I am experiencing trouble on scene / object / surface / node / ennvelope saves. I know that All surface properties are binded to objects in LW, not to scene.

I am rendering 360 views of multiple products with predefined surfaces, changing colors. As you suggested, I am using envelopes on Diffuse channel for the color change. Although they work fine before closing the scene, they most of the time get weird on scene reload (which is needed for a render-Q at least). The sympthom is not predictable. For an example, a model with having 5 surfaces, having 3x5 different envelopes in different channels (r,g,b) ; they are not assigned to model/surface and loaded as it should be. I could not get any default procedure for that to work right. This does not seem to be an Octane plug-in issue, looks like something related with LW but, this always happens. The only way to work with it is: always "save all", "save all objects" and repeat this many times ; close the scene; reload the scene; check envelope keypoint renders; repeat till it gets ok. Can there be anything to do with this ?

2.) I think it would be GREAT to have a scripting/communicating way to talk to rendering status of the plugin.

Because sometimes (most of the time), long sequential renders may fail. Sometimes they fail to save, sometime rendering hangs, sometimes one of the GPUs get lost and performance decreases for the rest of the sequence. If there would be a very simple daemon to talk to; answering me about the current render state, I could write my own script to understand/anticipate/notify myself about what`s going on and behave accordingly.

Wishing you good luck on new release.

Best wishes...
Win7 64 & Slackware 14 64 | 3x Zotac 580 amp & 1x MSI 680 | i7 3930K @4.8 | 32 GB | Asus rampage extreme IV
User avatar
karanis
Licensed Customer
Licensed Customer
 
Posts: 79
Joined: Sat Jul 23, 2011 11:21 pm
Location: Ankara / TURKEY

Re: 2 more notes

Postby juanjgon » Thu Nov 14, 2013 10:48 am

juanjgon Thu Nov 14, 2013 10:48 am
If you have a basic scene with the Envelopes issue, please send it to me, perhaps there is some kind of problem with them in the Octane nodes.

You can try to add a LW constant color node and link it to the octane node input to use the LW node envelopes, perhaps the envelopes inside the LW color nodes are going to work without problems.

Anyway I need a scene with this issue to test it here.

About the rendering progress, you can enable the log system before render a scene, and now with the next plugin release it could be even better to use LWSN to batch render the scene. LWSN shows a lot of information about rendering progress.

-Juanjo
Computer Graphics Software Developer
Octane plugin development and support: LightWave and Houdini
User avatar
juanjgon
Octane Plugin Developer
Octane Plugin Developer
 
Posts: 7297
Joined: Tue Jan 19, 2010 12:01 pm
Location: Spain

Return to Lightwave 3D


Who is online

Users browsing this forum: No registered users and 2 guests

Sun Feb 23, 2020 3:09 am [ UTC ]