Smooth Texture Issue

Forums: Smooth Texture Issue
Blender (Export script developed by yoyoz; Integrated Plugin developed by JimStar)

Smooth Texture Issue

Postby SGD4170 » Mon Mar 18, 2019 4:09 pm

SGD4170 Mon Mar 18, 2019 4:09 pm
Just inquiring on if there is a fix for something like this, or is it just poor poly's? . when I use the smooth button a lot of objects I have dealt with turn out like this.

Slide Image 1 edited.jpg


Slide Image 2.jpg
SGD4170
Licensed Customer
Licensed Customer
 
Posts: 4
Joined: Sat Feb 10, 2018 5:14 pm

Re: Smooth Texture Issue

Postby ChrisH » Mon Mar 18, 2019 4:35 pm

ChrisH Mon Mar 18, 2019 4:35 pm
There's several ways around this:

  • Add more geometry, like edge loops around the holes, to control the shading. This is the "traditional" way to do it, it works pretty well (and for some instances this is the best option). The negative is that it adds more geometry that you might not want.
  • Use the Edge split modifier. This is also a more "traditional" way, but can cause problems (and it adds more geometry). It breaks the mesh along certain corners (depending on angle)
  • Enable Auto Smooth (in mesh options) and tweak the angle. This is the best option (IMHO), but might need some help from additional geometry sometimes. This let's you define what angles should be considered "sharp" (and thus shaded as such), it also let's you mark edges as sharp (In Edit mode: Ctrl+E > Mark Sharp), so you can control the "smoothness". In this case, just enabling "Auto Smooth" should work fine, but you could also select the edges of the holes and mark them as sharp.
    AutoSmooth2.png
Windows 10 Pro - AMD Ryzen 7 2100X 8 core 3.70GHz - 32GB RAM - GeForce GTX 1080 8GB
Stand Alone + Blender Plugin user
User avatar
ChrisH
Licensed Customer
Licensed Customer
 
Posts: 53
Joined: Sun Mar 06, 2011 12:13 am
Location: Lidköping, Sweden

Re: Smooth Texture Issue

Postby SGD4170 » Thu Mar 21, 2019 5:23 pm

SGD4170 Thu Mar 21, 2019 5:23 pm
Thank you this did work. The company also sent a revised model as the Vertices was way too high seemed to fix the problem. Thank you! :D
SGD4170
Licensed Customer
Licensed Customer
 
Posts: 4
Joined: Sat Feb 10, 2018 5:14 pm

Return to Blender


Who is online

Users browsing this forum: No registered users and 2 guests

Tue Jun 25, 2019 8:20 am [ UTC ]