Set material to not be affected by light

Forums: Set material to not be affected by light
Blender (Export script developed by yoyoz; Integrated Plugin developed by JimStar)

Set material to not be affected by light

Postby Whispermode » Tue Feb 19, 2019 10:31 am

Whispermode Tue Feb 19, 2019 10:31 am
Hello.

Is it possible to have a material/object NOT be affected by light or environment in Octane Blender?

I've seen it done in Cycles using an emission shader (I think), but can't get the same to work in the Octane plugin.

Thanks.
Whispermode
Licensed Customer
Licensed Customer
 
Posts: 81
Joined: Thu Aug 11, 2016 11:27 pm

Re: Set material to not be affected by light

Postby J.C » Wed Feb 20, 2019 4:22 pm

J.C Wed Feb 20, 2019 4:22 pm
Have you tried using emission texture node?
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti, 2xRTX 2080
System – OS X 10.12.6, Windows 10, Octane 4/2018, Blender Plugin 16.x.x and 17.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 976
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Set material to not be affected by light

Postby Whispermode » Sat Feb 23, 2019 5:44 pm

Whispermode Sat Feb 23, 2019 5:44 pm
J.C wrote:Have you tried using emission texture node?


Thanks, J.C - I had, but could never get it right... I just tried again and realised if you set the Diffuse colour to black, it works. :roll:

...still, ideally I don't want to use an emission node, and would like to be able to turn off 'accept light', 'accept shadows' etc.
Whispermode
Licensed Customer
Licensed Customer
 
Posts: 81
Joined: Thu Aug 11, 2016 11:27 pm

Re: Set material to not be affected by light

Postby J.C » Mon Feb 25, 2019 4:22 pm

J.C Mon Feb 25, 2019 4:22 pm
You will need light linking for this:
http://www.aoktar.com/octane/OCTANE%20H ... index.html
CPU – i7 8700k 4.8Ghz + 64GB RAM, GPU – 2xGTX 980 Ti, 2xRTX 2080
System – OS X 10.12.6, Windows 10, Octane 4/2018, Blender Plugin 16.x.x and 17.x
My Behance portfolio, Blender plugin FB support group
J.C
Licensed Customer
Licensed Customer
 
Posts: 976
Joined: Thu May 13, 2010 6:35 pm
Location: Wrocław

Re: Set material to not be affected by light

Postby ChrisH » Mon Feb 25, 2019 5:48 pm

ChrisH Mon Feb 25, 2019 5:48 pm
One possible way, depending on how your scene is set up, is to use the render passes.and compositing

The Diffuse Filter passes (there's two, either should work [even if they differ slightly in my test]) gives the objects diffuse colors, without any shading. You could use that, mask it out with info from either the Material Index pass or the Object Index Pass, and composite over the rest of the scene.

This doesn't work if it's behind glass though..
Windows 10 Pro - AMD Ryzen 7 2100X 8 core 3.70GHz - 32GB RAM - GeForce GTX 1080 8GB
Stand Alone + Blender Plugin user
User avatar
ChrisH
Licensed Customer
Licensed Customer
 
Posts: 80
Joined: Sun Mar 06, 2011 12:13 am
Location: Lidköping, Sweden

Re: Set material to not be affected by light

Postby Whispermode » Mon Feb 25, 2019 8:26 pm

Whispermode Mon Feb 25, 2019 8:26 pm
J.C wrote:You will need light linking for this:
http://www.aoktar.com/octane/OCTANE%20H ... index.html


This is exactly what I need. Thanks for pointing me in the right direction, J.C.
Whispermode
Licensed Customer
Licensed Customer
 
Posts: 81
Joined: Thu Aug 11, 2016 11:27 pm

Return to Blender


Who is online

Users browsing this forum: No registered users and 2 guests

Mon Sep 23, 2019 7:36 pm [ UTC ]