Page 1 of 1

Rounded edge

PostPosted: Wed Feb 06, 2019 9:27 am
by canderled
Hello Guys

I can't figure out the setup to make the rounded edge work in blender. i tried lot's of options and setup but never got it to work.
if i just export the model in obj with smoothing group and rendered it in standalone, it work perfectly out of the box.
I'm using the latest versions 2018.1 rc3.

In standalone:
Standalone render

best i got in blender with rounded edges:
Blender render

Re: Rounded edge

PostPosted: Thu Feb 07, 2019 7:32 pm
by J.C
Did you enable smoothing in material settings?

Re: Rounded edge

PostPosted: Fri Feb 08, 2019 3:36 pm
by canderled
Yes, i tried with and without smoothing in the material, i never got it to work correctly :/

Re: Rounded edge

PostPosted: Fri Feb 08, 2019 4:17 pm
by J.C
If it's not material smoothing then it looks like a mesh issue. Go to edit mesh mode and check if the edges have unnecessary weights assigned.

Re: Rounded edge

PostPosted: Sat Feb 09, 2019 9:52 pm
by ChrisH
It seems that you can either have rounded edges OR Smooth shading (Smooth overrides Rounded Edges) and Rounded Edges don't care about the angles between faces.

Here's my test (and the difference in shader settings):

And the same scene in Octane Standalone:

It seems that you have two options:
  • Use different materials for different objects/meshes (one for Rounded Edges, one for Smooth)
  • Use a bevel modifier on the object (giving you control over which angles should be beveled)

NB: Rounded edges doesn't work with Auto Smooth.. :(

Re: Rounded edge

PostPosted: Sun Feb 10, 2019 6:11 pm
by J.C
Octane implementation of Rounded Edge is working ok only on meshes with flat surfaces. For other cases the best would be to use Bevel modifier with edge split modifiers to preserve mixed flat and smooth surfaces.
According to the developers Octane 2018.1 should have it improved.