Weird square present in some exports from Blender

Forums: Weird square present in some exports from Blender
Blender (Export script developed by yoyoz; Integrated Plugin developed by JimStar)

Weird square present in some exports from Blender

Postby ROUBAL » Mon Oct 01, 2012 10:14 am

ROUBAL Mon Oct 01, 2012 10:14 am
Weird square present in some exports from Blender.

As you can see on the attached image, I get an unexpected square object in some exports :

A square with Null material is appearing on my exports of this building,
and at first glance this object is not present in the Blender file.

I gave it a red color to make it more visible, but it is created white when loading the obj the first time.

As non renderable objects and hidden objects are
not exported, what could be this weird square ?

As no other object is modified when I change its color,
it is not a forgotten face belonging to an other object.

It is not really a big problem, because I can make it transparent and ignore it, but It is very strange and I'd like to understand where it comes from.

Any idea will be welcome.

Thanks in advance.

Philippe.
Attachments
ExportBug_01.jpg
French Blender user - CPU : intel Quad QX9650 at 3GHz - 8GB of RAM - Windows 7 Pro 64 bits. Display GPU : GeForce GTX 480 (2 Samsung 2443BW-1920x1600 monitors). External GPUs : two EVGA GTX 580 3GB in a Cubix GPU-Xpander Pro 2. NVidia Driver : 368.22.
User avatar
ROUBAL
Licensed Customer
Licensed Customer
 
Posts: 2199
Joined: Mon Jan 25, 2010 5:25 pm
Location: FRANCE

Re: Weird square present in some exports from Blender

Postby steveps3 » Mon Oct 01, 2012 12:16 pm

steveps3 Mon Oct 01, 2012 12:16 pm
hidden objects are only not rendered if you say that you don't want them rendered. As a default they will get rendered.

Are you saying that you do not have this object in you model at all??
(HW) Intel i7 2600k, 16GB DDR3, MSI 560GTX ti (2GB) x 3
(SW) Octane (1.50) Blender (2.70) (exporter 2.02)
(OS) Windows 7(64)
User avatar
steveps3
Licensed Customer
Licensed Customer
 
Posts: 1118
Joined: Sat Aug 21, 2010 4:07 pm
Location: England

Re: Weird square present in some exports from Blender

Postby ROUBAL » Mon Oct 01, 2012 12:35 pm

ROUBAL Mon Oct 01, 2012 12:35 pm
Yes ! It is very weird. I have enabled export to avoid hidden objects and objects set to not renderable.

In Blender, I have checked before hiding objects, showing every layers and the object doesn't appear ! :roll:

I have made every object visible, selected and deleted everything to clear all layers. After exporting, the square object is still there in Octane and Octane displays 1 Mesh 4 tris...

I tried with a new file : I had to add one cube to avoid export failure. The Ghost object is not there. So, it seems related to my current real scene...

EDIT : A malfunction with some tools just remember me that this file has originally been created with Blender 2.49b and so probably contains some conversion bugs. I tried to append the whole scene in a new file in order to fix it as i did some time ago for an other bug, but this time, the scene is not imported correctly : objects scales broken, and the building that I am working on is missing ! :shock:

It is a problem when working on big projects on a long time period... file compatibility after upgrade to new versions.

I think I will have to live with the ghost object if I don't want worse things happening while trying to repair the file !

EDIT : Damned ! It is worse than expected : A ghost object is created for each exported obj and when generating a scatter file, the ghost object is instanced as well as the real object used for instance ! :evil:

I have to "kill" all these unwanted instanced objects by applying Alpha=0, and they are many ! :|

EDIT : I confirm that it is a Blender version conversion bug : I imported again my building in a new file. This time no more scale trouble and no ghost square, but UV mapped objects are no more textured in Blender 3D view ! Fortunately, textures are still linked and present when loading in Octane, but I will have to fix that in Blender if I want to render the objects in Blender.
French Blender user - CPU : intel Quad QX9650 at 3GHz - 8GB of RAM - Windows 7 Pro 64 bits. Display GPU : GeForce GTX 480 (2 Samsung 2443BW-1920x1600 monitors). External GPUs : two EVGA GTX 580 3GB in a Cubix GPU-Xpander Pro 2. NVidia Driver : 368.22.
User avatar
ROUBAL
Licensed Customer
Licensed Customer
 
Posts: 2199
Joined: Mon Jan 25, 2010 5:25 pm
Location: FRANCE

Return to Blender


Who is online

Users browsing this forum: No registered users and 7 guests

Thu Jul 02, 2020 10:06 am [ UTC ]