Page 1 of 1

Exporter does not correctly export every material

PostPosted: Sun Oct 09, 2011 9:24 am
by Alain
Hi all

See here:
Comparison_01_091011.jpg


Here you see it more detailed (all the red parts have a standardmaterial in Octane but in Sketchup they have another material):
Bildschirminhalt erfassen-3.jpg


Is this a bug or how can I prevent this wrong material translation ?


Kind regards
Alain

Re: Exporter does not correctly export every material

PostPosted: Sun Oct 09, 2011 10:21 am
by TIG
Please change the view mode of your SKP to Monochrome,.
Then change the default-material of the current Style to off-white for face fronts and bright-blue for face backs.
I expect that the parts of the SKP that seem to 'export incorrectly' will now be seen in bright-blue.
They are exporting correctly but they are modeled backwards!
If you apply a material to a face's back it will looks OK in the SKP, but when you export it into most 3rd party renderers like Octane it does what you tell it to - the front faces get the specified materials [in the case of reversed faces that's the 'default'] and all back faces' materials are simply ignored and rendered as 'default' off-white - because you should never see them as they should be inside objects they are not considered by the renderer.
So all back faces are Rendered in the off-white default-material irrespective of them having been erroneously given a material in the SKP model.

My "FixReverseFaceMaterials" tool that is supplied with the Exporter helps you quickly reverse backwards faces whilst preserving the materials as already mistakenly applied. Flipping faces and materials can be a pain without this tool...
If you read the thread about the tool it explains more fully - fixing mistakes later is always worse than modeling things correctly in the first place - remember to use Monochrome mode now and again while modeling so you don't fall into a trap...

If after you've fixed reverse faces etc it still exports oddly please post the corrected SKP so I can test it - if it's very large zip it, if it's confidential attach it to a PM, or PM link to secure file sharing site where you've lodged it...
:geek:

Re: Exporter does not correctly export every material

PostPosted: Sun Oct 09, 2011 1:31 pm
by Alain
Thank you.

You are right, those were backfaces. I turned them (by hand, have to check your tool later) and now everything is correct :-)

Kind regards
Alain