Page 2 of 2

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Sun May 29, 2011 9:55 am
by TIG
There is no major change between the versions of the Exporter.
Although the latest one is recommended for the current Octane versions even the older one should work.
Your ../Plugins/Octane/ folder should also contain the older file "Octane_1022.rb" as well as the newer one "Octane/Octane_1024.rb" [I can't see in your screen-shot as the window is scrolled down]. If not install the _1022 version then the _1024 version over it - then you will have both .rb files.
The file inside ../Plugins/ called "Octane_loader.rb" loads a particular version.
To load the latest version it says
#load "Octane/Octane_1022.rb"
load "Octane/Octane_1024.rb"

with the earlier version disabled by the leading '#'.
To let the older version load you swap the '#' thus
load "Octane/Octane_1022.rb"
#load "Octane/Octane_1024.rb"

Now _1022 will load/run after a restart.
If you now get that to open OK then something in the newer version of the rb file is incorrect - although I can't see what it might be :?
If it still fails you can try reinstalling _1022 and overwriting all files - that version will now load/run on a restart.
If it opens OK then the error is in the newer versions of the dialog's file [html/js/css etc] - although again I can't see what it might be :?
At least we then have clues about from where the error is emanating...

Let me know the outcome...

The question about 'which web-browser' is because Sketchup's web-dialogs use each system's web-browser to make themselves with html files - so it might be possible to have the system settings conflicting with these html file's coding etc - it may be I can force something in the dialog's html to override that...
E.G. <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> works for me but perhaps not for you ?
I need to get feedback on what is failing first though... :roll:

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Mon May 30, 2011 2:04 am
by gozilla

A) I put the 1022 among the files as you said.

Then I altered the loader script to load the 1022 version.

Running SK in this way gives a blank dialogue exporter window.

B) replaced the 1024 files with the 1022 files

Running SK in this way gives the same blank dialogue exporter window.

So something happened, when I installed the 1024 the first time, that now even earlier versions of the exporter won`t work.
I really can`t imagine what that could be.

I`m using SK7.

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Mon May 30, 2011 10:36 am
by TIG
Rename the Octane subfolder.
Reinstall 1022 version of Octane - that way we know it's 'pure'.
Try again.
If it still fails then [as I suspected] it's nothing to do with the Octane Exporter per se... I think that you've changed something on your system between times and that's messing everything up....
Has Safari been updated ? [MAC use it as the basis of the Sketchup webdialogs]
Have you tried reinstalling it ?
Do you have its settings to allow javascripts to run etc...
Do you have any other Sketchup tools using webdialogs ? If so do these work properly ?
Seems a complete mystery :? PC and MAC users have NEVER reported this issue before... so there must must be something exceptional in your system's setup... :cry:

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Tue May 31, 2011 10:30 am
by AJ5I
i want to know Why the plugin use very long time to export the scene to Octane? Is smething wrong? ps. sry for my poor english

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Tue May 31, 2011 11:19 am
by TIG

Without more details who can say ?
Is it a single frame or an animated frame-set ?
What do you consider 'a long time' ?
If your SKP contains lots of complex geometry and/or UV-mapped textures then obviously it could take longer than a simple objects and materials.
The exporter has to export all of these to separate files and construct an OBJ/MTL file-set that Octane can read in...
Octane then has to import it all, using the settings you have given...

Can you purge/fix the SKP then zip it and attach it [or PM it], together with your exporter's settings [and perhaps your ocs options] so that it can be tested...

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Tue Jun 07, 2011 3:27 pm
by gozilla

I deleted the content of the plugin folder.
Reinstalled the Octane plugin 1022-12
Run SU7 but no luck.


Safari ver. 5.0.5 is fine: Javascript and plugins allowed. Java disabled. No cookies, no pop-ups.
I did update Firefox to the last version, but you did not mention it so probably it does not matter.
Other things I can think of are maybe Little Snitch running in background.

I don`t think I messed up with anything.
I just installed the Octane plugin following the instructions on the readme file.
Everything is in its right place.

In the SU plugin folder there is ONLY Octane stuff, so the culprit should be something related to Octane....but what?

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Tue Jun 07, 2011 4:02 pm
by TIG

I know what the problem is... BUT I'm not sure what's causing it... or how to fix it... :roll:

A SUp webdialog is setup by html code: for example there are many table 'cells' like this...
<table id="project_configuration1" style="padding:0px; margin:3px; width:576px; border-style:none;">
In the ruby code itself it changes the html code's parts' values to suit your entered settings and so on by using javascript calls - and also to update text-fields to suit a locale - when it executes a snippet of javascript to change a cell's "innerHTML", when translating its text-string with deBabelizer [db()], e.g.
js=("document.getElementById(\"project_configuration_label\").setAttribute(\"innerHTML\",\" "+(db("Project Configuration"))+"\");")

Here the "project_configuration_label" is set to be db("Project Configuration") - i.e. the translated text [which defaults to the original string if there's no available translation in any case !]
Some of the javascripts work - i.e. where there's no "innerHTML" to change it updates fields OK !
So it seems to me that your MAC's system/browser [Safari] is not allowing javascript to change the "innerHTML" of these elements properly :?
It works fine on all PCs that I know of... AND on all MACs except yours ??
So what is different about your setup compared to everyone else's?
The way javascript can change "innerHTML" WAS identified as a security hole in IE on PCs several years ago, but as this is all user-side stuff it should never affect it...

Have you recently changed Safari?
Is there anything in the MAC world noting problems with 'innerHTML' and new versions of Safari. or just when its settings are askew ??

I am still investigating, but since I don't have MAC and can't reproduce the problem I'm in a bind...
I'll try and help you help yourself, but it'll have to be a joint-effort :roll:

Re: Octane Sketchup Exporter - 1024-04

PostPosted: Wed Jun 08, 2011 7:48 am
by TIG

Good news for you - but lots of work for me!

I think I have found the issue and how to fix it... :?
I set the cells' 'innerHTML' as an 'attribute' - this has worked fine on PC & MAC BUT recent changes to Safari etc expect the 'innerHTML' to be set as a 'property' :roll: so that's why it's failing...

I need to do some testing ans if it still works on my set up I'll send you a version to test...
If it's then OK on your newer browser I'll issue a full update of the code that should then be future-proof...

Watch your PMs for the replacement file... :geek: