Octane Sketchup Exporter - 1024-01

Forums: Octane Sketchup Exporter - 1024-01
SketchUp Integrated Plugin (Integrated Plugin maintained by OTOY)

Re: Octane Sketchup Exporter - 1024-01

Postby TIG » Wed Mar 23, 2011 10:49 am

TIG Wed Mar 23, 2011 10:49 am
radiance wrote:Hi TIG,

can you test your smoothing with the default octane OBJ import settings ?

These are:

- import per material smooth value = ON
- use OBJ vertex normals if supplied = ON
- interpolate using smoothgroups = OFF

I think the issue is that if you enable the last parameter (interpolate using smoothgroups),
octane will simply recompute the vertex normals based on groups/edges and you don't end up using proper supplied vertex normals from sketchup.

As all users have these settings by default, it's important that the exporter writes out vertex normals properly so that it works like all the other exporters,
otherwise users will end up with several problems, for example you will lose control of normal direction which can cause artifacts in renders with transmissive materials like glass...

Radiance

I have done further testing as you suggested and I concede that the newer version of the exporter does indeed mess with smooth normals, unlike the earlier version - my ticking of the 'smoothgroups' option was confusing the issue...
I will recast the coding changes made in the newer version of the exporter to keep the efficacy of the previous one.
I had made some slight changes to address a very rare flipped faces issue - better to keep the smoothing right and look for another solution to that one - watch out for a up date soon... :roll:
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - 1024-01

Postby abstrax » Wed Mar 23, 2011 10:52 am

abstrax Wed Mar 23, 2011 10:52 am
TIG wrote:I have done further testing as you suggested and I concede that the newer version of the exporter does indeed mess with smooth normals, unlike the earlier version - my ticking of the 'smoothgroups' option was confusing the issue...
I will recast the coding changes made in the newer version of the exporter to keep the efficacy of the previous one.
I had made some slight changes to address a very rare flipped faces issue - better to keep the smoothing right and look for another solution to that one - watch out for a up date soon... :roll:


Sounds good. Thanks for your efforts :)

Cheers,
Marcus
In theory there is no difference between theory and practice. In practice there is. - Yogi Berra
User avatar
abstrax
OctaneRender Team
OctaneRender Team
 
Posts: 5069
Joined: Tue May 18, 2010 11:01 am
Location: Auckland, New Zealand

Re: Octane Sketchup Exporter - 1024-01

Postby TIG » Wed Mar 23, 2011 11:16 am

TIG Wed Mar 23, 2011 11:16 am
abstrax wrote:
TIG wrote:I have done further testing as you suggested and I concede that the newer version of the exporter does indeed mess with smooth normals, unlike the earlier version - my ticking of the 'smoothgroups' option was confusing the issue...
I will recast the coding changes made in the newer version of the exporter to keep the efficacy of the previous one.
I had made some slight changes to address a very rare flipped faces issue - better to keep the smoothing right and look for another solution to that one - watch out for a up date soon... :roll:


Sounds good. Thanks for your efforts :)

Cheers,
Marcus

The updated version - 1024-02 - is here viewtopic.php?p=50157#p50157
I have tested it with the default settings and smoothing is now restored in the imported version :D
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm
Previous

Return to SketchUp


Who is online

Users browsing this forum: No registered users and 1 guest

Wed Aug 21, 2019 1:14 am [ UTC ]