Page 3 of 4

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 17, 2010 10:01 am
by TIG
DigitalDouble wrote:Hi Tig,

I have both SU 7 and 8 installed.
I installed the SU plugin on both directories.
Su7 is able to launch the dialog box and render and V8 doesn't.
I think it worked at one point, but not anymore.
I tried rebooting etc.. but to no avail.
I tried going back to 1.05 but same thing...

Some more info:
When trying to launch Octane from SU8 with an empty scene I get the dialog box "You must save this...."
This is good !

But when I create a simple scene (a box) and save it, clicking on the octane icon doesn't so anything and the icon stays depressed.
The file name and the directory path do not have spaces or foreign characters.


Sorry I missed yours it was in Guy's morass...
Have you done a full install of all files for v8 as well as v7 - as discussed here and in the README file - please don't try and copy files from one folder to the other - you might miss something.
If it's still not working in v8 then open the Ruby Console and run the Octane Render Exporter and post any error-messages you get in there.
If you get any other error dialogs etc please post those too.

If you try to run the Exporter in v7 or v7 and the project has not been saved then you will get that message - the Exporter needs to have a saved 'SKP' so that it knows what the default project name and path might be. It is nothing to do with 'Scenes' because it will limit itself to the Camera of the Current View and disabled the Animation Options if there are no Scenes available.
The SKP's name/file-path can contain special-characters and spaces [it's recommended 'not' - but it's not 'fatal' !].
The OCS's project folder-path can contain spaces but NO special-characters [***example accented letters or non-ASCII Unicode characters].
The OCS project-name [>>> "xxx".ocs] should only consist of ***A-Z, a-z, 0-9, '_' and '-' characters, but with NO <spaces> or special-characters.

Can you also provide details of your default web-browser and IE version - and general OS etc...

If you feel confident enough could you please also run 'regedit' and post a screen-shot of the entry for the WebDialog_OctaneDialog as I explained more fully in an earlier post in this thread.

Most people with Sketchup version 8 are having no problems at all with the tool working - BUT a few of you are and I'm still trying to get a fix - I need to find some common factors. Remember that you can always do a "save_as" on your v8-SKP and save it as v7-SKP [use drop-down list to change version], then close and reopen it in v7 and use the Octane Render Exporter in v7, which still seems to run perfectly for all users irrespective of setups - excepting special-character glitches [Sketch's Ruby's inability to process Unicode characters on Windows for 'File' processes is a know issue but we are still looking at fixes for it]...

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 17, 2010 4:56 pm
by DigitalDouble
Robi Console Error message.

Error: #<NoMethodError: undefined method `tr!' for nil:NilClass>
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:234:in `activate'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2860:in `select_tool'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2860:in `octane'
C:/Program Files/Google/Google SketchUp 8/Plugins/Octane/Octane_1022.rb:2872

I am using Firefox latest version.

I checked the registry.
I noticed that V8 didn't have the "HKEY_CURRENT_USER\Software\Google\SketchUp8\WebDialog_Octane_FolderBrowser" key at all.
I added it with all the sub-keys values copied from V7 entries. I also copied the values for HKEY_CURRENT_USER\Software\Google\SketchUp8\WebDialog_Octane from V7 to V8 entries.
That did not help either.

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Fri Sep 17, 2010 7:58 pm
by TIG
You won't have the WebDialog_Octane_FolderBrowser entry if it hadn't been used - likely as the main dialog didn't load [yet]...

It's failing to find/resolve the "project path" properly.
It sets the model-path. It exits if the model has not yet been saved.
[mimic this by typing/pasting into the Ruby Console...
p path=Sketchup.active_model.path
It sets the project_path
[ now mimic...
p project_path=File.dirname(path)
It EXITS if not saved ???
[ now mimic...
p title=Sketchup.active_model.title
p" ","_").gsub!(/[^_A-Za-z0-9\-]/,'_')

Now mimic the attribute check
p xproject_path=Sketchup.active_model.get_attribute("Octane", "project_path", nil)
NOTE THAT If not xproject_path then xproject_path=project_path
should kick in BUT it's failing... and leaving xproject_path as nil ???

In line #234
[ mimic... IT FAILS if xproject_name==nil which it shouldn't !!!
p!(" ","_")

If you could put these into the Rub y Console in turn I would be grateful... :roll:

I am looking at making a special tester version of the rb/html files for you = with more dialogs etc - to try and pin down the source of the problem - including Guy's problems too which I think are related...
I'll try and post something in a day or two... :geek:

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sat Sep 18, 2010 8:30 am
by TIG
On a simpler note :?
I suspect that if you open a new SKP and before saving it tou copy/paste this line of code into the Ruby Console
in a version 7 SKP it will print

BUT in a version 8 SKP - under Win7 with certain SPs - it will return 'nil' and print an error
Error: #<TypeError: (eval):3775:in `+': can't convert nil into String>

However, in version 7 OR 8 SKP - Vista etc it prints '' - as it has in all other versions and OSs

If you can confirm this I will issue 1022-16 with this issue resolved AND also the coding convolution needed to allow special-characters/accents inside file-paths... ;)

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sat Sep 18, 2010 9:49 pm
by DigitalDouble

I'm on Vista 32 bit
Both Su 7 and Su8 output the same thing:

Copy and paste from the Robi Console:

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sun Sep 19, 2010 10:13 am
by TIG

This is strange that 'puts' command is to write into a cmd file NOT the Console.

What is the whole message - that snippet shouldn't be on its own ???

Is there a dialog being made?
If so leave it open and open the Project folder
Is it making any '.cmd' files.
If so can you open them with Notepad and post the text ?

I assume you have appropriate access rights to the folder etc.

Can you also copy/paste your Project folder Path and the entered ocs File name ?

This is very confusing - so far... :?

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sun Sep 19, 2010 4:34 pm
by DigitalDouble
This is strange that 'puts' command is to write into a cmd file NOT the Console.

I followed your instructions from a previous post where you specifically said to open the Roby console and type the following.
So I am very confused.

I get no dialog box at all in version 8.

Here is the project path for Version7 = C:\Users\ADG123\Documents
Here is the path to the render binary= C:\Program Files\Refractive Software\OctaneRender_23_3_4\octane.exe

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sun Sep 19, 2010 4:48 pm
by DigitalDouble
I also uninstalled and re-installed Sketchup 8 - still having exact same issues.

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sun Sep 19, 2010 7:02 pm
by TIG

Sorry I misunderstood your post... :roll:
when you have
typed into the Console it should return the path to the model's skp file.
IF you haven't saved the skp you get

BUT IF you have saved it you should get something like this

Have you saved the model before you did this ?
If not the tool should trap it and stop you proceeding.
If yes it's weird as the path should return and the tool run OK...

Version 7 can't be in
It must be inside some sub-folders ???
The correct [default] locations are
C:\Program Files\Google\Google SketchUp 7
C:\Program Files\Google\Google SketchUp 8
Did you mean
C:\Users\ADG123\Documents\Google\Google SketchUp 7 ???

Please copy/paste this code into the Ruby Console to see what the path is returned as
It should return
C:/Program Files/Google/Google SketchUp 7/.
or something similar...
Inside that folder there should be a Plugins folder containing the various ruby scripts etc, and in this case an Octane sub-folder with several subsidiary files...

When you uninstall SUp and reinstall do you use the System [Control_Panel/Programs] unistall option to ensure the Registry is cleaned up ?

This is plain weird... :(

The Octane Render binary [exe] is typically in a folder like
C:\Program Files\Refractive Software\OctaneRender_23_3_4\octane.exe
Mine is in perhaps
C:\Program Files\Refractive Software\OctaneRender_COM_1022_beta22_RC3_win_32\octane.rb
I see no problems with that...

Re: Octane Sketchup Exporter - Full 1022-06

PostPosted: Sun Sep 19, 2010 7:58 pm
by DigitalDouble
Hi Tig,

Roby Console output:


C:/Program Files/Google/Google SketchUp 8/.

Sub-directory structure is the default.
I installed your plugin as written in the readme file
I have nothing special in my setup or installation.

I did use the control panel for uninstall.

Again, your plugin works great with Sketchup 7, but refuses to work with Sketchup 8.
Also all the other commercial and free plugins works as intended in sU8.

So this is really bizarre. :shock: