Octane Sketchup Exporter - Full 1022-02 [superseded]

Forums: Octane Sketchup Exporter - Full 1022-02 [superseded]
SketchUp Integrated Plugin (Integrated Plugin maintained by OTOY)

Octane Sketchup Exporter - Full 1022-02 [superseded]

Postby TIG » Wed Aug 04, 2010 10:39 pm

TIG Wed Aug 04, 2010 10:39 pm
Here's 1022-02
Octane_1022-02.zip
(537.04 KiB) Downloaded 188 times
It has some adjustments to the toolbar icon image code etc to make it more robust - a very few users have reported missing icons - this update should fix this issue.

Feedback please...
Last edited by TIG on Fri Aug 06, 2010 10:26 am, edited 1 time in total.
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby ilac » Wed Aug 04, 2010 10:43 pm

ilac Wed Aug 04, 2010 10:43 pm
It works, icons and all! :)

Thanks! :)
[email protected] - 4GB || Geforce GTX 470 - 1240GB || Win XP 32 sp3
ilac
Licensed Customer
Licensed Customer
 
Posts: 28
Joined: Sat May 29, 2010 6:19 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby TIG » Wed Aug 04, 2010 11:02 pm

TIG Wed Aug 04, 2010 11:02 pm
Your wish is my command... ;)
Different OSs can have slightly different Ruby versions etc... I have now made a 'cast-iron' version: although it did work for the vast majority before, it did rely on Ruby's kind nature in finding the files in the same folder as to script - which of course it usually did - but now there is no doubt as it's been 'hard-coded' !
Hopefully this will 'cut of at the pass' any further bug reports about this mini-glitch... :roll:
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby Burkhard » Thu Aug 05, 2010 3:46 pm

Burkhard Thu Aug 05, 2010 3:46 pm
Hi TIG, what is the second Icon for? ;)
Attachments
icon.png
icon.png (6.38 KiB) Viewed 2437 times
MacPro Quad * 8Gig RAM * GTX 285 Mac Edition ( delete two GT120 to make it run with octane! ) * Snow Leopard 10.6
Burkhard
Licensed Customer
Licensed Customer
 
Posts: 142
Joined: Mon Jan 25, 2010 7:53 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby vizfellas » Thu Aug 05, 2010 4:27 pm

vizfellas Thu Aug 05, 2010 4:27 pm
Hi TIG thx a lot it works perfect :shock:
Vista 64 bit|GeForce GTX 260|Duo 3Ghz|8 Gb
vizfellas
Licensed Customer
Licensed Customer
 
Posts: 43
Joined: Tue Jan 12, 2010 9:47 pm
Location: POLAND

Re: Octane Sketchup Exporter - Full 1022-02

Postby TIG » Thu Aug 05, 2010 10:03 pm

TIG Thu Aug 05, 2010 10:03 pm
Burkhard wrote:Hi TIG, what is the second Icon for? ;)

There is NO second icon ! :shock:

You are getting an additional button for some obscure reason :roll: .
Can you hover your cursor over both buttons and see what the tool tip and command line text says for each - also try clicking each one in turn and report what it does...
I do recall a MAC user getting this on another tool ages ago/
Firstly can you please check that you haven't got two versions of some of the Octane stuff loading - perhaps in the two 'Plugins' locations*** - use the README or Help tips to find where your Plugins folder is and thus where the files and sub-folders should be installed -then check you haven't got duplicates of any of them in other places - e.g. perhaps even loose in Plugins or in your personal 'user' folder structure***...

On that one occasion this MAC glitch of an extra blank button was solved thus - change the toolbar from a horizontal to a vertical one and the duplicate button disappears; after a restart it's OK - then changing it again doesn't result in the extra button ??? It seemed to be a MAC OS glitch rather than tool specific... :roll:

PC version =
Capture.PNG
Capture.PNG (3.09 KiB) Viewed 2413 times
MAC version =
Capture1.PNG
Capture1.PNG (2.04 KiB) Viewed 2410 times
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby SurfingAlien » Thu Aug 05, 2010 10:36 pm

SurfingAlien Thu Aug 05, 2010 10:36 pm
Burkhard wrote:Hi TIG, what is the second Icon for? ;)


I just noticed this too (also with the previous version):
- if Octane toolbar is OFF when you start SU and then you activate it via menu it loads fine (one single icon like in my old post for 1022-01)
- if Octane toolbar is On when you start SU it loads the second "fake" button...

not a great problem TIG, it's just to remind you'll never get rid of Mac glitches until our smart Apples know you're a win-only guy :lol:

cheers,
A
MacBookPro unibody 2x2.4GHz | 4Gb | 9400M+9600GT 256Mb | OSX 10.6.8
i7 2600-K @3.4GHz | 8Gb | GTX560Ti 2Gb | Windows7x64 | Octane 1.0 b2.52
SurfingAlien
Licensed Customer
Licensed Customer
 
Posts: 355
Joined: Thu Jan 21, 2010 12:05 am
Location: Italy

Re: Octane Sketchup Exporter - Full 1022-02

Postby TIG » Thu Aug 05, 2010 10:42 pm

TIG Thu Aug 05, 2010 10:42 pm
Weird indeed - have you tried the making it vertical rather than horizontal trick ? :?
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby TIG » Thu Aug 05, 2010 10:53 pm

TIG Thu Aug 05, 2010 10:53 pm
Could you MAC users with this glitch try this alternative .rb file [in this zip]
Octane_1022poss~03.zip
(15.41 KiB) Downloaded 169 times
to go into your ../Plugins/Octane/ folder and replace the 1022-02 version.
If it works it'll form the basis of 1022-03...

Feedback please...
TIG
User avatar
TIG
Licensed Customer
Licensed Customer
 
Posts: 536
Joined: Wed May 12, 2010 1:25 pm

Re: Octane Sketchup Exporter - Full 1022-02

Postby SurfingAlien » Thu Aug 05, 2010 10:56 pm

SurfingAlien Thu Aug 05, 2010 10:56 pm
TIG wrote:Weird indeed - have you tried the making it vertical rather than horizontal trick ? :?


mmm... making it vertical does the trick indeed, while re-making it horizontal takes back the issue again. now this is a good or bad news? :?

BTW, the "fake" button shows no tooltips but I can push it (of course it does nothing)
Attachments
Schermata 2010-08-06 a 00.53.39.png
Schermata 2010-08-06 a 00.53.39.png (8.89 KiB) Viewed 2402 times
MacBookPro unibody 2x2.4GHz | 4Gb | 9400M+9600GT 256Mb | OSX 10.6.8
i7 2600-K @3.4GHz | 8Gb | GTX560Ti 2Gb | Windows7x64 | Octane 1.0 b2.52
SurfingAlien
Licensed Customer
Licensed Customer
 
Posts: 355
Joined: Thu Jan 21, 2010 12:05 am
Location: Italy
Next

Return to SketchUp


Who is online

Users browsing this forum: No registered users and 3 guests

Mon Sep 28, 2020 12:33 am [ UTC ]